aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabrice Fontaine <fontaine.fabrice@gmail.com>2018-12-04 22:38:37 +0100
committerAnthony G. Basile <blueness@gentoo.org>2018-12-04 17:14:32 -0500
commit2cb6b734de901dda6e631de5dffbd4cb8e165cbb (patch)
treed998e21d5abec058db4f507703207a7c6282c928
parentconfigure.ac: bump to version 3.2.7 (diff)
downloadeudev-2cb6b734de901dda6e631de5dffbd4cb8e165cbb.tar.gz
eudev-2cb6b734de901dda6e631de5dffbd4cb8e165cbb.tar.bz2
eudev-2cb6b734de901dda6e631de5dffbd4cb8e165cbb.zip
missing.h: add KEY_ALS_TOGGLE
KEY_ALS_TOGGLE has been added in kernel 4.8 with https://github.com/torvalds/linux/commit/9ee27487127461b5cf71670b708ed5b2b8da568c So add it to missing.h to fix build with kernel older than 4.8 Fixes: - http://autobuild.buildroot.org/results/0c0aff02df91cdb869efa01e397f7ccc0d9f69af Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com> Signed-off-by: Anthony G. Basile <blueness@gentoo.org>
-rw-r--r--src/shared/missing.h4
1 files changed, 4 insertions, 0 deletions
diff --git a/src/shared/missing.h b/src/shared/missing.h
index bebbb42be..b5b2e1194 100644
--- a/src/shared/missing.h
+++ b/src/shared/missing.h
@@ -179,3 +179,7 @@ static inline int name_to_handle_at(int fd, const char *name, struct file_handle
#ifndef INPUT_PROP_MAX
#define INPUT_PROP_MAX 0x1f
#endif
+
+#ifndef KEY_ALS_TOGGLE
+#define KEY_ALS_TOGGLE 0x7a
+#endif