summaryrefslogtreecommitdiff
path: root/g_cran
diff options
context:
space:
mode:
authorAuke Booij (tulcod) <auke@tulcod.com>2010-07-28 22:25:56 +0200
committerAuke Booij (tulcod) <auke@tulcod.com>2010-07-28 22:27:08 +0200
commit434c7e33ef28f671308a2c72729dd17ad50212dd (patch)
treea3cfbfda71ffbdf61a3a03f5e8991c10a5a7c7b6 /g_cran
parentStarting gcommon dev branch... nothing useful here (diff)
downloadg-cran-434c7e33ef28f671308a2c72729dd17ad50212dd.tar.gz
g-cran-434c7e33ef28f671308a2c72729dd17ad50212dd.tar.bz2
g-cran-434c7e33ef28f671308a2c72729dd17ad50212dd.zip
Some actions should work now. Proper configuration not included, stay tuned.
Diffstat (limited to 'g_cran')
-rwxr-xr-xg_cran/cran.ebuild27
-rw-r--r--g_cran/g_cran.py13
2 files changed, 0 insertions, 40 deletions
diff --git a/g_cran/cran.ebuild b/g_cran/cran.ebuild
deleted file mode 100755
index ac4d286..0000000
--- a/g_cran/cran.ebuild
+++ /dev/null
@@ -1,27 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-argv0=${BASH_ARGV[0]}
-this_file=$argv0
-this_dirname=$(/bin/dirname $this_file)
-this_repo="${this_dirname}/../../"
-
-#discover category, package name and version
-cat_pn_pvr=$(echo $this_file|/bin/sed -r 's$.+?/([A-Za-z0-9+_.-]+)/([A-Za-z0-9+_-]+)/\2-([0-9]+(\.[0-9]+)*[a-z]?((_alpha|_beta|_pre|_rc|_p)[0-9]*)*(-r[0-9]*)?)\.ebuild$\1/\2 \3$')
-
-#this reads in metadata from g-cran
-{ while read -r line
-do
- export "$line"
-done
-} < <(/usr/bin/g-cran $this_repo package $cat_pn_pvr || die);
-
-for phase in $GCOMMON_PHASES
-do
- eval "$(printf '%q() { exec_phase %q; }' "$phase" "$phase")"
-done
-
-function exec_phase() {
- /usr/bin/g-cran $this_repo $1 || die
-}
diff --git a/g_cran/g_cran.py b/g_cran/g_cran.py
index 6898109..d005d38 100644
--- a/g_cran/g_cran.py
+++ b/g_cran/g_cran.py
@@ -35,17 +35,6 @@ def list_packages(repo_location):
for package in packages:
print 'dev-R/'+package.ebuild_vars['pn'],package.ebuild_vars['pv']
-#generate a tree of ebuilds... note that we only link ebuild files
-#metadata.xml and Manifest and whatnot is not generated
-def generate_tree(repo_location):
- packages=read_packages(os.path.join(repo_location,REPO_MYDIR,'PACKAGES'),repo_location)
- ebuild_file=os.path.join(os.path.dirname(__file__),'cran.ebuild')
- for package in packages:
- ebuild_dir=os.path.join(repo_location,'dev-R',package.ebuild_vars['pn'])
- if not os.path.exists(ebuild_dir):
- os.makedirs(ebuild_dir)
- os.symlink(ebuild_file,os.path.join(ebuild_dir,package.ebuild_vars['pn']+'-'+package.ebuild_vars['pv']+'.ebuild'))
-
#list package details, in PMS's format
def action_package(repo_location,package_name):
defined_phases=[]
@@ -90,8 +79,6 @@ def main():
list_categories(repo_location)
elif action=='list-packages':
list_packages(repo_location)
- elif action=='generate-tree':
- generate_tree(repo_location)
elif action=='package':
if len(arguments)<3:
print "The 'package' action takes the following parameters:"