aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRafael G. Martins <rafael@rafaelmartins.eng.br>2010-12-18 22:41:10 -0200
committerRafael G. Martins <rafael@rafaelmartins.eng.br>2010-12-18 22:41:10 -0200
commiteeed11eea953c6381a001cfad3adff93563a260b (patch)
tree4c07494aa870b863ba999abddcefa186da2f5dc8 /g-octave
parentrewrote g_octave.ebuild. fixed eclass and tests (diff)
downloadg-octave-eeed11eea953c6381a001cfad3adff93563a260b.tar.gz
g-octave-eeed11eea953c6381a001cfad3adff93563a260b.tar.bz2
g-octave-eeed11eea953c6381a001cfad3adff93563a260b.zip
added new command line interface.
Diffstat (limited to 'g-octave')
-rwxr-xr-xg-octave19
1 files changed, 19 insertions, 0 deletions
diff --git a/g-octave b/g-octave
new file mode 100755
index 0000000..f79da18
--- /dev/null
+++ b/g-octave
@@ -0,0 +1,19 @@
+#!/usr/bin/env python
+# -*- coding: utf-8 -*-
+
+"""
+ g_octave
+ ~~~~~~~~
+
+ g-octave's main script.
+
+ :copyright: (c) 2010 by Rafael Goncalves Martins
+ :license: GPL-2, see LICENSE for more details.
+"""
+
+from g_octave.cli import Cli
+import sys
+
+if __name__ == '__main__':
+ cli = Cli()
+ sys.exit(cli.run())