aboutsummaryrefslogtreecommitdiff
path: root/tests
diff options
context:
space:
mode:
authorRafael G. Martins <rafael@rafaelmartins.eng.br>2010-07-01 02:33:00 -0300
committerRafael G. Martins <rafael@rafaelmartins.eng.br>2010-07-01 02:33:00 -0300
commit4ad07a4e9f86ba2b243169ecf397c097fb9f9698 (patch)
tree30f3fd136e933bf8b96f2c213aaa9a0ea9c5d18f /tests
parentadded support to installation from SVN to the module g_octave.ebuild (diff)
downloadg-octave-4ad07a4e9f86ba2b243169ecf397c097fb9f9698.tar.gz
g-octave-4ad07a4e9f86ba2b243169ecf397c097fb9f9698.tar.bz2
g-octave-4ad07a4e9f86ba2b243169ecf397c097fb9f9698.zip
fixed test suite.
Diffstat (limited to 'tests')
-rw-r--r--tests/files/ebuilds/extra1-0.0.1.ebuild9
-rw-r--r--tests/files/ebuilds/extra2-0.0.1.ebuild9
-rw-r--r--tests/files/ebuilds/language1-0.0.1.ebuild9
-rw-r--r--tests/files/ebuilds/language2-0.0.1.ebuild9
-rw-r--r--tests/files/ebuilds/main1-0.0.1.ebuild9
-rw-r--r--tests/files/ebuilds/main2-0.0.1.ebuild9
-rw-r--r--tests/test_overlay.py4
7 files changed, 33 insertions, 25 deletions
diff --git a/tests/files/ebuilds/extra1-0.0.1.ebuild b/tests/files/ebuilds/extra1-0.0.1.ebuild
index 7853983..9c9c9d8 100644
--- a/tests/files/ebuilds/extra1-0.0.1.ebuild
+++ b/tests/files/ebuilds/extra1-0.0.1.ebuild
@@ -4,11 +4,12 @@
EAPI="3"
-inherit octave-forge eutils
+G_OCTAVE_CAT="extra"
+
+inherit g-octave eutils
DESCRIPTION="This is the Extra 1 description"
HOMEPAGE="http://extra1.org"
-SRC_URI="mirror://sourceforge/octave/${OCT_P}.tar.gz"
LICENSE="|| ( GPL-2 GPL-3 LGPL BSD GFDL )"
SLOT="0"
@@ -20,9 +21,9 @@ IUSE=""
RESTRICT="mirror"
DEPEND=">sci-mathematics/pkg4-1.0.0
- >=sci-mathematics/pkg1-4.3.2
+ sci-mathematics/pkg3
<sci-mathematics/pkg2-1.2.3
- sci-mathematics/pkg3"
+ >=sci-mathematics/pkg1-4.3.2"
RDEPEND="${DEPEND}
>=sci-mathematics/octave-3.2.0"
diff --git a/tests/files/ebuilds/extra2-0.0.1.ebuild b/tests/files/ebuilds/extra2-0.0.1.ebuild
index 812dfc7..64f8b3d 100644
--- a/tests/files/ebuilds/extra2-0.0.1.ebuild
+++ b/tests/files/ebuilds/extra2-0.0.1.ebuild
@@ -4,11 +4,12 @@
EAPI="3"
-inherit octave-forge
+G_OCTAVE_CAT="extra"
+
+inherit g-octave
DESCRIPTION="This is the Extra 2 description"
HOMEPAGE="http://extra2.org"
-SRC_URI="mirror://sourceforge/octave/${OCT_P}.tar.gz"
LICENSE="|| ( GPL-2 GPL-3 LGPL BSD GFDL )"
SLOT="0"
@@ -20,8 +21,8 @@ IUSE=""
RESTRICT="mirror"
DEPEND=">sci-mathematics/pkg8-1.0.0
- >=sci-mathematics/pkg5-4.3.2
+ sci-mathematics/pkg7
<sci-mathematics/pkg6-1.2.3
- sci-mathematics/pkg7"
+ >=sci-mathematics/pkg5-4.3.2"
RDEPEND="${DEPEND}
>=sci-mathematics/octave-3.2.0"
diff --git a/tests/files/ebuilds/language1-0.0.1.ebuild b/tests/files/ebuilds/language1-0.0.1.ebuild
index da9f6e5..44872f9 100644
--- a/tests/files/ebuilds/language1-0.0.1.ebuild
+++ b/tests/files/ebuilds/language1-0.0.1.ebuild
@@ -4,11 +4,12 @@
EAPI="3"
-inherit octave-forge eutils
+G_OCTAVE_CAT="language"
+
+inherit g-octave eutils
DESCRIPTION="This is the Language 1 description"
HOMEPAGE="http://language1.org"
-SRC_URI="mirror://sourceforge/octave/${OCT_P}.tar.gz"
LICENSE="|| ( GPL-2 GPL-3 LGPL BSD GFDL )"
SLOT="0"
@@ -20,9 +21,9 @@ IUSE=""
RESTRICT="mirror"
DEPEND=">sci-mathematics/pkg4-1.0.0
- >=sci-mathematics/pkg1-4.3.2
+ sci-mathematics/pkg3
<sci-mathematics/pkg2-1.2.3
- sci-mathematics/pkg3"
+ >=sci-mathematics/pkg1-4.3.2"
RDEPEND="${DEPEND}
>=sci-mathematics/octave-3.2.0"
diff --git a/tests/files/ebuilds/language2-0.0.1.ebuild b/tests/files/ebuilds/language2-0.0.1.ebuild
index 3eacb41..a8b7f94 100644
--- a/tests/files/ebuilds/language2-0.0.1.ebuild
+++ b/tests/files/ebuilds/language2-0.0.1.ebuild
@@ -4,11 +4,12 @@
EAPI="3"
-inherit octave-forge
+G_OCTAVE_CAT="language"
+
+inherit g-octave
DESCRIPTION="This is the Language 2 description"
HOMEPAGE="http://language2.org"
-SRC_URI="mirror://sourceforge/octave/${OCT_P}.tar.gz"
LICENSE="|| ( GPL-2 GPL-3 LGPL BSD GFDL )"
SLOT="0"
@@ -20,8 +21,8 @@ IUSE=""
RESTRICT="mirror"
DEPEND=">sci-mathematics/pkg8-1.0.0
- >=sci-mathematics/pkg5-4.3.2
+ sci-mathematics/pkg7
<sci-mathematics/pkg6-1.2.3
- sci-mathematics/pkg7"
+ >=sci-mathematics/pkg5-4.3.2"
RDEPEND="${DEPEND}
>=sci-mathematics/octave-3.2.0"
diff --git a/tests/files/ebuilds/main1-0.0.1.ebuild b/tests/files/ebuilds/main1-0.0.1.ebuild
index 4a78dc7..d0284ab 100644
--- a/tests/files/ebuilds/main1-0.0.1.ebuild
+++ b/tests/files/ebuilds/main1-0.0.1.ebuild
@@ -4,11 +4,12 @@
EAPI="3"
-inherit octave-forge eutils
+G_OCTAVE_CAT="main"
+
+inherit g-octave eutils
DESCRIPTION="This is the Main 1 description"
HOMEPAGE="http://main1.org"
-SRC_URI="mirror://sourceforge/octave/${OCT_P}.tar.gz"
LICENSE="|| ( GPL-2 GPL-3 LGPL BSD GFDL )"
SLOT="0"
@@ -20,9 +21,9 @@ IUSE=""
RESTRICT="mirror"
DEPEND=">sci-mathematics/pkg4-1.0.0
- >=sci-mathematics/pkg1-4.3.2
+ sci-mathematics/pkg3
<sci-mathematics/pkg2-1.2.3
- sci-mathematics/pkg3"
+ >=sci-mathematics/pkg1-4.3.2"
RDEPEND="${DEPEND}
>=sci-mathematics/octave-3.0.0"
diff --git a/tests/files/ebuilds/main2-0.0.1.ebuild b/tests/files/ebuilds/main2-0.0.1.ebuild
index f89d3b1..fc931b0 100644
--- a/tests/files/ebuilds/main2-0.0.1.ebuild
+++ b/tests/files/ebuilds/main2-0.0.1.ebuild
@@ -4,11 +4,12 @@
EAPI="3"
-inherit octave-forge
+G_OCTAVE_CAT="main"
+
+inherit g-octave
DESCRIPTION="This is the Main 2 description"
HOMEPAGE="http://main2.org"
-SRC_URI="mirror://sourceforge/octave/${OCT_P}.tar.gz"
LICENSE="|| ( GPL-2 GPL-3 LGPL BSD GFDL )"
SLOT="0"
@@ -20,8 +21,8 @@ IUSE=""
RESTRICT="mirror"
DEPEND=">sci-mathematics/pkg8-1.0.0
- >=sci-mathematics/pkg5-4.3.2
+ sci-mathematics/pkg7
<sci-mathematics/pkg6-1.2.3
- sci-mathematics/pkg7"
+ >=sci-mathematics/pkg5-4.3.2"
RDEPEND="${DEPEND}
>=sci-mathematics/octave-3.2.0"
diff --git a/tests/test_overlay.py b/tests/test_overlay.py
index 9ac7d2d..6a480c1 100644
--- a/tests/test_overlay.py
+++ b/tests/test_overlay.py
@@ -26,7 +26,6 @@ class TestOverlay(unittest.TestCase):
def test_overlay(self):
overlay.create_overlay(conf = self._config, quiet = True)
files = {
- os.path.join(self._config.overlay, 'eclass', 'octave-forge.eclass'): '',
os.path.join(self._config.overlay, 'profiles', 'repo_name'): 'g-octave',
os.path.join(self._config.overlay, 'profiles', 'categories'): 'g-octave',
}
@@ -34,6 +33,9 @@ class TestOverlay(unittest.TestCase):
self.assertTrue(os.path.exists(_file))
with open(_file) as fp:
self.assertEqual(fp.read(), files[_file])
+ self.assertTrue(os.path.islink(
+ os.path.join(self._config.overlay, 'eclass', 'g-octave.eclass')
+ ))
def tearDown(self):
utils.clean_env(self._config_file, self._dir)