summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAzamat H. Hackimov <azamat.hackimov@gmail.com>2018-12-01 17:24:33 +0300
committerAzamat H. Hackimov <azamat.hackimov@gmail.com>2018-12-01 18:40:47 +0300
commit430df1cbd2e1dd2ef345572772a8f415a3680c64 (patch)
treef3dda38450003e4abd4c9c8775b83a4bffb427bd
parentgames-sports/stuntrally: fix build for gcc6 (diff)
downloadgamerlay-430df1cbd2e1dd2ef345572772a8f415a3680c64.tar.gz
gamerlay-430df1cbd2e1dd2ef345572772a8f415a3680c64.tar.bz2
gamerlay-430df1cbd2e1dd2ef345572772a8f415a3680c64.zip
games-sports/stuntrally: additional fixes
Added media-libs/libsdl2[haptic] dep, build bundled libraries statically Signed-off-by: Azamat H. Hackimov <azamat.hackimov@gmail.com> Package-Manager: Portage-2.3.51, Repoman-2.3.11
-rw-r--r--games-sports/stuntrally/stuntrally-2.6.ebuild18
-rw-r--r--games-sports/stuntrally/stuntrally-9999.ebuild18
2 files changed, 20 insertions, 16 deletions
diff --git a/games-sports/stuntrally/stuntrally-2.6.ebuild b/games-sports/stuntrally/stuntrally-2.6.ebuild
index 49d0882..06b7065 100644
--- a/games-sports/stuntrally/stuntrally-2.6.ebuild
+++ b/games-sports/stuntrally/stuntrally-2.6.ebuild
@@ -12,7 +12,7 @@ HOMEPAGE="http://stuntrally.tuxfamily.org/"
SLOT="0"
LICENSE="GPL-3"
-IUSE="dedicated +game editor static-libs"
+IUSE="dedicated +game editor"
if [[ ${PV} = 9999* ]]; then
SRC_URI=""
@@ -24,11 +24,11 @@ else
SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tgz"
fi
-RDEPEND="
+DEPEND="
game? (
dev-games/ogre[cg,boost,ois,freeimage,opengl,zip,-double-precision]
dev-games/mygui[ogre]
- media-libs/libsdl2
+ media-libs/libsdl2[haptic]
media-libs/libvorbis
media-libs/libogg
media-libs/openal
@@ -38,7 +38,9 @@ RDEPEND="
net-libs/enet:1.3
virtual/libstdc++
"
-DEPEND="${RDEPEND}"
+RDEPEND="${DEPEND}
+ ~games-sports/stuntrally-tracks-${PV}
+"
PDEPEND="${LIVE_PDEPEND}"
REQUIRED_USE="editor? ( game )"
@@ -51,10 +53,10 @@ DOCS=(Readme.txt)
src_configure() {
local mycmakeargs=(
- -DBUILD_MASTER_SERVER=$(usex dedicated ON OFF)
- -DBUILD_GAME=$(usex game ON OFF)
- -DBUILD_EDITOR=$(usex editor ON OFF)
- -DBUILD_SHARED_LIBS=$(usex !static-libs ON OFF)
+ -DBUILD_MASTER_SERVER=$(usex dedicated)
+ -DBUILD_GAME=$(usex game)
+ -DBUILD_EDITOR=$(usex editor)
+ -DBUILD_SHARED_LIBS=OFF
)
cmake-utils_src_configure
}
diff --git a/games-sports/stuntrally/stuntrally-9999.ebuild b/games-sports/stuntrally/stuntrally-9999.ebuild
index 13fa61b..6e9d7bf 100644
--- a/games-sports/stuntrally/stuntrally-9999.ebuild
+++ b/games-sports/stuntrally/stuntrally-9999.ebuild
@@ -12,7 +12,7 @@ HOMEPAGE="http://stuntrally.tuxfamily.org/"
SLOT="0"
LICENSE="GPL-3"
-IUSE="dedicated +game editor static-libs"
+IUSE="dedicated +game editor"
if [[ ${PV} = 9999* ]]; then
SRC_URI=""
@@ -24,11 +24,11 @@ else
SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tgz"
fi
-RDEPEND="
+DEPEND="
game? (
dev-games/ogre[cg,boost,ois,freeimage,opengl,zip,-double-precision]
dev-games/mygui[ogre]
- media-libs/libsdl2
+ media-libs/libsdl2[haptic]
media-libs/libvorbis
media-libs/libogg
media-libs/openal
@@ -38,7 +38,9 @@ RDEPEND="
net-libs/enet:1.3
virtual/libstdc++
"
-DEPEND="${RDEPEND}"
+RDEPEND="${DEPEND}
+ ~games-sports/stuntrally-tracks-${PV}
+"
PDEPEND="${LIVE_PDEPEND}"
REQUIRED_USE="editor? ( game )"
@@ -47,10 +49,10 @@ DOCS=(Readme.txt)
src_configure() {
local mycmakeargs=(
- -DBUILD_MASTER_SERVER=$(usex dedicated ON OFF)
- -DBUILD_GAME=$(usex game ON OFF)
- -DBUILD_EDITOR=$(usex editor ON OFF)
- -DBUILD_SHARED_LIBS=$(usex !static-libs ON OFF)
+ -DBUILD_MASTER_SERVER=$(usex dedicated)
+ -DBUILD_GAME=$(usex game)
+ -DBUILD_EDITOR=$(usex editor)
+ -DBUILD_SHARED_LIBS=OFF
)
cmake-utils_src_configure
}