summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAzamat H. Hackimov <azamat.hackimov@gmail.com>2020-02-29 01:35:59 +0300
committerAzamat H. Hackimov <azamat.hackimov@gmail.com>2020-02-29 01:35:59 +0300
commit27b2aca82659aaf2920a76a30d93f27bf022e444 (patch)
tree8336dd3bff63434220a50694194e2cec7299baea /games-arcade
parentgames-arcade/funkysmugglers: update package (diff)
downloadgamerlay-27b2aca82659aaf2920a76a30d93f27bf022e444.tar.gz
gamerlay-27b2aca82659aaf2920a76a30d93f27bf022e444.tar.bz2
gamerlay-27b2aca82659aaf2920a76a30d93f27bf022e444.zip
games-arcade/sleepwalker: update ebuild
Migrate from deprecated eclass. Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Azamat H. Hackimov <azamat.hackimov@gmail.com>
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/sleepwalker/sleepwalker-20130613.ebuild54
1 files changed, 20 insertions, 34 deletions
diff --git a/games-arcade/sleepwalker/sleepwalker-20130613.ebuild b/games-arcade/sleepwalker/sleepwalker-20130613.ebuild
index 4d7a04e..832020d 100644
--- a/games-arcade/sleepwalker/sleepwalker-20130613.ebuild
+++ b/games-arcade/sleepwalker/sleepwalker-20130613.ebuild
@@ -1,50 +1,39 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-EAPI="5"
+EAPI=7
-inherit unpacker games
+inherit desktop eutils multilib-minimal unpacker
-DESCRIPTION="Guide a hero safely through various traps, clear obstructions from his path, and shift his surroundings to create a safe passage to the cozy bed."
+DESCRIPTION="Guide a hero safely through various traps, clear obstructions from his path."
HOMEPAGE="http://www.11bitstudios.com/games/12/sleepwalker-s-journey"
# Is it non-HiB distfile?
SRC_URI="Sleepwalker-lin_1371139237-Installer"
RESTRICT="fetch strip"
-LICENSE="as-is"
+LICENSE="all-rights-reserved"
SLOT="0"
KEYWORDS="-* ~amd64 ~x86"
IUSE="multilib"
-DEPEND=""
+DEPEND="app-arch/unzip"
RDEPEND="
- x86? (
- media-libs/openal
- x11-libs/libdrm
- x11-libs/libX11
- x11-libs/libXau
- x11-libs/libxcb
- x11-libs/libXdamage
- x11-libs/libXdmcp
- x11-libs/libXext
- x11-libs/libXfixes
- x11-libs/libXxf86vm
- )
- amd64? (
- app-emulation/emul-linux-x86-xlibs
- app-emulation/emul-linux-x86-opengl
- app-emulation/emul-linux-x86-sdl
- )
+ media-libs/openal[${MULTILIB_USEDEP}]
+ x11-libs/libdrm[${MULTILIB_USEDEP}]
+ x11-libs/libX11[${MULTILIB_USEDEP}]
+ x11-libs/libXau[${MULTILIB_USEDEP}]
+ x11-libs/libxcb[${MULTILIB_USEDEP}]
+ x11-libs/libXdamage[${MULTILIB_USEDEP}]
+ x11-libs/libXdmcp[${MULTILIB_USEDEP}]
+ x11-libs/libXext[${MULTILIB_USEDEP}]
+ x11-libs/libXfixes[${MULTILIB_USEDEP}]
+ x11-libs/libXxf86vm[${MULTILIB_USEDEP}]
virtual/opengl
- app-arch/unzip
"
-REQUIRED_USE="amd64? ( multilib )"
-
-S="${WORKDIR}"
+S="${WORKDIR}/data"
src_unpack() {
- unpack_zip "${A}"
+ unpack_zip ${A}
}
pkg_nofetch() {
@@ -54,12 +43,11 @@ pkg_nofetch() {
}
src_install() {
- cd "${S}/data"
- local dir="${GAMES_PREFIX_OPT}/${PN}"
+ local dir="/opt/${PN}"
newicon "icon.png" "${PN}.png"
make_desktop_entry "${PN}" "Sleepwalker" "${PN}"
- games_make_wrapper "${PN}" "./Sleepwalker" "${dir}"
+ make_wrapper "${PN}" "./Sleepwalker" "${dir}"
dodoc README
exeinto "${dir}"
doexe "Sleepwalker"
@@ -73,6 +61,4 @@ src_install() {
"Copyright license Xpm"
insinto "${dir}"
doins -r .
-
- prepgamesdirs
}