summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcel Unbehaun <frostworks@gmx.de>2010-03-23 15:23:29 +0100
committerMarcel Unbehaun <frostworks@gmx.de>2010-03-23 15:23:29 +0100
commitb392d34da1e19d0962c01723874299365b417056 (patch)
treea0d5d23eba5b1dfe7a49424419148cc67431befd /x11-apps
parent[games-misc/openmsx] Do not depend on unix2dos (diff)
downloadgamerlay-b392d34da1e19d0962c01723874299365b417056.tar.gz
gamerlay-b392d34da1e19d0962c01723874299365b417056.tar.bz2
gamerlay-b392d34da1e19d0962c01723874299365b417056.zip
[x11-apps/typhon] version bump - typhon-0.72.ebuild
[x11-apps/typhon] new Manifest
Diffstat (limited to 'x11-apps')
-rw-r--r--x11-apps/typhon/Manifest2
-rw-r--r--x11-apps/typhon/typhon-0.72.ebuild62
2 files changed, 64 insertions, 0 deletions
diff --git a/x11-apps/typhon/Manifest b/x11-apps/typhon/Manifest
index a62b542..1e7f572 100644
--- a/x11-apps/typhon/Manifest
+++ b/x11-apps/typhon/Manifest
@@ -1,3 +1,5 @@
DIST typhon-0.71.tar.bz2 48789 RMD160 06aae0b267b4cdd4ecee477196bab6c307a511fb SHA1 7661085ff96aedbf75464353ffd7519acfb90a79 SHA256 2698c91f4788d3c036cae1048b822688e86c37adbd7d5d20e504e821fc9e416b
+DIST typhon-0.72.tar.bz2 51290 RMD160 b563c8c00b1891edec3672733082951d69e2d595 SHA1 eb0faef4f160d48b1c27366e306d0a248f014702 SHA256 d4a835293395f95239be3129362ae187e011c4223b22d0866d36d13cea343bcf
EBUILD typhon-0.71.ebuild 1561 RMD160 c64d75121c010f7e2654638ad0f7232e45756ff4 SHA1 f84c87cd9fe0d7a569e8c757d0dce08b609d53fe SHA256 c331f3bebde7d21ebd1032c2adaa01b811425e3035952009e859b28923cb07ee
+EBUILD typhon-0.72.ebuild 1574 RMD160 bb0499dab0a2f0c60fa09c5e71d90dc45e39c848 SHA1 2ad310c651e83b42e6bd31c8e0c5adeb0679af42 SHA256 1b05c7c5483d8b6ee411efaa7320a52373245898c0a1699adb9193d02200b206
MISC metadata.xml 495 RMD160 a23a4e534107aea1572abd6635397ef7757e6b99 SHA1 1654772438c526ae0468a0a21afd831559f55f6e SHA256 321720d7d59e11c5da72e78ef55f1a73bde4db320ee24cee7910e9ac43420d83
diff --git a/x11-apps/typhon/typhon-0.72.ebuild b/x11-apps/typhon/typhon-0.72.ebuild
new file mode 100644
index 0000000..fc4051a
--- /dev/null
+++ b/x11-apps/typhon/typhon-0.72.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: x11-apps/typhontyphon-0.71.ebuild,v 1.0 2010/03/16 10:37:45 by frostwork Exp $
+
+EAPI="2"
+
+inherit eutils
+
+DESCRIPTION="A slim and themeable opengl dashboard / program launcher"
+HOMEPAGE="http://www.frostworx.de/programs/typhon.html"
+SRC_URI="http://www.frostworx.de/typhon/${P/_/-}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+emu sdl fmod glut png debug"
+
+S="${WORKDIR}/${P/_/-}/src"
+
+RDEPEND="media-libs/ftgl
+ virtual/opengl
+ glut? ( media-libs/freeglut )
+ png? ( media-libs/glpng )
+ sdl? ( media-libs/sdl-mixer )
+ fmod? ( =media-libs/fmod-3* )"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ if use sdl && use fmod ; then
+ ewarn "both sdl and fmod useflag not possible!"
+ die "disable fmod useflag in favour of sdl-mixer"
+ fi
+ if use fmod; then
+ echo "SOUNDFLAGS = -DFMOD -DSOUND" >> Makefile
+ echo "SOUNDLIBS = -lfmod" >> Makefile
+ fi
+ if use sdl; then
+ echo "SOUNDFLAGS = -DSDLMIXER -DSOUND `sdl-config --cflags`" >> Makefile
+ echo "SOUNDLIBS = `sdl-config --libs` -lSDL_mixer" >> Makefile
+ fi
+ if use glut; then
+ echo "GLUTFLAGS = -DGLUT" >> Makefile
+ echo "GLUTLIBS = -lglut" >> Makefile
+ fi
+ if use png; then
+ echo "PICFLAGS = -DPNG" >> Makefile
+ echo "PICLIBS = -lglpng" >> Makefile
+ fi
+ if use debug; then
+ echo "DEBUGFLAGS = -g" >> Makefile
+ fi
+ if use emu; then
+ echo "EMUFLAGS = -DEMU" >> Makefile
+ fi
+}
+
+src_install() {
+ dobin ../${PN}
+ newicon ../${PN}.png ${PN}.png
+ make_desktop_entry ${PN} ${PN}
+ dodoc ../README
+}