summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-strategy/revenge-of-the-titans/revenge-of-the-titans-1.80.20-r1.ebuild')
-rw-r--r--games-strategy/revenge-of-the-titans/revenge-of-the-titans-1.80.20-r1.ebuild45
1 files changed, 20 insertions, 25 deletions
diff --git a/games-strategy/revenge-of-the-titans/revenge-of-the-titans-1.80.20-r1.ebuild b/games-strategy/revenge-of-the-titans/revenge-of-the-titans-1.80.20-r1.ebuild
index f80df78..59de6ff 100644
--- a/games-strategy/revenge-of-the-titans/revenge-of-the-titans-1.80.20-r1.ebuild
+++ b/games-strategy/revenge-of-the-titans/revenge-of-the-titans-1.80.20-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-inherit desktop eutils java-pkg-2
+inherit desktop wrapper java-pkg-2
MY_PN=RevengeOfTheTitans
# Divide second subversion by 10, i.e. 1.80.10 => 1810
@@ -12,40 +12,35 @@ MY_PV=$(ver_rs 1-2 "")
DESCRIPTION="Defeat the returning Titan horde in a series of epic ground battles."
HOMEPAGE="http://www.puppygames.net/revenge-of-the-titans/"
-SRC_URI="hib? (
+SRC_URI="
amd64? ( ${MY_PN}-HIB-${MY_PV}-amd64.tar.gz )
x86? ( ${MY_PN}-HIB-${MY_PV}-i386.tar.gz ) )
- !hib? (
- amd64? ( http://d4ec1k3inlcla.cloudfront.net/${MY_PN}-amd64.tar.gz -> ${P}-amd64.tar.gz )
- x86? ( http://d4ec1k3inlcla.cloudfront.net/${MY_PN}-i386.tar.gz -> ${P}-i386.tar.gz ) )"
-
+"
LICENSE="all-rights-reserved"
SLOT="0"
-KEYWORDS="-* ~amd64 ~x86"
-IUSE="hib"
+KEYWORDS="~amd64 ~x86"
-RDEPEND=">=virtual/jre-1.6
- virtual/opengl"
-DEPEND=""
+RDEPEND="
+ >=virtual/jre-1.6
+ virtual/opengl
+"
-RESTRICT="mirror strip"
+RESTRICT="fetch mirror strip"
dir="/opt/${MY_PN}"
S="${WORKDIR}/revengeofthetitans"
pkg_nofetch() {
- if use hib ; then
- local TARBALL
- if use amd64 ; then
- TARBALL="${MY_PN}-HIB-${MY_PV}-amd64.tar.gz"
- fi
- if use x86 ; then
- TARBALL="${MY_PN}-HIB-${MY_PV}-i386.tar.gz"
- fi
- einfo "Please download ${TARBALL}"
- einfo "from your personal page in Humble Indie Bundle #2 site"
- einfo "(http://www.humblebundle.com) and place it in ${DISTDIR}"
+ local TARBALL
+ if use amd64 ; then
+ TARBALL="${MY_PN}-HIB-${MY_PV}-amd64.tar.gz"
+ fi
+ if use x86 ; then
+ TARBALL="${MY_PN}-HIB-${MY_PV}-i386.tar.gz"
fi
+ einfo "Please download ${TARBALL}"
+ einfo "from your personal page in Humble Indie Bundle site"
+ einfo "(http://www.humblebundle.com) and place it in ${DISTDIR}"
}
# nothing to do ... stubs for eclasses