aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-05-07 10:57:26 +0100
committerSam James <sam@gentoo.org>2024-05-07 10:57:41 +0100
commitf525de00d17a460aebb382c0d34529ddc383fb9d (patch)
tree136b4363aee7a5701f42b7253fd86947441732c4 /14.1.0/gentoo/14_all_respect-build-cxxflags.patch
parentvalidate_failures.py: fix python 3.12 escape sequence warnings (diff)
downloadgcc-patches-f525de00d17a460aebb382c0d34529ddc383fb9d.tar.gz
gcc-patches-f525de00d17a460aebb382c0d34529ddc383fb9d.tar.bz2
gcc-patches-f525de00d17a460aebb382c0d34529ddc383fb9d.zip
14.1.0: init
Clone of 14.0.0. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to '14.1.0/gentoo/14_all_respect-build-cxxflags.patch')
-rw-r--r--14.1.0/gentoo/14_all_respect-build-cxxflags.patch39
1 files changed, 39 insertions, 0 deletions
diff --git a/14.1.0/gentoo/14_all_respect-build-cxxflags.patch b/14.1.0/gentoo/14_all_respect-build-cxxflags.patch
new file mode 100644
index 0000000..1f9a774
--- /dev/null
+++ b/14.1.0/gentoo/14_all_respect-build-cxxflags.patch
@@ -0,0 +1,39 @@
+Pass CXXFLAGS as CXXFLAGS_FOR_BUILD to stage1.
+
+Fixes build failure when CXXFLAGS contains
+TARGET-specific flags.
+
+Tested on x86_64-pc-linux-gnu host as:
+ # CFLAGS='-O2 -mfpu=neon-vfpv4' CXXFLAGS='-O2 -mfpu=neon-vfpv4' \
+ armv7a-unknown-linux-gnueabihf-emerge -v1 sys-devel/gcc --quiet-build=n
+
+Fix by Peter Levine.
+https://bugs.gentoo.org/581406
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -176,6 +176,7 @@
+ # built for the build system to override those in BASE_FLAGS_TO_PASS.
+ EXTRA_BUILD_FLAGS = \
+ CFLAGS="$(CFLAGS_FOR_BUILD)" \
++ CXXFLAGS="$(CXXFLAGS_FOR_BUILD)" \
+ LDFLAGS="$(LDFLAGS_FOR_BUILD)"
+
+ # This is the list of directories to built for the host system.
+@@ -842,6 +843,7 @@
+ "CC_FOR_BUILD=$(CC_FOR_BUILD)" \
+ "CFLAGS_FOR_BUILD=$(CFLAGS_FOR_BUILD)" \
+ "CXX_FOR_BUILD=$(CXX_FOR_BUILD)" \
++ "CXXFLAGS_FOR_BUILD=$(CXXFLAGS_FOR_BUILD)" \
+ "EXPECT=$(EXPECT)" \
+ "FLEX=$(FLEX)" \
+ "INSTALL=$(INSTALL)" \
+--- a/Makefile.tpl
++++ b/Makefile.tpl
+@@ -179,6 +179,7 @@
+ # built for the build system to override those in BASE_FLAGS_TO_PASS.
+ EXTRA_BUILD_FLAGS = \
+ CFLAGS="$(CFLAGS_FOR_BUILD)" \
++ CXXFLAGS="$(CXXFLAGS_FOR_BUILD)" \
+ LDFLAGS="$(LDFLAGS_FOR_BUILD)"
+
+ # This is the list of directories to built for the host system.