aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-02-08 01:09:01 +0000
committerSam James <sam@gentoo.org>2023-02-08 01:09:01 +0000
commit19c4c47cef978f07b4a605aa772f4478751d2e63 (patch)
tree66dc7f10404de4d87a071bed0cefac52ea831e05
parent8.5.0: add 33_all_msgfmt-libstdc++-link.patch (diff)
downloadgcc-patches-19c4c47cef978f07b4a605aa772f4478751d2e63.tar.gz
gcc-patches-19c4c47cef978f07b4a605aa772f4478751d2e63.tar.bz2
gcc-patches-19c4c47cef978f07b4a605aa772f4478751d2e63.zip
9.5.0: add 31_all_msgfmt-libstdc++-link.patch
Bug: https://bugs.gentoo.org/892816 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--9.5.0/gentoo/31_all_msgfmt-libstdc++-link.patch39
-rw-r--r--9.5.0/gentoo/README.history3
2 files changed, 42 insertions, 0 deletions
diff --git a/9.5.0/gentoo/31_all_msgfmt-libstdc++-link.patch b/9.5.0/gentoo/31_all_msgfmt-libstdc++-link.patch
new file mode 100644
index 0000000..0d2f113
--- /dev/null
+++ b/9.5.0/gentoo/31_all_msgfmt-libstdc++-link.patch
@@ -0,0 +1,39 @@
+Ensure that msgfmt doesn't encounter problems during gcc bootstrapping.
+
+Solves error messages like the following:
+
+msgfmt: /var/tmp/portage/sys-devel/gcc-4.1.2/work/build/./gcc/libgcc_s.so.1: version `GCC_4.2.0' not found (required by /usr/lib/gcc/x86_64-pc-linux-gnu/4.5.3/libstdc++.so.6)
+
+The libgcc_s.so used during build doesn't satisfy the needs of the
+libstdc++.so that msgfmt is linked against. On the other hand, msgfmt
+is used as a stand-alone application here, and what library it uses
+behind the scenes is of no concern to the gcc build process.
+Therefore, simply invoking it "as usual", i.e. without any special
+library path, will make it work as expected here.
+
+2011-09-19 Martin von Gagern
+
+References:
+https://bugs.gentoo.org/372377
+https://bugs.gentoo.org/295480
+https://bugs.gentoo.org/843119
+--- a/libstdc++-v3/po/Makefile.am
++++ b/libstdc++-v3/po/Makefile.am
+@@ -39,6 +39,7 @@ MSGFMT = msgfmt
+ EXTRA_DIST = string_literals.cc POTFILES.in $(PACKAGE).pot $(LOCALE_IN)
+
+ .po.mo:
++ env --unset=LD_LIBRARY_PATH \
+ $(MSGFMT) -o $@ $<
+
+ all-local: all-local-$(USE_NLS)
+--- a/libstdc++-v3/po/Makefile.in
++++ b/libstdc++-v3/po/Makefile.in
+@@ -419,6 +419,7 @@ uninstall-am: uninstall-info-am
+
+
+ .po.mo:
++ env --unset=LD_LIBRARY_PATH \
+ $(MSGFMT) -o $@ $<
+
+ all-local: all-local-$(USE_NLS)
diff --git a/9.5.0/gentoo/README.history b/9.5.0/gentoo/README.history
index a5308d6..a084063 100644
--- a/9.5.0/gentoo/README.history
+++ b/9.5.0/gentoo/README.history
@@ -1,3 +1,6 @@
+2 08 Feb 202
+ + 31_all_msgfmt-libstdc++-link.patch
+
1 15 Aug 2022
+ 01_all_default-fortify-source.patch
+ 02_all_default-warn-format-security.patch