aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-12-17 07:27:58 +0000
committerSam James <sam@gentoo.org>2022-12-17 07:27:58 +0000
commitebe8be7dd3772238844454283aa6f3c716cce657 (patch)
tree5a474fde18f9b59aae1efd552e39c4c04d4c0f4b
parent13.1.0: add 30_all_tar_libstdc++-link.patch (diff)
downloadgcc-patches-ebe8be7dd3772238844454283aa6f3c716cce657.tar.gz
gcc-patches-ebe8be7dd3772238844454283aa6f3c716cce657.tar.bz2
gcc-patches-ebe8be7dd3772238844454283aa6f3c716cce657.zip
10.5.0/11.4.0/12.2.0/13.1.0: update libarchive/bsdtar patch
Bug: https://bugs.gentoo.org/886447 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--10.5.0/gentoo/35_all_tar_libstdc++-link.patch15
-rw-r--r--10.5.0/gentoo/README.history3
-rw-r--r--11.4.0/gentoo/29_all_tar_libstdc++-link.patch13
-rw-r--r--11.4.0/gentoo/README.history3
-rw-r--r--12.2.0/gentoo/30_all_tar_libstdc++-link.patch13
-rw-r--r--12.2.0/gentoo/README.history3
-rw-r--r--13.1.0/gentoo/30_all_tar_libstdc++-link.patch13
-rw-r--r--13.1.0/gentoo/README.history3
8 files changed, 44 insertions, 22 deletions
diff --git a/10.5.0/gentoo/35_all_tar_libstdc++-link.patch b/10.5.0/gentoo/35_all_tar_libstdc++-link.patch
index 7b1132e..5e1a154 100644
--- a/10.5.0/gentoo/35_all_tar_libstdc++-link.patch
+++ b/10.5.0/gentoo/35_all_tar_libstdc++-link.patch
@@ -31,19 +31,22 @@ https://bugs.gentoo.org/843119
Signed-off-by: Sam James <sam@gentoo.org>
--- a/gcc/Makefile.in
+++ b/gcc/Makefile.in
-@@ -3835,9 +3835,9 @@ install-headers-tar: stmp-int-hdrs install-include-dir
+@@ -3833,10 +3833,10 @@ install-headers-tar: stmp-int-hdrs install-include-dir
# Unless a full pathname is provided, some shells would print the new CWD,
# found in CDPATH, corrupting the output. We could just redirect the
# output of `cd', but some shells lose on redirection within `()'s
- (cd `${PWD_COMMAND}`/include ; \
-+ (unset LD_LIBRARY_PATH ; cd `${PWD_COMMAND}`/include ; \
- tar -cf - .; exit 0) | (cd $(DESTDIR)$(libsubdir)/include; tar xpf - )
+- tar -cf - .; exit 0) | (cd $(DESTDIR)$(libsubdir)/include; tar xpf - )
- (cd `${PWD_COMMAND}`/include-fixed ; \
+- tar -cf - .; exit 0) | (cd $(DESTDIR)$(libsubdir)/include-fixed; tar xpf - )
++ (unset LD_LIBRARY_PATH ; cd `${PWD_COMMAND}`/include ; \
++ tar -cf - .; exit 0) | (unset LD_LIBRARY_PATH ; cd $(DESTDIR)$(libsubdir)/include; tar xpf - )
+ (unset LD_LIBRARY_PATH ; cd `${PWD_COMMAND}`/include-fixed ; \
- tar -cf - .; exit 0) | (cd $(DESTDIR)$(libsubdir)/include-fixed; tar xpf - )
++ tar -cf - .; exit 0) | (unset LD_LIBRARY_PATH ; cd $(DESTDIR)$(libsubdir)/include-fixed; tar xpf - )
# /bin/sh on some systems returns the status of the first tar,
# and that can lose with GNU tar which always writes a full block.
-@@ -3859,7 +3859,7 @@ install-headers-cp: stmp-int-hdrs install-include-dir
+ # So use `exit 0' to ignore its exit status.
+@@ -3857,7 +3857,7 @@ install-headers-cp: stmp-int-hdrs install-include-dir
# Targets without dependencies, for use in prev-gcc during bootstrap.
real-install-headers-tar:
(cd `${PWD_COMMAND}`/include-fixed ; \
@@ -52,5 +55,3 @@ Signed-off-by: Sam James <sam@gentoo.org>
real-install-headers-cpio:
cd `${PWD_COMMAND}`/include-fixed ; \
---
-2.39.0
diff --git a/10.5.0/gentoo/README.history b/10.5.0/gentoo/README.history
index 29abddb..db63084 100644
--- a/10.5.0/gentoo/README.history
+++ b/10.5.0/gentoo/README.history
@@ -1,3 +1,6 @@
+3 17 Dec 2022
+ U 35_all_tar_libstdc++-link.patch
+
2 17 Dec 2022
+ 35_all_tar_libstdc++-link.patch
diff --git a/11.4.0/gentoo/29_all_tar_libstdc++-link.patch b/11.4.0/gentoo/29_all_tar_libstdc++-link.patch
index 678efc5..680ab38 100644
--- a/11.4.0/gentoo/29_all_tar_libstdc++-link.patch
+++ b/11.4.0/gentoo/29_all_tar_libstdc++-link.patch
@@ -31,19 +31,22 @@ https://bugs.gentoo.org/843119
Signed-off-by: Sam James <sam@gentoo.org>
--- a/gcc/Makefile.in
+++ b/gcc/Makefile.in
-@@ -3904,9 +3904,9 @@ install-headers-tar: stmp-int-hdrs install-include-dir
+@@ -3902,10 +3902,10 @@ install-headers-tar: stmp-int-hdrs install-include-dir
# Unless a full pathname is provided, some shells would print the new CWD,
# found in CDPATH, corrupting the output. We could just redirect the
# output of `cd', but some shells lose on redirection within `()'s
- (cd `${PWD_COMMAND}`/include ; \
-+ (unset LD_LIBRARY_PATH ; cd `${PWD_COMMAND}`/include ; \
- tar -cf - .; exit 0) | (cd $(DESTDIR)$(libsubdir)/include; tar xpf - )
+- tar -cf - .; exit 0) | (cd $(DESTDIR)$(libsubdir)/include; tar xpf - )
- (cd `${PWD_COMMAND}`/include-fixed ; \
+- tar -cf - .; exit 0) | (cd $(DESTDIR)$(libsubdir)/include-fixed; tar xpf - )
++ (unset LD_LIBRARY_PATH ; cd `${PWD_COMMAND}`/include ; \
++ tar -cf - .; exit 0) | (unset LD_LIBRARY_PATH ; cd $(DESTDIR)$(libsubdir)/include; tar xpf - )
+ (unset LD_LIBRARY_PATH ; cd `${PWD_COMMAND}`/include-fixed ; \
- tar -cf - .; exit 0) | (cd $(DESTDIR)$(libsubdir)/include-fixed; tar xpf - )
++ tar -cf - .; exit 0) | (unset LD_LIBRARY_PATH ; cd $(DESTDIR)$(libsubdir)/include-fixed; tar xpf - )
# /bin/sh on some systems returns the status of the first tar,
# and that can lose with GNU tar which always writes a full block.
-@@ -3928,7 +3928,7 @@ install-headers-cp: stmp-int-hdrs install-include-dir
+ # So use `exit 0' to ignore its exit status.
+@@ -3926,7 +3926,7 @@ install-headers-cp: stmp-int-hdrs install-include-dir
# Targets without dependencies, for use in prev-gcc during bootstrap.
real-install-headers-tar:
(cd `${PWD_COMMAND}`/include-fixed ; \
diff --git a/11.4.0/gentoo/README.history b/11.4.0/gentoo/README.history
index fc526c2..c799994 100644
--- a/11.4.0/gentoo/README.history
+++ b/11.4.0/gentoo/README.history
@@ -1,3 +1,6 @@
+5 17 Dec 2022
+ U 29_all_tar_libstdc++-link.patch
+
4 17 Dec 2022
+ 35_all_tar_libstdc++-link.patch
diff --git a/12.2.0/gentoo/30_all_tar_libstdc++-link.patch b/12.2.0/gentoo/30_all_tar_libstdc++-link.patch
index ab654e9..149d614 100644
--- a/12.2.0/gentoo/30_all_tar_libstdc++-link.patch
+++ b/12.2.0/gentoo/30_all_tar_libstdc++-link.patch
@@ -31,19 +31,22 @@ https://bugs.gentoo.org/843119
Signed-off-by: Sam James <sam@gentoo.org>
--- a/gcc/Makefile.in
+++ b/gcc/Makefile.in
-@@ -3936,9 +3936,9 @@ install-headers-tar: stmp-int-hdrs install-include-dir
+@@ -3934,10 +3934,10 @@ install-headers-tar: stmp-int-hdrs install-include-dir
# Unless a full pathname is provided, some shells would print the new CWD,
# found in CDPATH, corrupting the output. We could just redirect the
# output of `cd', but some shells lose on redirection within `()'s
- (cd `${PWD_COMMAND}`/include ; \
-+ (unset LD_LIBRARY_PATH ; cd `${PWD_COMMAND}`/include ; \
- tar -cf - .; exit 0) | (cd $(DESTDIR)$(libsubdir)/include; tar xpf - )
+- tar -cf - .; exit 0) | (cd $(DESTDIR)$(libsubdir)/include; tar xpf - )
- (cd `${PWD_COMMAND}`/include-fixed ; \
+- tar -cf - .; exit 0) | (cd $(DESTDIR)$(libsubdir)/include-fixed; tar xpf - )
++ (unset LD_LIBRARY_PATH ; cd `${PWD_COMMAND}`/include ; \
++ tar -cf - .; exit 0) | (unset LD_LIBRARY_PATH ; cd $(DESTDIR)$(libsubdir)/include; tar xpf - )
+ (unset LD_LIBRARY_PATH ; cd `${PWD_COMMAND}`/include-fixed ; \
- tar -cf - .; exit 0) | (cd $(DESTDIR)$(libsubdir)/include-fixed; tar xpf - )
++ tar -cf - .; exit 0) | (unset LD_LIBRARY_PATH ; cd $(DESTDIR)$(libsubdir)/include-fixed; tar xpf - )
# /bin/sh on some systems returns the status of the first tar,
# and that can lose with GNU tar which always writes a full block.
-@@ -3960,7 +3960,7 @@ install-headers-cp: stmp-int-hdrs install-include-dir
+ # So use `exit 0' to ignore its exit status.
+@@ -3958,7 +3958,7 @@ install-headers-cp: stmp-int-hdrs install-include-dir
# Targets without dependencies, for use in prev-gcc during bootstrap.
real-install-headers-tar:
(cd `${PWD_COMMAND}`/include-fixed ; \
diff --git a/12.2.0/gentoo/README.history b/12.2.0/gentoo/README.history
index ee29c5e..9d111f5 100644
--- a/12.2.0/gentoo/README.history
+++ b/12.2.0/gentoo/README.history
@@ -1,3 +1,6 @@
+6 17 Dec 2022
+ U 30_all_tar_libstdc++-link.patch
+
5 17 Dec 2022
+ 30_all_tar_libstdc++-link.patch
diff --git a/13.1.0/gentoo/30_all_tar_libstdc++-link.patch b/13.1.0/gentoo/30_all_tar_libstdc++-link.patch
index 3dd94f8..adb414a 100644
--- a/13.1.0/gentoo/30_all_tar_libstdc++-link.patch
+++ b/13.1.0/gentoo/30_all_tar_libstdc++-link.patch
@@ -31,19 +31,22 @@ https://bugs.gentoo.org/843119
Signed-off-by: Sam James <sam@gentoo.org>
--- a/gcc/Makefile.in
+++ b/gcc/Makefile.in
-@@ -3957,9 +3957,9 @@ install-headers-tar: stmp-int-hdrs install-include-dir
+@@ -3955,10 +3955,10 @@ install-headers-tar: stmp-int-hdrs install-include-dir
# Unless a full pathname is provided, some shells would print the new CWD,
# found in CDPATH, corrupting the output. We could just redirect the
# output of `cd', but some shells lose on redirection within `()'s
- (cd `${PWD_COMMAND}`/include ; \
-+ (unset LD_LIBRARY_PATH ; cd `${PWD_COMMAND}`/include ; \
- tar -cf - .; exit 0) | (cd $(DESTDIR)$(libsubdir)/include; tar xpf - )
+- tar -cf - .; exit 0) | (cd $(DESTDIR)$(libsubdir)/include; tar xpf - )
- (cd `${PWD_COMMAND}`/include-fixed ; \
+- tar -cf - .; exit 0) | (cd $(DESTDIR)$(libsubdir)/include-fixed; tar xpf - )
++ (unset LD_LIBRARY_PATH ; cd `${PWD_COMMAND}`/include ; \
++ tar -cf - .; exit 0) | (unset LD_LIBRARY_PATH ; cd $(DESTDIR)$(libsubdir)/include; tar xpf - )
+ (unset LD_LIBRARY_PATH ; cd `${PWD_COMMAND}`/include-fixed ; \
- tar -cf - .; exit 0) | (cd $(DESTDIR)$(libsubdir)/include-fixed; tar xpf - )
++ tar -cf - .; exit 0) | (unset LD_LIBRARY_PATH ; cd $(DESTDIR)$(libsubdir)/include-fixed; tar xpf - )
# /bin/sh on some systems returns the status of the first tar,
# and that can lose with GNU tar which always writes a full block.
-@@ -3981,7 +3981,7 @@ install-headers-cp: stmp-int-hdrs install-include-dir
+ # So use `exit 0' to ignore its exit status.
+@@ -3979,7 +3979,7 @@ install-headers-cp: stmp-int-hdrs install-include-dir
# Targets without dependencies, for use in prev-gcc during bootstrap.
real-install-headers-tar:
(cd `${PWD_COMMAND}`/include-fixed ; \
diff --git a/13.1.0/gentoo/README.history b/13.1.0/gentoo/README.history
index b56b51e..43b714e 100644
--- a/13.1.0/gentoo/README.history
+++ b/13.1.0/gentoo/README.history
@@ -1,3 +1,6 @@
+5 17 Dec 2022
+ U 30_all_tar_libstdc++-link.patch
+
4 17 Dec 2022
+ 30_all_tar_libstdc++-link.patch