aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2018-09-30 17:44:40 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2018-09-30 17:44:40 +0100
commitf4cf8c88325985c2bc2ffe7d4828b410b73732ce (patch)
tree6c3f5713e70dfa858b148c110dbe71a221f90642
parent3.4.6: expand 'struct ucontext' to 'ucontext_t' rename in glibc (diff)
downloadgcc-patches-f4cf8c88325985c2bc2ffe7d4828b410b73732ce.tar.gz
gcc-patches-f4cf8c88325985c2bc2ffe7d4828b410b73732ce.tar.bz2
gcc-patches-f4cf8c88325985c2bc2ffe7d4828b410b73732ce.zip
3.3.6: fix stage1 bulding against modern toolchain
One new patche: - 91_all_libexec-gcc-binutils.patch: add /usr/libexec/gcc/<TARGET> to search path Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
-rw-r--r--3.3.6/gentoo/91_all_libexec-gcc-binutils.patch61
-rw-r--r--3.3.6/gentoo/README.history1
2 files changed, 62 insertions, 0 deletions
diff --git a/3.3.6/gentoo/91_all_libexec-gcc-binutils.patch b/3.3.6/gentoo/91_all_libexec-gcc-binutils.patch
new file mode 100644
index 0000000..8e0e774
--- /dev/null
+++ b/3.3.6/gentoo/91_all_libexec-gcc-binutils.patch
@@ -0,0 +1,61 @@
+Before gcc-3.4 gcc libraries and searched executables
+were in /usr/lib/gcc-lib/<TARGET> (STANDARD_EXEC_PREFIX)
+
+After gcc-3.4 the split happened:
+- /usr/lib/gcc/<TARGET> for libraries (STARDARD_EXEC_PREFIX)
+- /usr/libexec/gcc/<TARGET> for executables (STANDARD_LIBEXEC_PREFIX)
+
+This patch adds STANDARD_LIBEXEC_PREFIX to allow bootstrapping
+on 3.4+-only system.
+--- a/gcc/Makefile.in
++++ b/gcc/Makefile.in
+@@ -323,8 +323,13 @@ exec_prefix = @exec_prefix@
+ bindir = @bindir@
+ # Directory in which to put the directories used by the compiler.
+ libdir = @libdir@
++# Directory in which GCC puts its executables.
++libexecdir = @libexecdir@
++
+ # Directory in which the compiler finds executables, libraries, etc.
+ libsubdir = $(libdir)/gcc-lib/$(target_alias)/$(version)
++# Directory in which the compiler finds executables
++libexecsubdir = $(libexecdir)/gcc/$(target_alias)/$(version)
+ # Used to produce a relative $(gcc_tooldir) in gcc.o
+ unlibsubdir = ../../..
+ # Directory in which to find other cross-compilation tools and headers.
+@@ -726,6 +731,7 @@ ORDINARY_FLAGS_TO_PASS = \
+ "gcc_tooldir=$(gcc_tooldir)" \
+ "bindir=$(bindir)" \
+ "libsubdir=$(libsubdir)" \
++ "libexecsubdir=$(libsubdir)" \
+ "datadir=$(datadir)" \
+ "localedir=$(localedir)"
+ FLAGS_TO_PASS = $(ORDINARY_FLAGS_TO_PASS) "CC=@cc_set_by_configure@" \
+@@ -1297,6 +1303,7 @@ c-dump.o : c-dump.c $(CONFIG_H) $(SYSTEM_H) $(TREE_H) $(C_TREE_H) tree-dump.h
+ DRIVER_DEFINES = \
+ -DSTANDARD_STARTFILE_PREFIX=\"$(unlibsubdir)/\" \
+ -DSTANDARD_EXEC_PREFIX=\"$(libdir)/gcc-lib/\" \
++ -DSTANDARD_LIBEXEC_PREFIX=\"$(libexecdir)/gcc/\" \
+ -DDEFAULT_TARGET_VERSION=\"$(version)\" \
+ -DDEFAULT_TARGET_MACHINE=\"$(target_alias)\" \
+ -DSTANDARD_BINDIR_PREFIX=\"$(bindir)/\" \
+--- a/gcc/gcc.c
++++ b/gcc/gcc.c
+@@ -1346,6 +1346,8 @@ static const char *const standard_exec_prefix = STANDARD_EXEC_PREFIX;
+ static const char *const standard_exec_prefix_1 = "/usr/lib/gcc/";
+ static const char *md_exec_prefix = MD_EXEC_PREFIX;
+
++static const char *standard_libexec_prefix = STANDARD_LIBEXEC_PREFIX;
++
+ static const char *md_startfile_prefix = MD_STARTFILE_PREFIX;
+ static const char *md_startfile_prefix_1 = MD_STARTFILE_PREFIX_1;
+ static const char *const standard_startfile_prefix = STANDARD_STARTFILE_PREFIX;
+@@ -3718,6 +3720,8 @@ warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.\n\n"
+ PREFIX_PRIORITY_LAST, 2, warn_std_ptr, 0);
+ add_prefix (&exec_prefixes, standard_exec_prefix_1, "BINUTILS",
+ PREFIX_PRIORITY_LAST, 2, warn_std_ptr, 0);
++ add_prefix (&exec_prefixes, standard_libexec_prefix, "BINUTILS",
++ PREFIX_PRIORITY_LAST, 2, warn_std_ptr, 0);
+ #endif
+
+ add_prefix (&startfile_prefixes, standard_exec_prefix, "BINUTILS",
diff --git a/3.3.6/gentoo/README.history b/3.3.6/gentoo/README.history
index 8cf625a..dc6baaf 100644
--- a/3.3.6/gentoo/README.history
+++ b/3.3.6/gentoo/README.history
@@ -1,6 +1,7 @@
1.10 TODO
+ 89_all_gcc-3.3.x-ucontext.patch
+ 90_all_libtool-pass-all.patch
+ + 91_all_libexec-gcc-binutils.patch
1.9 06 Apr 2015
R 05_all_gcc-4.3.x-siginfo.patch -> 05_all_gcc-3.3.x-siginfo.patch