aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authoragaffney <agaffney@kagome.(none)>2008-11-12 22:25:22 -0600
committeragaffney <agaffney@kagome.(none)>2008-11-12 22:25:22 -0600
commit4e38e4d39b988097e5322350d1f007984b101de3 (patch)
treed6c5cd571de20409072137bacd78f104d098440e
parentanother try at compiling unionfs-fuse (diff)
downloadgenkernel-4e38e4d39b988097e5322350d1f007984b101de3.tar.gz
genkernel-4e38e4d39b988097e5322350d1f007984b101de3.tar.bz2
genkernel-4e38e4d39b988097e5322350d1f007984b101de3.zip
Add -L line into LIB= in Makefile
-rw-r--r--ChangeLog3
-rw-r--r--gen_compile.sh1
2 files changed, 4 insertions, 0 deletions
diff --git a/ChangeLog b/ChangeLog
index 8237fcc..c90476d 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -3,6 +3,9 @@
# Distributed under the GPL v2
13 Nov 2008; Andrew Gaffney <agaffney@gentoo.org> gen_compile.sh:
+ Add -L line into LIB= in Makefile
+
+ 13 Nov 2008; Andrew Gaffney <agaffney@gentoo.org> gen_compile.sh:
Unpack fuse source and modify CFLAGS for unionfs-fuse
12 Nov 2008; Andrew Gaffney <agaffney@gentoo.org> gen_compile.sh,
diff --git a/gen_compile.sh b/gen_compile.sh
index 1cd854a..87cc28e 100644
--- a/gen_compile.sh
+++ b/gen_compile.sh
@@ -568,6 +568,7 @@ compile_unionfs_fuse() {
# cd ..
print_info 1 'unionfs-fuse: >> Compiling...'
sed -i "/^\(CFLAGS\|CPPFLAGS\)/s:^\\(.*\\)$:\\1 -I${TEMP}/${FUSE_DIR}/include -L${TEMP}/${FUSE_DIR}/lib/.libs:" Makefile src/Makefile
+ sed -i "/^LIB = /s:^LIB = \(.*\)$:LIB = -L${TEMP}/${FUSE_DIR}/lib/.libs \1:" Makefile src/Makefile
cat Makefile src/Makefile
bash
MAKE=${UTILS_MAKE} compile_generic "" ""