aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2019-07-14 10:19:08 +0200
committerThomas Deutschmann <whissi@gentoo.org>2019-07-14 13:58:14 +0200
commitcbd8468428a7305f71fa02c94158b2a128da7a4e (patch)
tree49b31bd1c8c4547236cc25457f59488fb73d8021 /gen_compile.sh
parentRework --gpg support (diff)
downloadgenkernel-cbd8468428a7305f71fa02c94158b2a128da7a4e.tar.gz
genkernel-cbd8468428a7305f71fa02c94158b2a128da7a4e.tar.bz2
genkernel-cbd8468428a7305f71fa02c94158b2a128da7a4e.zip
Rework --unionfs support
Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'gen_compile.sh')
-rwxr-xr-xgen_compile.sh68
1 files changed, 0 insertions, 68 deletions
diff --git a/gen_compile.sh b/gen_compile.sh
index 590c26f..22c2b76 100755
--- a/gen_compile.sh
+++ b/gen_compile.sh
@@ -745,74 +745,6 @@ compile_device_mapper() {
compile_lvm
}
-compile_fuse() {
- [ ! -f "${FUSE_SRCTAR}" ] &&
- gen_die "Could not find fuse source tarball: ${FUSE_SRCTAR}. Please place it there, or place another version, changing /etc/genkernel.conf as necessary!"
- cd "${TEMP}"
- rm -rf "${FUSE_DIR}" > /dev/null
- /bin/tar -xpf "${FUSE_SRCTAR}" ||
- gen_die 'Could not extract fuse source tarball!'
- [ ! -d "${FUSE_DIR}" ] &&
- gen_die "fuse directory ${FUSE_DIR} is invalid"
-
- cd "${FUSE_DIR}"
- apply_patches fuse ${FUSE_VER}
-
- print_info 1 "$(getIndent 2)fuse: >> Configuring ..."
- ./configure --disable-example >> ${LOGFILE} 2>&1 ||
- gen_die 'Configuring fuse failed!'
-
- print_info 1 "$(getIndent 2)fuse: >> Compiling ..."
- compile_generic '' utils || gen_die "failed to build fuse"
-}
-
-compile_unionfs_fuse() {
- if [ -f "${UNIONFS_FUSE_BINCACHE}" ]
- then
- print_info 1 "$(getIndent 2)unionfs-fuse: Using cache ..."
- else
- # We'll call compile_fuse() from here, since it's not needed directly by anything else
- compile_fuse
-
- [ ! -f "${UNIONFS_FUSE_SRCTAR}" ] &&
- gen_die "Could not find unionfs-fuse source tarball: ${UNIONFS_FUSE_SRCTAR}. Please place it there, or place another version, changing /etc/genkernel.conf as necessary!"
- cd "${TEMP}"
- rm -rf "${UNIONFS_FUSE_DIR}" > /dev/null
- tar -xpf "${UNIONFS_FUSE_SRCTAR}" ||
- gen_die 'Could not extract unionfs-fuse source tarball!'
- [ ! -d "${UNIONFS_FUSE_DIR}" ] &&
- gen_die "unionfs-fuse directory ${UNIONFS_FUSE_DIR} is invalid"
-
- cd "${UNIONFS_FUSE_DIR}"
- apply_patches unionfs-fuse ${UNIONFS_FUSE_VER}
-
- print_info 1 "$(getIndent 2)unionfs-fuse: >> Preparing ..."
- FUSE_CFLAGS="-I${TEMP}/${FUSE_DIR}/include -D_FILE_OFFSET_BITS=64" # pkg-config --cflags fuse
- FUSE_LIBS="-L${TEMP}/${FUSE_DIR}/lib/.libs -lfuse -pthread -ldl" # pkg-config --static --libs fuse
- sed -i \
- -e "s|\$(shell pkg-config --cflags fuse)|${FUSE_CFLAGS}|g" \
- -e "s|\$(shell pkg-config --libs fuse)|-static ${FUSE_LIBS}|g" \
- src/Makefile || gen_die "Failed to adjust unionfs-fuse Makefile"
-
- print_info 1 "$(getIndent 2)unionfs-fuse: >> Compiling ..."
- compile_generic '' utils || gen_die "failed to build unionfs-fuse"
-
- print_info 1 "$(getIndent 2)unionfs-fuse: >> Copying to bincache ..."
- [ -f "${TEMP}/${UNIONFS_FUSE_DIR}/src/unionfs" ] ||
- gen_die 'unionfs binary does not exist!'
- ${UTILS_CROSS_COMPILE}strip "${TEMP}/${UNIONFS_FUSE_DIR}/src/unionfs" ||
- gen_die 'Could not strip unionfs binary!'
- bzip2 "${TEMP}/${UNIONFS_FUSE_DIR}/src/unionfs" ||
- gen_die 'bzip2 compression of unionfs binary failed!'
- mv "${TEMP}/${UNIONFS_FUSE_DIR}/src/unionfs.bz2" "${UNIONFS_FUSE_BINCACHE}" ||
- gen_die 'Could not copy the unionfs binary to the package directory, does the directory exist?'
-
- cd "${TEMP}"
- isTrue "${CMD_DEBUGCLEANUP}" && rm -rf "${FUSE_DIR}" "${UNIONFS_FUSE_DIR}" > /dev/null
- return 0
- fi
-}
-
compile_iscsi() {
compile_iscsi_isns