aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authoragaffney <agaffney@kagome.(none)>2008-11-13 11:03:03 -0600
committeragaffney <agaffney@kagome.(none)>2008-11-13 11:03:03 -0600
commite4f3b17b3afa6af5719c633ea7982de81996eebe (patch)
tree7ead7418f510eaee1830b6409790d363cc526f71 /gen_compile.sh
parentMake sure that /sbin/unionfs is +x (diff)
downloadgenkernel-e4f3b17b3afa6af5719c633ea7982de81996eebe.tar.gz
genkernel-e4f3b17b3afa6af5719c633ea7982de81996eebe.tar.bz2
genkernel-e4f3b17b3afa6af5719c633ea7982de81996eebe.zip
Compile unionfs-fuse statically
Diffstat (limited to 'gen_compile.sh')
-rw-r--r--gen_compile.sh2
1 files changed, 1 insertions, 1 deletions
diff --git a/gen_compile.sh b/gen_compile.sh
index e10ad77..2c3787f 100644
--- a/gen_compile.sh
+++ b/gen_compile.sh
@@ -564,7 +564,7 @@ compile_unionfs_fuse() {
cd "${UNIONFS_FUSE_DIR}"
print_info 1 'unionfs-fuse: >> Compiling...'
sed -i "/^\(CFLAGS\|CPPFLAGS\)/s:^\\(.*\\)$:\\1 -I${TEMP}/${FUSE_DIR}/include -L${TEMP}/${FUSE_DIR}/lib/.libs:" Makefile src/Makefile
- sed -i "/^LIB = /s:^LIB = \(.*\)$:LIB = -L${TEMP}/${FUSE_DIR}/lib/.libs \1:" Makefile src/Makefile
+ sed -i "/^LIB = /s:^LIB = \(.*\)$:LIB = -static -ldl -lrt -L${TEMP}/${FUSE_DIR}/lib/.libs \1:" Makefile src/Makefile
MAKE=${UTILS_MAKE} compile_generic "" ""
print_info 1 'unionfs-fuse: >> Copying to cache...'
[ -f "${TEMP}/${UNIONFS_FUSE_DIR}/src/unionfs" ] ||