aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rwxr-xr-xgen_compile.sh7
-rw-r--r--patches/iscsi/2.0-872/open-iscsi-2.0.872-omg-calling-configure.patch11
-rw-r--r--patches/iscsi/2.0-872/open-iscsi-2.0.872-slp.patch11
3 files changed, 28 insertions, 1 deletions
diff --git a/gen_compile.sh b/gen_compile.sh
index b60b921..00b5de9 100755
--- a/gen_compile.sh
+++ b/gen_compile.sh
@@ -685,10 +685,15 @@ compile_iscsi() {
gen_die "ISCSI directory ${ISCSI_DIR} invalid"
print_info 1 'iSCSI: >> Compiling...'
cd "${TEMP}/${ISCSI_DIR}"
+ apply_patches iscsi ${ISCSI_VER}
# Only build userspace
+ print_info 1 'iSCSI: >> Configuring userspace...'
+ cd utils/open-isns || gen_die 'Could not enter open-isns dir'
+ ./configure --without-slp >> ${LOGFILE} 2>&1 || gen_die 'Could not configure userspace'
+ cd ../.. || gen_die 'wtf?'
MAKE=${UTILS_MAKE} compile_generic "user" ""
-
+
# if kernel modules exist, copy them to initramfs, otherwise it will be compiled into the kernel
mkdir -p "${TEMP}/initramfs-iscsi-temp/lib/modules/${RELEASE}/kernel/drivers/scsi/"
for modname in iscsi_tcp libiscsi scsi_transport_iscsi
diff --git a/patches/iscsi/2.0-872/open-iscsi-2.0.872-omg-calling-configure.patch b/patches/iscsi/2.0-872/open-iscsi-2.0.872-omg-calling-configure.patch
new file mode 100644
index 0000000..185f1ac
--- /dev/null
+++ b/patches/iscsi/2.0-872/open-iscsi-2.0.872-omg-calling-configure.patch
@@ -0,0 +1,11 @@
+--- open-iscsi-2.0-872.orig/Makefile
++++ open-iscsi-2.0-872/Makefile
+@@ -27,7 +27,7 @@ IFACEFILES = etc/iface.example
+ all: user kernel
+
+ user: ;
+- cd utils/open-isns; ./configure; $(MAKE)
++ cd utils/open-isns; $(MAKE)
+ $(MAKE) -C utils/sysdeps
+ $(MAKE) -C utils/fwparam_ibft
+ $(MAKE) -C usr
diff --git a/patches/iscsi/2.0-872/open-iscsi-2.0.872-slp.patch b/patches/iscsi/2.0-872/open-iscsi-2.0.872-slp.patch
new file mode 100644
index 0000000..16658f3
--- /dev/null
+++ b/patches/iscsi/2.0-872/open-iscsi-2.0.872-slp.patch
@@ -0,0 +1,11 @@
+--- open-iscsi-2.0-872.orig/utils/open-isns/configure.ac
++++ open-iscsi-2.0-872/utils/open-isns/configure.ac
+@@ -79,7 +79,7 @@ AC_ARG_WITH(slp,
+ WITH_SLP=$withval
+ else
+ WITH_SLP=yes
+- CPPFLAGS="$CPPFLAGS -I${withval}"
++ CPPFLAGS="$CPPFLAGS -I${withval} -lslp"
+ LDFLAGS="$LDFLAGS -L${withval}"
+ fi
+ ]