aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 0a339e3..207f7cf 100644
--- a/Makefile
+++ b/Makefile
@@ -45,7 +45,11 @@ distclean: clean
# Generic rules
%/generated-config: %/arch-config $(BASE_KCONF) merge.pl Makefile
- grep -sq THIS_CONFIG_IS_BROKEN $< && cat $< >$@ || grep -sq perl merge.pl $< $(BASE_KCONF) > $@
+ if grep -sq THIS_CONFIG_IS_BROKEN $< ; then \
+ cat $< >$@ ; \
+ else \
+ perl merge.pl $< $(BASE_KCONF) > $@ ; \
+ fi ;
%.8: doc/%.8.txt doc/asciidoc.conf Makefile genkernel
a2x --conf-file=doc/asciidoc.conf --attribute="genkernelversion=$(PACKAGE_VERSION)" \