aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'patches/open-iscsi/2.1.4/open-iscsi-2.1.4-Makefiles.patch')
-rw-r--r--patches/open-iscsi/2.1.4/open-iscsi-2.1.4-Makefiles.patch99
1 files changed, 99 insertions, 0 deletions
diff --git a/patches/open-iscsi/2.1.4/open-iscsi-2.1.4-Makefiles.patch b/patches/open-iscsi/2.1.4/open-iscsi-2.1.4-Makefiles.patch
new file mode 100644
index 0000000..2488b73
--- /dev/null
+++ b/patches/open-iscsi/2.1.4/open-iscsi-2.1.4-Makefiles.patch
@@ -0,0 +1,99 @@
+--- a/libopeniscsiusr/Makefile
++++ b/libopeniscsiusr/Makefile
+@@ -23,7 +23,7 @@ endif
+ INCLUDE_DIR ?= $(prefix)/include
+ PKGCONF_DIR ?= $(LIB_DIR)/pkgconfig
+
+-PKG_CONFIG = /usr/bin/pkg-config
++PKG_CONFIG ?= pkg-config
+
+ LIBISCSI_USR_DIR=$(TOPDIR)/libopeniscsiusr
+
+@@ -45,17 +45,18 @@ EXTRA_MAN_FILES = libopeniscsiusr.h.3
+ OBJS = context.o misc.o session.o sysfs.o iface.o idbm.o node.o default.o
+
+ CFLAGS ?= -O2 -g
+-CFLAGS += -Wall -Werror -Wextra -fvisibility=hidden -fPIC
++CFLAGS += -Wextra -fvisibility=hidden -fPIC
+ CFLAGS += $(shell $(PKG_CONFIG) --cflags libkmod)
+
+ LDFLAGS += $(shell $(PKG_CONFIG) --libs libkmod)
+
+ LIBADD =
+
+-all: $(LIBS) $(LIBS_MAJOR) $(TESTS) doc
++all: $(LIBS) $(LIBS_MAJOR)
+
+ $(LIBS): $(OBJS)
+ @echo CFLAGS= $(CFLAGS)
++ $(AR) $(ARFLAGS) libopeniscsiusr.a $^
+ $(CC) $(CFLAGS) -shared -Wl,-soname=$@ -o $@ $(OBJS) $(LDFLAGS) $(LIBADD)
+ ln -sf $@ $(DEVLIB)
+
+--- a/usr/Makefile
++++ b/usr/Makefile
+@@ -32,7 +32,7 @@ IPC_OBJ=ioctl.o
+ endif
+ endif
+
+-PKG_CONFIG = /usr/bin/pkg-config
++PKG_CONFIG ?= pkg-config
+
+ CFLAGS ?= -O2 -g
+ WARNFLAGS ?= -Wall -Wextra -Werror -Wstrict-prototypes -fno-common
+@@ -78,9 +78,9 @@ iscsistart: $(ISCSI_LIB_SRCS) $(INITIATOR_SRCS) $(FW_BOOT_SRCS) \
+ iscsistart.o statics.o
+ $(CC) $(CFLAGS) $^ -o $@ -lcrypto -lrt $(LDFLAGS) $(ISCSI_LIB)
+ clean:
+- rm -f *.o $(PROGRAMS) .depend $(LIBSYS)
++ $(RM) *.o $(PROGRAMS) .depend $(LIBSYS)
+
+ depend:
+- gcc $(CFLAGS) -M `ls *.c` > .depend
++ $(CC) $(CFLAGS) -M `ls *.c` > .depend
+
+ -include .depend
+--- a/utils/Makefile
++++ b/utils/Makefile
+@@ -10,9 +10,9 @@ iscsi-iname: md5.o iscsi-iname.o
+ $(CC) $(CFLAGS) $(LDFLAGS) $^ $(DBM_LIB) -o $@
+
+ clean:
+- rm -f *.o $(PROGRAMS) .depend
++ $(RM) *.o $(PROGRAMS) .depend
+
+ depend:
+- gcc $(CFLAGS) -M `ls *.c` > .depend
++ $(CC) $(CFLAGS) -M `ls *.c` > .depend
+
+ -include .depend
+--- a/utils/fwparam_ibft/Makefile
++++ b/utils/fwparam_ibft/Makefile
+@@ -41,11 +41,11 @@ LDFLAGS += -L$(TOPDIR)/libopeniscsiusr -liscsiusr
+ all: $(OBJS)
+
+ clean:
+- rm -f *.o $(CLEANFILES) .depend
++ $(RM) *.o $(CLEANFILES) .depend
+
+ $(OBJS): prom_parse.tab.h prom_parse.h fwparam_ibft.h
+
+ depend:
+- gcc $(CFLAGS) -M `ls *.c` > .depend
++ $(CC) $(CFLAGS) -M `ls *.c` > .depend
+
+ -include .depend
+--- a/utils/sysdeps/Makefile
++++ b/utils/sysdeps/Makefile
+@@ -8,9 +8,9 @@ SYSDEPS_OBJS=sysdeps.o
+ all: $(SYSDEPS_OBJS)
+
+ clean:
+- rm -f *.o .depend
++ $(RM) *.o .depend
+
+ depend:
+- gcc $(CFLAGS) -M `ls *.c` > .depend
++ $(CC) $(CFLAGS) -M `ls *.c` > .depend
+
+ -include .depend