summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Ruppert <idl0r@gentoo.org>2012-02-15 03:16:07 +0100
committerChristian Ruppert <idl0r@gentoo.org>2012-02-15 03:16:07 +0100
commit83e767fc1d59776c8a36af4f58d1afd0756fefb3 (patch)
treecf3f7f0d6c19a193dd4597e0e319182b8ada865f /Makefile
parentbug 311441: fix revdep-rebuild completion, by Martin von Gagern (diff)
downloadgentoo-bashcomp-83e767fc1d59776c8a36af4f58d1afd0756fefb3.tar.gz
gentoo-bashcomp-83e767fc1d59776c8a36af4f58d1afd0756fefb3.tar.bz2
gentoo-bashcomp-83e767fc1d59776c8a36af4f58d1afd0756fefb3.zip
Make the dist and tag target git compatible
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile18
1 files changed, 9 insertions, 9 deletions
diff --git a/Makefile b/Makefile
index 8d6f04b..62f4ea7 100644
--- a/Makefile
+++ b/Makefile
@@ -18,19 +18,19 @@ install:
"$(DESTDIR)/etc/bash_completion.d/gentoo"
tag:
- svn up ../
- svn cp ../trunk ../tags/release-$(distver)
+ git pull
+ git tag $(distpkg)
@echo
- @echo "tag created remember to check it in"
+ @echo "tag created remember to push it"
@echo
dist: tag
- mkdir -p "$(distpkg)"
- cp AUTHORS COPYING gentoo layman repoman Makefile TODO "$(distpkg)/"
- svn up
- svn2cl -o "$(distpkg)/"ChangeLog
- tar cjf "$(distpkg).tar.bz2" "$(distpkg)"
- rm -fr "$(distpkg)/"
+ git archive --prefix=$(distpkg)/ --format=tar -o $(distpkg).tar $(distpkg)
+ mkdir $(distpkg)/
+ git log > $(distpkg)/ChangeLog
+ tar vfr $(distpkg).tar $(distpkg)/ChangeLog
+ bzip2 $(distpkg).tar
+ rm -rf $(distpkg)/
@echo "success."
dist-upload: dist