summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdam Feldman <NP-Hardass@gentoo.org>2021-08-01 21:59:08 -0400
committerAdam Feldman <NP-Hardass@gentoo.org>2021-08-01 21:59:08 -0400
commit75a4b8cec6eb4394c9c377f1982d9741aa259adf (patch)
treed3ee2d804de72531f155298ccf2d9b85135c5bb4
parentmate-extra/caja-admin: Remove long description from metadata.xml (diff)
downloadgentoo-mate-master.tar.gz
gentoo-mate-master.tar.bz2
gentoo-mate-master.zip
mate-extra/mate-power-manager: Bump to 1.24.3HEADmaster
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Adam Feldman <NP-Hardass@gentoo.org>
-rw-r--r--mate-extra/mate-power-manager/Manifest1
-rw-r--r--mate-extra/mate-power-manager/mate-power-manager-1.24.3.ebuild75
2 files changed, 76 insertions, 0 deletions
diff --git a/mate-extra/mate-power-manager/Manifest b/mate-extra/mate-power-manager/Manifest
index 55081b3..f7357cd 100644
--- a/mate-extra/mate-power-manager/Manifest
+++ b/mate-extra/mate-power-manager/Manifest
@@ -1 +1,2 @@
DIST mate-power-manager-1.24.2.tar.xz 6194976 BLAKE2B 6f533f9d6cbe99e9acf6e0fe9deb641e771d38f80add33b1f51aaa27aff46e2bb77d7da60ee7994908667d34b6f05c868472283cf9fd52c251467482c7c64bb3 SHA512 edbad37f41e67219790dfe704936be6fcf1d727cdff3b51cb43234b0d48f53666361d0f048704a594a594b5e124d7d8ea9d626c560cbc23ba4de3dcaafbd55ff
+DIST mate-power-manager-1.24.3.tar.xz 6199712 BLAKE2B 21eb92d6b0bc8f97c3f13847e877d6df7d8782ca90cae20e414d38c18ec9345b4b6a65cc72ed23010aec65d764381e66ac01a77a60b698c43764f2c3eb6c5229 SHA512 6aad5c5346e563ce0fbc4e72bccce49323843e3b12738b9e45040dd804f962344a1dbc8f26d518b28fc35ca9ec87a2068f81731eb0c094be114378f2f93a2a8c
diff --git a/mate-extra/mate-power-manager/mate-power-manager-1.24.3.ebuild b/mate-extra/mate-power-manager/mate-power-manager-1.24.3.ebuild
new file mode 100644
index 0000000..84d486d
--- /dev/null
+++ b/mate-extra/mate-power-manager/mate-power-manager-1.24.3.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit mate
+
+if [[ ${PV} != 9999 ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+DESCRIPTION="A session daemon for MATE that makes it easy to manage your laptop or desktop"
+
+LICENSE="FDL-1.1+ GPL-2+ LGPL-2+"
+SLOT="0"
+IUSE="+applet elogind libsecret policykit systemd test"
+
+REQUIRED_USE="^^ ( elogind systemd )"
+
+# Interactive testsuite.
+RESTRICT="test"
+
+COMMON_DEPEND="
+ >=dev-libs/dbus-glib-0.70
+ >=dev-libs/glib-2.50:2
+ >=media-libs/libcanberra-0.10:0[gtk3]
+ >=sys-apps/dbus-1
+ >=sys-power/upower-0.99.8:=
+ >=x11-apps/xrandr-1.3
+ >=x11-libs/cairo-1
+ >=x11-libs/gdk-pixbuf-2.11:2
+ >=x11-libs/gtk+-3.22:3
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXrandr
+ >=x11-libs/libnotify-0.7:0
+ x11-libs/pango
+ applet? ( >=mate-base/mate-panel-1.17.0 )
+ libsecret? ( >=app-crypt/libsecret-0.11 )
+"
+
+RDEPEND="${COMMON_DEPEND}
+ virtual/libintl
+ policykit? ( >=mate-extra/mate-polkit-1.6 )
+ systemd? ( sys-apps/systemd )
+ elogind? ( sys-auth/elogind )
+"
+
+DEPEND="${COMMON_DEPEND}
+ app-text/docbook-xml-dtd:4.3
+ app-text/rarian
+ >=app-text/scrollkeeper-dtd-1:1.0
+ app-text/yelp-tools
+ dev-libs/libxml2
+ dev-util/glib-utils
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ x11-base/xorg-proto
+"
+
+PATCHES=( "${FILESDIR}/${PN}-1.24.1-libsecret.patch" )
+
+src_configure() {
+ mate_src_configure \
+ --enable-compile-warnings=minimum \
+ $(use_with libsecret) \
+ $(use_enable applet applets) \
+ $(use_enable test tests)
+}
+
+src_test() {
+ unset DBUS_SESSION_BUS_ADDRESS
+
+ dbus-launch Xemake check || die "Test phase failed"
+}