summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEttore Di Giacinto <mudler@gentoo.org>2017-03-16 12:45:25 +0100
committerEttore Di Giacinto <mudler@gentoo.org>2017-03-16 12:45:25 +0100
commit672fa6464eb21e77c2a750b9c7610e80d4329c4c (patch)
treeab515ab6e9eca350831a17246fa3dbd372475b13
parentapp-arch/engrampa: sync live ebuild with upstream (diff)
downloadgentoo-mate-672fa6464eb21e77c2a750b9c7610e80d4329c4c.tar.gz
gentoo-mate-672fa6464eb21e77c2a750b9c7610e80d4329c4c.tar.bz2
gentoo-mate-672fa6464eb21e77c2a750b9c7610e80d4329c4c.zip
media-gfx/eom: sync live ebuild with upstream
* Drop gtk3 and python useflags * Bump required version of mate-desktop and add new dev-libs/libpeas dependency Package-Manager: Portage-2.3.3, Repoman-2.3.1
-rw-r--r--media-gfx/eom/eom-9999.ebuild30
1 files changed, 6 insertions, 24 deletions
diff --git a/media-gfx/eom/eom-9999.ebuild b/media-gfx/eom/eom-9999.ebuild
index 293481b..4293772 100644
--- a/media-gfx/eom/eom-9999.ebuild
+++ b/media-gfx/eom/eom-9999.ebuild
@@ -1,11 +1,9 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-PYTHON_COMPAT=( python2_7 )
-
-inherit mate python-single-r1
+inherit mate
if [[ ${PV} != 9999 ]]; then
KEYWORDS="~amd64 ~arm ~x86"
@@ -15,22 +13,19 @@ DESCRIPTION="The MATE image viewer"
LICENSE="GPL-2"
SLOT="0"
-IUSE="X debug dbus exif gtk3 +introspection jpeg lcms python svg tiff xmp"
-
-REQUIRED_USE="
- gtk3? ( !python )
- python? ( ${PYTHON_REQUIRED_USE} )
- "
+IUSE="X debug dbus exif +introspection jpeg lcms svg tiff xmp"
COMMON_DEPEND="
dev-libs/atk:0
>=dev-libs/glib-2.36:2
+ >=dev-libs/libpeas-1.2.0[gtk]
>=dev-libs/libxml2-2:2
gnome-base/dconf:0
- >=mate-base/mate-desktop-1.9.1[gtk3(-)=]
+ >=mate-base/mate-desktop-1.17.0
sys-libs/zlib:0
x11-libs/cairo:0
>=x11-libs/gdk-pixbuf-2.4:2[introspection?,jpeg?,tiff?]
+ >=x11-libs/gtk+-3.14:3[introspection?]
x11-libs/libX11:0
>=x11-misc/shared-mime-info-0.20:0
virtual/libintl:0
@@ -39,16 +34,9 @@ COMMON_DEPEND="
>=media-libs/libexif-0.6.14:0
virtual/jpeg:0
)
- !gtk3? ( >=x11-libs/gtk+-2.18:2[introspection?] )
- gtk3? ( >=x11-libs/gtk+-3.0:3[introspection?] )
introspection? ( >=dev-libs/gobject-introspection-0.9.3:= )
jpeg? ( virtual/jpeg:0 )
lcms? ( media-libs/lcms:2 )
- python? (
- ${PYTHON_DEPS}
- >=dev-python/pygobject-2.15.1:2[${PYTHON_USEDEP}]
- >=dev-python/pygtk-2.13:2[${PYTHON_USEDEP}]
- )
svg? ( >=gnome-base/librsvg-2.36.2:2 )
xmp? ( >=media-libs/exempi-1.99.5:2 )
!!media-gfx/mate-image-viewer"
@@ -63,16 +51,10 @@ DEPEND="${COMMON_DEPEND}
sys-devel/gettext:*
virtual/pkgconfig:*"
-pkg_setup() {
- use python && python-single-r1_pkg_setup
-}
-
src_configure() {
mate_src_configure \
- --with-gtk=$(usex gtk3 3.0 2.0) \
$(use_enable debug) \
$(use_enable introspection) \
- $(use_enable python) \
$(use_with X x) \
$(use_with dbus) \
$(use_with exif libexif) \