summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authormudler <mudler@sabayon.org>2016-09-05 16:03:03 +0200
committermudler <mudler@sabayon.org>2016-09-05 16:03:03 +0200
commitb9b51c7509e0341558232874bffdd8af8a7d0f14 (patch)
tree7e34c81ad099e719eeabd4c646646c5e767af9b3 /x11-misc
parentmate-extra/mate-utils: Version bump to 1.14.1 (diff)
downloadgentoo-mate-b9b51c7509e0341558232874bffdd8af8a7d0f14.tar.gz
gentoo-mate-b9b51c7509e0341558232874bffdd8af8a7d0f14.tar.bz2
gentoo-mate-b9b51c7509e0341558232874bffdd8af8a7d0f14.zip
x11-misc/mozo: Version bump to 1.14.1
Package-Manager: portage-2.2.26
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/mozo/Manifest1
-rw-r--r--x11-misc/mozo/mozo-1.14.1.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/x11-misc/mozo/Manifest b/x11-misc/mozo/Manifest
index 27cf776..806faf8 100644
--- a/x11-misc/mozo/Manifest
+++ b/x11-misc/mozo/Manifest
@@ -1,3 +1,4 @@
DIST mozo-1.10.1.tar.xz 163456 SHA256 91e97700d67cddaf39ec5f06d1bddaf585458d7677d76d72a4a527cfd030ecd8 SHA512 767f81c84642f83ba7579fde5eceedb588d934e52f0dd8f8a405e596e445aa68d0e3828db909130d121298e4fc7822736b45af7eda8f2c01f809b9df294a4aea WHIRLPOOL 6542017d320840a8a1f53e8e44c4a38a81efa62352ebe46c7f5b50bca9cde19401ff3cf07b08f4f85f15c555964af26dc539c95ec8062fd31bed8e25dafaa299
DIST mozo-1.12.0-gtk3.patch.bz2 6562 SHA256 b8aed33b49bd7d5c09d9546770ba79d8643b8d7eb56a0d512e1105c8e8ffd32d SHA512 9f86a77f29fb359fb59092d819634d2223b74c5eb149917b1442589306d989cfb87df2cc8c4f1e36fd086ba57a75274feccb4978cc0156e20cfd73712ea2a48b WHIRLPOOL 3b78ad3496b6f31e90effff345c83805d6e35a910a4298cfd35a048810425cc26283b8da72cb5134d84a81fa124a0197fa1ba446aa99c0add1eeafc24ae5c31c
DIST mozo-1.12.0.tar.xz 163820 SHA256 59ab1c873064177e5515ba31c493fe9fd158c37b1054f7ae638c6571640aecc7 SHA512 93e760b791a74b6a6ca0377d5aaa060c8bf339dcfde91fcb146ef1e37cc25912b3c93fa2b4d612c0abf2bbd00597c80b58769bc88b57925ec4c465967f32c05b WHIRLPOOL 188419370e749b984d6cc1437baf67dc2611e255d9e18ee2cee113eff578cde8db078064050d63e523d457d5b1fa391a6f1a1db0e95f23c0c79742e484670932
+DIST mozo-1.14.1.tar.xz 171576 SHA256 6ec9afc8de9c61ac44d0a65e09bdad847caae5050b1ffe66ca02bc6d479f7163 SHA512 62269ed358807d7ebcf04e6bcbfd3689f019396ebd43a8634bca752f13d6609e94b97688b5fdfa83b1168f0e1cdf284275dc08054e27ab507ce40c2de881bc76 WHIRLPOOL ef795b2268a05ebc6343b62d67e0546b993fe4d6e01d4fbba5c4e8528cb7dae267116de22ddc9dcda91d6aeb332d41411efa2e598ed322ca4acf9da6403f0ea9
diff --git a/x11-misc/mozo/mozo-1.14.1.ebuild b/x11-misc/mozo/mozo-1.14.1.ebuild
new file mode 100644
index 0000000..80e2d65
--- /dev/null
+++ b/x11-misc/mozo/mozo-1.14.1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="xml"
+
+inherit python-r1 mate
+
+if [[ ${PV} != 9999 ]]; then
+ KEYWORDS="~amd64 ~arm ~x86"
+fi
+
+DESCRIPTION="Mozo menu editor for MATE"
+LICENSE="GPL-2"
+SLOT="0"
+
+IUSE=""
+
+COMMON_DEPEND="${PYTHON_DEPS}
+ >=dev-python/pygobject-3:3[${PYTHON_USEDEP}]
+ >=mate-base/mate-menus-1.6[introspection]
+ x11-libs/gdk-pixbuf:2[introspection]
+ x11-libs/gtk+:3[introspection]
+ virtual/libintl:0
+ !!x11-misc/mate-menu-editor"
+
+RDEPEND="${COMMON_DEPEND}"
+
+DEPEND="${COMMON_DEPEND}
+ >=dev-util/intltool-0.40:*
+ sys-devel/gettext:*
+ virtual/pkgconfig:*"
+
+src_prepare() {
+ mate_src_prepare
+ python_copy_sources
+}
+
+src_configure() {
+ python_foreach_impl run_in_build_dir mate_src_configure \
+ --disable-icon-update
+}
+
+src_compile() {
+ python_foreach_impl run_in_build_dir default
+}
+
+src_test() {
+ python_foreach_impl run_in_build_dir emake check
+}
+
+src_install() {
+ installing() {
+ mate_src_install
+
+ # Massage shebang to make python_doscript happy
+ sed -e 's:#! '"${PYTHON}:#!/usr/bin/python:" \
+ -i mozo || die
+
+ python_doscript mozo
+ }
+
+ python_foreach_impl run_in_build_dir installing
+}