aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-07-13 07:26:36 +0200
committerMichał Górny <mgorny@gentoo.org>2022-07-13 07:26:36 +0200
commit3bc67579b990d53cdcf2ba9b016995b41d2b26a3 (patch)
treecb5b9807004fc1cf1960f1180c7b86d51176555b
parentgentoo-common: fix "Undefined variable: git" (diff)
downloadgentoo-syntax-3bc67579b990d53cdcf2ba9b016995b41d2b26a3.tar.gz
gentoo-syntax-3bc67579b990d53cdcf2ba9b016995b41d2b26a3.tar.bz2
gentoo-syntax-3bc67579b990d53cdcf2ba9b016995b41d2b26a3.zip
Fix tag rule for multiple existing tagsv3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 04bfcdb..9d2d016 100644
--- a/Makefile
+++ b/Makefile
@@ -29,7 +29,7 @@ install-file-%: $(subst _,/,$*)
cp "$(subst _,/,$*)" "$(PREFIX)/$(subst _,/,$*)"
tag:
- git tag -s v$$(( $$(git tag -l --sort=-creatordate | sed -n -e 's:^v::p') + 1 ))
+ git tag -s v$$(( $$(git tag -l --sort=-creatordate | sed -n -e 's:^v::p' | head -n 1) + 1 ))
uninstall : uninstall-files