summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2013-08-01 18:08:48 +0200
committerMichał Górny <mgorny@gentoo.org>2013-08-01 18:21:24 +0200
commitc60d39fc6d5222d9773179faf42c34a3217e9146 (patch)
treeb7f2a53e438541f5237d6cf5182a6b267724d0fb /Makefile.am
parentInitial version of local.d support. (diff)
downloadgentoo-systemd-integration-c60d39fc6d5222d9773179faf42c34a3217e9146.tar.gz
gentoo-systemd-integration-c60d39fc6d5222d9773179faf42c34a3217e9146.tar.bz2
gentoo-systemd-integration-c60d39fc6d5222d9773179faf42c34a3217e9146.zip
Switch local.d support to a generator.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am25
1 files changed, 6 insertions, 19 deletions
diff --git a/Makefile.am b/Makefile.am
index 1c6f985..b91f88c 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -3,34 +3,21 @@ DISTCHECK_CONFIGURE_FLAGS = \
--with-systemdsystemunitdir=\$${libdir}/systemd/system \
--with-systemdutildir=\$${libdir}/systemd
+# TODO: upstream that?
+systemdsystemgeneratordir = $(systemdutildir)/system-generators
+
dist_tmpfiles_DATA = \
tmpfiles.d/gentoo-run.conf
dist_systemdsystemunit_DATA = \
mounts/var-lock.mount \
mounts/var-run.mount
-dist_systemdutil_SCRIPTS = \
- bin/gentoo-run-directory
+dist_systemdsystemgenerator_SCRIPTS = \
+ system-generators/gentoo-local-generator
-systemdsystemunit_DATA = \
- services/gentoo-local.service
-EXTRA_DIST = \
- services/gentoo-local.service.in
DISTCLEANFILES = \
$(systemdsystemunit_DATA)
-services/gentoo-local.service: services/gentoo-local.service.in
-
-$(systemdsystemunit_DATA): config.status
- $(MKDIR_P) services
- rm -f $@ $@.tmp
- $(SED) \
- -e "s|@systemdutildir[@]|$(systemdutildir)|" \
- ${srcdir}/$@.in > $@.tmp
- chmod a-w $@.tmp
- mv $@.tmp $@
-
-
-EXTRA_DIST += NEWS
+EXTRA_DIST = NEWS
NEWS: configure.ac Makefile.am
git for-each-ref refs/tags --sort '-*committerdate' \
--format '# %(tag) (%(*committerdate:short))%0a%(contents:body)' \