aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorfuzzyray <fuzzyray@gentoo.org>2009-05-01 17:33:51 +0000
committerfuzzyray <fuzzyray@gentoo.org>2009-05-01 17:33:51 +0000
commit6d7f0d8da0e3e8f7a74c49377dcc191fd4fdc002 (patch)
tree8e574331d12e29d1ada81d3780057e0747d4ad06
parentAdd ekeyword rewritten in python to repo (diff)
downloadgentoolkit-6d7f0d8da0e3e8f7a74c49377dcc191fd4fdc002.tar.gz
gentoolkit-6d7f0d8da0e3e8f7a74c49377dcc191fd4fdc002.tar.bz2
gentoolkit-6d7f0d8da0e3e8f7a74c49377dcc191fd4fdc002.zip
Fix typo in Makefile
svn path=/; revision=568
-rw-r--r--trunk/Makefile2
-rw-r--r--trunk/src/echangelog/Makefile11
-rwxr-xr-xtrunk/src/euse/euse7
3 files changed, 13 insertions, 7 deletions
diff --git a/trunk/Makefile b/trunk/Makefile
index 3906c52..76dfe1d 100644
--- a/trunk/Makefile
+++ b/trunk/Makefile
@@ -51,7 +51,7 @@ dist-gentoolkit:
( cd release ; tar zcf gentoolkit-$(VERSION)$(RELEASE_TAG).tar.gz gentoolkit-$(VERSION)$(RELEASE_TAG)/ )
install:
- echo "Err0r: Must use either install-gentoolkit or install-gentoolkit-dev"
+ echo "Error: Must use either install-gentoolkit or install-gentoolkit-dev"
exit 1
install-gentoolkit:
diff --git a/trunk/src/echangelog/Makefile b/trunk/src/echangelog/Makefile
index 61c5e57..b33e0ce 100644
--- a/trunk/src/echangelog/Makefile
+++ b/trunk/src/echangelog/Makefile
@@ -6,13 +6,16 @@
include ../../makedefs.mak
-%.1 : %.pod
- pod2man $< > $@
+#%.1 : %.pod
+# pod2man $< > $@
.PHONY: all
-all: echangelog.1
-dist: echangelog.1
+#all: echangelog.1
+all:
+
+#dist: echangelog.1
+dist:
mkdir -p ../../$(distdir)/src/echangelog/
cp Makefile AUTHORS README TODO ChangeLog echangelog echangelog.pod echangelog.1 ../../$(distdir)/src/echangelog/
diff --git a/trunk/src/euse/euse b/trunk/src/euse/euse
index 7400709..f9fd2fd 100755
--- a/trunk/src/euse/euse
+++ b/trunk/src/euse/euse
@@ -347,7 +347,7 @@ showinstdesc() {
local current_desc
local args
local -i foundone=0
- local IFS
+ local OIFS="$IFS"
args=("${@:-*}")
@@ -377,7 +377,7 @@ showinstdesc() {
echo "$desc"
# get list of installed packages matching this USE flag.
IFS=$'\n'
- packages=($(equery -q -C hasuse -i "${1}" | awk '{ print $(NF-1) }'))
+ packages=($(equery -q -C hasuse -i "${1}" | awk '{ print $(NF-1) }' | sort))
foundone+=${#packages[@]}
printf "\nInstalled packages matching this USE flag: "
if [ ${foundone} -gt 0 ]; then
@@ -397,7 +397,9 @@ showinstdesc() {
# exit status of equery instead of a subshell and pipe to wc -l
if [ $(equery -q -C list -i -e "${pkg}" | wc -l) -gt 0 ]; then
foundone=1
+ IFS="$OIFS"
get_flagstatus "${flag}"
+ IFS=': '
printf "%s (%s):\n%s\n\n" "${flag}" "${pkg}" "${desc#- }"
fi
done < <(grep ":${1} *-" "${descdir}/use.local.desc")
@@ -409,6 +411,7 @@ showinstdesc() {
if [ ${foundone} -lt 1 ]; then
echo "no matching entries found"
fi
+ IFS="$OIFS"
}
# show a list of all currently active flags and where they are activated