aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2020-12-20 17:12:46 -0500
committerMatt Turner <mattst88@gentoo.org>2020-12-20 17:12:46 -0500
commit4c3ca2185c9bb71a028fb54953728c5a05807765 (patch)
treea1eb16e6c74ef788bf70f74a2969fa13183990eb
parentRemove Python < 3 version checks (diff)
downloadgentoolkit-4c3ca2185c9bb71a028fb54953728c5a05807765.tar.gz
gentoolkit-4c3ca2185c9bb71a028fb54953728c5a05807765.tar.bz2
gentoolkit-4c3ca2185c9bb71a028fb54953728c5a05807765.zip
Remove inherits from object
Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--pym/gentoolkit/cpv.py2
-rw-r--r--pym/gentoolkit/eclean/clean.py2
-rw-r--r--pym/gentoolkit/eclean/output.py2
-rw-r--r--pym/gentoolkit/eclean/pkgindex.py2
-rw-r--r--pym/gentoolkit/eclean/search.py2
-rw-r--r--pym/gentoolkit/enalyze/lib.py4
-rw-r--r--pym/gentoolkit/equery/belongs.py2
-rw-r--r--pym/gentoolkit/equery/check.py2
-rw-r--r--pym/gentoolkit/equery/depends.py2
-rw-r--r--pym/gentoolkit/formatters.py2
-rw-r--r--pym/gentoolkit/helpers.py4
-rw-r--r--pym/gentoolkit/keyword.py2
-rw-r--r--pym/gentoolkit/metadata.py8
-rw-r--r--pym/gentoolkit/module_base.py2
-rw-r--r--pym/gentoolkit/package.py2
-rw-r--r--pym/gentoolkit/revdep_rebuild/analyse.py2
-rw-r--r--pym/gentoolkit/revdep_rebuild/assign.py2
-rw-r--r--pym/gentoolkit/test/eclean/creator.py2
-rw-r--r--pym/gentoolkit/test/eclean/distsupport.py6
-rwxr-xr-xpym/gentoolkit/test/eclean/test_clean.py2
-rw-r--r--pym/gentoolkit/versionmatch.py2
21 files changed, 28 insertions, 28 deletions
diff --git a/pym/gentoolkit/cpv.py b/pym/gentoolkit/cpv.py
index 563dab8..5238e24 100644
--- a/pym/gentoolkit/cpv.py
+++ b/pym/gentoolkit/cpv.py
@@ -37,7 +37,7 @@ isvalid_rev_re = re.compile(r'(\d+|0\d+\.\d+)')
# Classes
# =======
-class CPV(object):
+class CPV:
"""Provides methods on a category/package-version string.
Will also correctly split just a package or package-version string.
diff --git a/pym/gentoolkit/eclean/clean.py b/pym/gentoolkit/eclean/clean.py
index 2b750e3..3f6fe45 100644
--- a/pym/gentoolkit/eclean/clean.py
+++ b/pym/gentoolkit/eclean/clean.py
@@ -11,7 +11,7 @@ import gentoolkit.pprinter as pp
from gentoolkit.eclean.pkgindex import PkgIndex
-class CleanUp(object):
+class CleanUp:
"""Performs all cleaning actions to distfiles or package directories.
@param controller: a progress output/user interaction controller function
diff --git a/pym/gentoolkit/eclean/output.py b/pym/gentoolkit/eclean/output.py
index 122d550..e2ed221 100644
--- a/pym/gentoolkit/eclean/output.py
+++ b/pym/gentoolkit/eclean/output.py
@@ -9,7 +9,7 @@ from portage.output import blue, yellow, teal, green, red
from gentoolkit.pprinter import cpv, number
-class OutputControl(object):
+class OutputControl:
"""Outputs data according to predetermined options and handles any user
interaction.
diff --git a/pym/gentoolkit/eclean/pkgindex.py b/pym/gentoolkit/eclean/pkgindex.py
index 6cf9000..46c734d 100644
--- a/pym/gentoolkit/eclean/pkgindex.py
+++ b/pym/gentoolkit/eclean/pkgindex.py
@@ -13,7 +13,7 @@ from gentoolkit.eprefix import EPREFIX
import portage
-class PkgIndex(object):
+class PkgIndex:
"""Handle the cleaning of the binpkg Package
Index file
diff --git a/pym/gentoolkit/eclean/search.py b/pym/gentoolkit/eclean/search.py
index 992949c..8f6e52f 100644
--- a/pym/gentoolkit/eclean/search.py
+++ b/pym/gentoolkit/eclean/search.py
@@ -50,7 +50,7 @@ def get_distdir():
distdir = get_distdir()
-class DistfilesSearch(object):
+class DistfilesSearch:
"""
@param output: verbose output method or (lambda x: None) to turn off
diff --git a/pym/gentoolkit/enalyze/lib.py b/pym/gentoolkit/enalyze/lib.py
index 8580bb7..50c7d11 100644
--- a/pym/gentoolkit/enalyze/lib.py
+++ b/pym/gentoolkit/enalyze/lib.py
@@ -17,7 +17,7 @@ from gentoolkit.flag import (reduce_flags, get_flags, get_all_cpv_use,
import portage
-class FlagAnalyzer(object):
+class FlagAnalyzer:
"""Specialty functions for analysing an installed package's
USE flags. Can be used for single or mulitple use without
needing to be reset unless the system USE flags are changed.
@@ -142,7 +142,7 @@ class FlagAnalyzer(object):
return _flags
-class KeywordAnalyser(object):
+class KeywordAnalyser:
"""Specialty functions for analysing the installed package db for
keyword useage and the packages that used them.
diff --git a/pym/gentoolkit/equery/belongs.py b/pym/gentoolkit/equery/belongs.py
index 8289366..1c9ab13 100644
--- a/pym/gentoolkit/equery/belongs.py
+++ b/pym/gentoolkit/equery/belongs.py
@@ -36,7 +36,7 @@ QUERY_OPTS = {
# Classes
# =======
-class BelongsPrinter(object):
+class BelongsPrinter:
"""Outputs a formatted list of packages that claim to own a files."""
def __init__(self, verbose=True, name_only=False):
diff --git a/pym/gentoolkit/equery/check.py b/pym/gentoolkit/equery/check.py
index e965164..47eba98 100644
--- a/pym/gentoolkit/equery/check.py
+++ b/pym/gentoolkit/equery/check.py
@@ -41,7 +41,7 @@ QUERY_OPTS = {
# Classes
# =======
-class VerifyContents(object):
+class VerifyContents:
"""Verify installed packages' CONTENTS files.
The CONTENTS file contains timestamps and MD5 sums for each file owned
diff --git a/pym/gentoolkit/equery/depends.py b/pym/gentoolkit/equery/depends.py
index 7461ade..74c6933 100644
--- a/pym/gentoolkit/equery/depends.py
+++ b/pym/gentoolkit/equery/depends.py
@@ -33,7 +33,7 @@ QUERY_OPTS = {
# Classes
# =======
-class DependPrinter(object):
+class DependPrinter:
"""Output L{gentoolkit.dependencies.Dependencies} objects."""
def __init__(self, verbose=True):
self.verbose = verbose
diff --git a/pym/gentoolkit/formatters.py b/pym/gentoolkit/formatters.py
index e8b1428..097c186 100644
--- a/pym/gentoolkit/formatters.py
+++ b/pym/gentoolkit/formatters.py
@@ -94,7 +94,7 @@ def format_timestamp(timestamp):
return time.strftime("%Y-%m-%d %H:%M:%S", time.localtime(int(timestamp)))
-class CpvValueWrapper(object):
+class CpvValueWrapper:
"""Format a cpv and linewrap pre-formatted values"""
def __init__(self, cpv_width=None, width=None):
diff --git a/pym/gentoolkit/helpers.py b/pym/gentoolkit/helpers.py
index 02ac20e..a979ca7 100644
--- a/pym/gentoolkit/helpers.py
+++ b/pym/gentoolkit/helpers.py
@@ -44,7 +44,7 @@ from gentoolkit.versionmatch import VersionMatch
# Classes
# =======
-class ChangeLog(object):
+class ChangeLog:
"""Provides methods for working with a Gentoo ChangeLog file.
Example usage:
@@ -216,7 +216,7 @@ class ChangeLog(object):
return result
-class FileOwner(object):
+class FileOwner:
"""Creates a function for locating the owner of filename queries.
Example usage:
diff --git a/pym/gentoolkit/keyword.py b/pym/gentoolkit/keyword.py
index 9edf4aa..e997efe 100644
--- a/pym/gentoolkit/keyword.py
+++ b/pym/gentoolkit/keyword.py
@@ -23,7 +23,7 @@ __all__ = (
# Classes
# =======
-class Keyword(object):
+class Keyword:
"""Provides common methods on a GLEP 53 keyword."""
def __init__(self, keyword):
diff --git a/pym/gentoolkit/metadata.py b/pym/gentoolkit/metadata.py
index ecf60c3..9dc9619 100644
--- a/pym/gentoolkit/metadata.py
+++ b/pym/gentoolkit/metadata.py
@@ -48,7 +48,7 @@ from portage import settings
# Classes
# =======
-class _Maintainer(object):
+class _Maintainer:
"""An object for representing one maintainer.
@type email: str or None
@@ -78,7 +78,7 @@ class _Maintainer(object):
return "<%s %r>" % (self.__class__.__name__, self.email)
-class _Useflag(object):
+class _Useflag:
"""An object for representing one USE flag.
@todo: Is there any way to have a keyword option to leave in
@@ -111,7 +111,7 @@ class _Useflag(object):
return "<%s %r>" % (self.__class__.__name__, self.name)
-class _Upstream(object):
+class _Upstream:
"""An object for representing one package's upstream.
@type maintainers: list
@@ -167,7 +167,7 @@ class _Upstream(object):
return [(e.text, e.get('type')) for e in self.node.findall('remote-id')]
-class MetaData(object):
+class MetaData:
"""Access metadata.xml"""
def __init__(self, metadata_path):
diff --git a/pym/gentoolkit/module_base.py b/pym/gentoolkit/module_base.py
index 322088d..0632469 100644
--- a/pym/gentoolkit/module_base.py
+++ b/pym/gentoolkit/module_base.py
@@ -17,7 +17,7 @@ import gentoolkit.pprinter as pp
from gentoolkit.formatters import format_options
from gentoolkit.base import mod_usage
-class ModuleBase(object):
+class ModuleBase:
"""E-app base module class to parse module options print module help, etc.."""
def __init__(self):
diff --git a/pym/gentoolkit/package.py b/pym/gentoolkit/package.py
index 37209d5..4c851bc 100644
--- a/pym/gentoolkit/package.py
+++ b/pym/gentoolkit/package.py
@@ -423,7 +423,7 @@ class Package(CPV):
return self.cpv not in unmasked
-class PackageFormatter(object):
+class PackageFormatter:
"""When applied to a L{gentoolkit.package.Package} object, determine the
location (Portage Tree vs. overlay), install status and masked status. That
information can then be easily formatted and displayed.
diff --git a/pym/gentoolkit/revdep_rebuild/analyse.py b/pym/gentoolkit/revdep_rebuild/analyse.py
index 6ce1568..3e46a51 100644
--- a/pym/gentoolkit/revdep_rebuild/analyse.py
+++ b/pym/gentoolkit/revdep_rebuild/analyse.py
@@ -115,7 +115,7 @@ def extract_dependencies_from_la(la, libraries, to_check, logger):
return broken
-class LibCheck(object):
+class LibCheck:
def __init__(self, scanned_files, logger, searchlibs=None, searchbits=None,
all_masks=None, masked_dirs=None):
'''LibCheck init function.
diff --git a/pym/gentoolkit/revdep_rebuild/assign.py b/pym/gentoolkit/revdep_rebuild/assign.py
index 3fa9299..570c114 100644
--- a/pym/gentoolkit/revdep_rebuild/assign.py
+++ b/pym/gentoolkit/revdep_rebuild/assign.py
@@ -16,7 +16,7 @@ from portage import portdb
from portage.output import bold, red, yellow, green
-class _file_matcher(object):
+class _file_matcher:
"""
Compares files by basename and parent directory (device, inode),
so comparisons work regardless of directory symlinks. If a
diff --git a/pym/gentoolkit/test/eclean/creator.py b/pym/gentoolkit/test/eclean/creator.py
index 678c203..da5123e 100644
--- a/pym/gentoolkit/test/eclean/creator.py
+++ b/pym/gentoolkit/test/eclean/creator.py
@@ -94,7 +94,7 @@ def make_symlinks(path, links, targets):
os.path.join(path, links[i]))
-class TestDirCreation(object):
+class TestDirCreation:
""""""
distfile_list = ['ExtUtils-ParseXS-2.22.tar.gz',
diff --git a/pym/gentoolkit/test/eclean/distsupport.py b/pym/gentoolkit/test/eclean/distsupport.py
index fd858d4..0fc2db8 100644
--- a/pym/gentoolkit/test/eclean/distsupport.py
+++ b/pym/gentoolkit/test/eclean/distsupport.py
@@ -335,7 +335,7 @@ def get_props(cpvs):
props[cpv] = PROPS[cpv].copy()
return props
-class Dbapi(object):
+class Dbapi:
"""Fake portage dbapi class used to return
pre-determined test data in place of a live system
@@ -397,7 +397,7 @@ class Dbapi(object):
return props
-class OutputSimulator(object):
+class OutputSimulator:
"""Simple output accumulator used for testing.
Simulates eclean.output.OutputControl class """
@@ -432,7 +432,7 @@ class OutputSimulator(object):
self.callback('list_pkgs', pkgs)
-class TestDisfiles(object):
+class TestDisfiles:
def __init__(self):
self.workdir = None
diff --git a/pym/gentoolkit/test/eclean/test_clean.py b/pym/gentoolkit/test/eclean/test_clean.py
index 0c35e93..2f50e27 100755
--- a/pym/gentoolkit/test/eclean/test_clean.py
+++ b/pym/gentoolkit/test/eclean/test_clean.py
@@ -20,7 +20,7 @@ __email__ = "brian.dolbec@gmail.com"
# from gentoolkit.eclean.clean import CleanUp
-# class Controllers(object):
+# class Controllers:
# """Contains controller methods for use in testing
# the clean module methods"""
diff --git a/pym/gentoolkit/versionmatch.py b/pym/gentoolkit/versionmatch.py
index 0d1c6ab..9287c13 100644
--- a/pym/gentoolkit/versionmatch.py
+++ b/pym/gentoolkit/versionmatch.py
@@ -21,7 +21,7 @@ from gentoolkit.cpv import CPV
# Classes
# =======
-class VersionMatch(object):
+class VersionMatch:
"""Gentoo version comparison object from pkgcore.ebuild.atom_restricts.
Any overriding of this class *must* maintain numerical order of