aboutsummaryrefslogtreecommitdiff
path: root/TODO
diff options
context:
space:
mode:
Diffstat (limited to 'TODO')
-rw-r--r--TODO34
1 files changed, 0 insertions, 34 deletions
diff --git a/TODO b/TODO
index f4d4124..997919e 100644
--- a/TODO
+++ b/TODO
@@ -3,15 +3,11 @@
- add glsa pkgspec
- query for current GLSAs on installed package(s)
- rewrite ekeywords and echangelog to use gentoolkit
-- fully deprecate qpkg
-- fully deprecate pkg-size
- merge change and echangelog
- merge useflag and euse, have _one_ command line tool
- update ufed to rely on the CLI tool
- update ufed to rely on generate-use
- merge generate-use and ufed?
-- rewrite revdep-rebuild to use gentoolkit
- - drop qpkg dependency; use equery instead
- write efeatures for turning on/off FEATURES in make.conf
- look at ekeys, ewatch
- revision bump tool
@@ -27,43 +23,13 @@ equery (modern):
Tighten up CPV.split_cpv, it's slow and bad
Extend PackageFormatter usage to everything that outputs packages to
allow for purvasive use of -F, --format goodness
- Add package::repo search syntax to do_lookup
- _do_repository_lookup?
- Move do_lookout and all it's silly friends into the new query module
- and Query class. Essentially, Query, when applied to a pkgspec input
- should contain most of the common 'helper' methods. So we should be
- be able to do:
- Query('portage').find_best(),
- Query('portage').find_package(),
- Query('portag*').is_regex() or .uses_globbing(), etc.
- Refactor each module to be useful for import. Done modules:
- +depends
- +belongs
- +meta
- +changes
- +depgraph
Ebuild changes:
- Add:
src_test() {
"${python}" setup.py test || die "testing returned non zero"
}
- - Add:
- DEPEND on python 2.5 (needed for 'from __future__ import with_statement' and others)
For Next Release:
- write NEWS file
- make CPV.__init__ more strict, it allows some silly stuff
- - $ equery uses '>=sys-apps/portage-2'
- * Searching for >=sys-apps/portage-2 ...
- * Found these USE flags for sys-apps/portage-2.1.6.13:
- - belongs doesn't properly match atom syntax
-
-
-For following release:
- - transition package query backend to using Query class.
- Query class should accept any kind package of input accepted by equery.
- Most of the functions in helpers should be able to moved out, either in
- to query (many of those functions pertain to finding packages matching a
- query) or into other appropriate modules (split_cpv,
- compare_package_strings into cpv, as they also requires a cpv string)