aboutsummaryrefslogtreecommitdiff
path: root/bin/ebump
diff options
context:
space:
mode:
Diffstat (limited to 'bin/ebump')
-rwxr-xr-xbin/ebump7
1 files changed, 4 insertions, 3 deletions
diff --git a/bin/ebump b/bin/ebump
index b129f85..a0d4d56 100755
--- a/bin/ebump
+++ b/bin/ebump
@@ -3,7 +3,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-__version__="0.1.1"
__author__="Karl Trygve Kalleberg"
__email__="<karltk@gentoo.org>"
__description__="Ebuild version bumping tool"
@@ -13,6 +12,8 @@ __description__="Ebuild version bumping tool"
# a given ebuild and auxiliary files in the Portage tree. It is only
# useful for Gentoo developers with CVS commit access.
+VERSION="git"
+
die() {
echo $1 >&2
exit -1
@@ -25,7 +26,7 @@ einfo() {
}
print_version() {
- echo "${__description__}, v${__version__}"
+ echo "${__description__}, v${VERSION}"
echo "Copyright (c) 2004 ${__author__} ${__email__}"
echo "Copyright 1999-2010 Gentoo Foundation"
echo "Distributed under the terms of the GNU General Public License v2"
@@ -33,7 +34,7 @@ print_version() {
print_usage() {
echo "Usage: ebump <options> foo<.ebuild>"
- echo "Ebuild version bumping tool, v${__version__}"
+ echo "Ebuild version bumping tool, v${VERSION}"
echo " -V|--version show version info"
echo " -v|--verbose increase verbosity"
echo " -q|--quiet turn off output"