summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSaleem Abdulrasool <compnerd@compnerd.org>2008-05-14 23:09:55 -0700
committerSaleem Abdulrasool <compnerd@compnerd.org>2008-05-14 23:09:55 -0700
commit39b99bb747b36c0fc88ce9a6304fe3ac81b42220 (patch)
treef2de141a664a3eb170385292bc8285b95e13955c
parentversion bump from upstream (diff)
downloadgentopia-39b99bb747b36c0fc88ce9a6304fe3ac81b42220.tar.gz
gentopia-39b99bb747b36c0fc88ce9a6304fe3ac81b42220.tar.bz2
gentopia-39b99bb747b36c0fc88ce9a6304fe3ac81b42220.zip
version bump from upstream
-rw-r--r--sys-apps/hal/Manifest3
-rw-r--r--sys-apps/hal/hal-0.5.11.ebuild294
2 files changed, 297 insertions, 0 deletions
diff --git a/sys-apps/hal/Manifest b/sys-apps/hal/Manifest
index 65b6835..84e42d4 100644
--- a/sys-apps/hal/Manifest
+++ b/sys-apps/hal/Manifest
@@ -5,7 +5,10 @@ AUX hal-0.5.9-hide-recovery-partitions.patch 572 RMD160 bb59ba36f8db6724466cbe41
AUX hal-unmount.dev 397 RMD160 78286dd9527bbb421082e73b0d08e06cd514d275 SHA1 31169a28448fb1eb1dfee5d1699de9a02449a6b7 SHA256 747a4c483f8a558f2c75666e9547e539475f112363f1dbfc6ea19ca393c8e89b
DIST hal-0.5.10-gentoo-patches-1.tar.bz2 40532 RMD160 7786001714445409fe2047c327cebfe2a0953bae SHA1 578c965d62b5e65e59c585c3290779cca2d58949 SHA256 a195cb3d25d64990c54aab33a6be054abc3355bb41d8ab61d9c8238a6698c846
DIST hal-0.5.10.tar.gz 1591146 RMD160 fafd90e671dbe95a8dd55a4ad257586a0289ef67 SHA1 8d67499df61590c11fd3203004d69e8a45abb8fa SHA256 5a71a18c40af2bac64f40f0b8add2b6789924b98d7f1cb79a0faf83cb77acb4c
+DIST hal-0.5.11-gentoo-patches-0.tar.bz2 1548 RMD160 5bfa243afde150c0e7a2d5c6ae59e25e1cf0fecf SHA1 efea44077a015d5c2681902eca3068fe1a6032da SHA256 57a3591887fdd800fd7fef261c89918b1e103ca0761b9dab6f83344e13c44f28
+DIST hal-0.5.11.tar.gz 1672992 RMD160 b937e8bec11e0e856d2a8efff58c36f87f9ba9d0 SHA1 f51366229e5dd6d5d72d60114fdef76bf5feba26 SHA256 730a9f2340f789677eb0c3b0984bbaca3ede6c12d1e4b16bc7ea91f51d10ba90
DIST hal-0.5.11_rc2-gentoo-patches-0.tar.bz2 3068 RMD160 83b3c0a98b4b2ce69470f827833aec73b6cefdfe SHA1 fd4837739218754991277767b3d8dbe3a7089ef5 SHA256 4f9a85be47fdd9ef7f529ea1bd9654bf98bfa83cde68c6ada5908df7e752221b
DIST hal-0.5.11rc2.tar.gz 1665175 RMD160 45512c7f3f4524d64a6b849d72e34a915c7ef50f SHA1 403ae3bacbe737dc7a19dd65b4d144241232a3f1 SHA256 3937d2ab06c091d0b5d604f7615096be505455448cc13635ebdba169d29b4bdc
EBUILD hal-0.5.10-r1.ebuild 10050 RMD160 ad2fedd3e8887b393ee14dc1a757f87a78d35fa8 SHA1 769e65ac5d10362f8d25bc821cd58461edcbc2f5 SHA256 810fb46ce833e668ded037cb1fa2130891eaf12c9debb9f060b1ad5863502d0a
+EBUILD hal-0.5.11.ebuild 9163 RMD160 5d8477d606ef2687b81f7d8b3212ecb61c88b661 SHA1 05d7694fed8bcc12db5d67c5848348c9eba85699 SHA256 eb071ee94542859ed826f97f0b10e6fa77de85de04c5e30173611f50038f511c
EBUILD hal-0.5.11_rc2.ebuild 9163 RMD160 5d8477d606ef2687b81f7d8b3212ecb61c88b661 SHA1 05d7694fed8bcc12db5d67c5848348c9eba85699 SHA256 eb071ee94542859ed826f97f0b10e6fa77de85de04c5e30173611f50038f511c
diff --git a/sys-apps/hal/hal-0.5.11.ebuild b/sys-apps/hal/hal-0.5.11.ebuild
new file mode 100644
index 0000000..ad04e6d
--- /dev/null
+++ b/sys-apps/hal/hal-0.5.11.ebuild
@@ -0,0 +1,294 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hal/hal-0.5.10.ebuild,v 1.8 2008/01/10 18:05:15 jer Exp $
+
+inherit eutils linux-info autotools flag-o-matic
+
+PATCH_VERSION="0"
+
+DESCRIPTION="Hardware Abstraction Layer"
+HOMEPAGE="http://www.freedesktop.org/Software/hal"
+SRC_URI="http://hal.freedesktop.org/releases/${P/_/}.tar.gz
+ http://dev.gentoo.org/~compnerd/files/${PN}/${P}-gentoo-patches-${PATCH_VERSION}.tar.bz2"
+
+LICENSE="|| ( GPL-2 AFL-2.0 )"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~mips ~x86"
+
+KERNEL_IUSE="kernel_linux kernel_FreeBSD"
+IUSE="acpi apm crypt debug dell disk-partition doc laptop selinux ${KERNEL_IUSE}"
+
+RDEPEND=">=dev-libs/dbus-glib-0.61
+ >=dev-libs/glib-2.14
+ >=dev-libs/expat-1.95.8
+ >=dev-libs/libusb-0.1.10a
+ >=sys-apps/pciutils-2.2.7-r1
+ >=dev-util/gperf-3.0.3
+ sys-apps/usbutils
+ virtual/eject
+ amd64? ( >=sys-apps/dmidecode-2.7 )
+ dell? ( >=sys-libs/libsmbios-0.13.4 )
+ disk-partition? ( >=sys-apps/parted-1.8.0 )
+ ia64? ( >=sys-apps/dmidecode-2.7 )
+ kernel_linux? (
+ >=sys-fs/udev-111
+ >=sys-apps/util-linux-2.13
+ >=sys-kernel/linux-headers-2.6.19
+ crypt? (
+ || (
+ >=sys-fs/cryptsetup-1.0.5
+ >=sys-fs/cryptsetup-luks-1.0.1
+ )
+ )
+ )
+ kernel_FreeBSD? ( dev-libs/libvolume_id )
+ x86? ( >=sys-apps/dmidecode-2.7 )
+ selinux? ( sys-libs/libselinux sec-policy/selinux-hal )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ >=dev-util/intltool-0.35
+ >=dev-python/pyxf86config-0.3.34-r1
+ doc? (
+ app-doc/doxygen
+ app-text/docbook-sgml-utils
+ app-text/xmlto
+ dev-libs/libxml2
+ )"
+PDEPEND="=app-misc/hal-info-20080310
+ !gnome-extra/hal-device-manager
+ laptop? ( >=sys-power/pm-utils-0.99.3 )"
+
+## HAL Daemon drops privledges so we need group access to read disks
+HALDAEMON_GROUPS_LINUX="haldaemon,plugdev,disk,cdrom,cdrw,floppy,usb"
+HALDAEMON_GROUPS_FREEBSD="haldaemon,plugdev,operator"
+
+function check_hotplug_net() {
+ local CONFIG_CHECK="~HOTPLUG ~NET"
+ local WARNING_HOTPLUG="CONFIG_HOTPLUG:\tis not set (required for HAL)\n"
+ local WARNING_NET="CONFIG_NET:\tis not set (required for HAL)\n"
+ check_extra_config
+}
+
+function check_inotify() {
+ local CONFIG_CHECK="~INOTIFY_USER"
+ local WARNING_INOTIFY_USER="CONFIG_INOTIFY_USER:\tis not set (required for HAL)\n"
+ check_extra_config
+}
+
+function check_acpi_proc() {
+ local CONFIG_CHECK="~ACPI_PROCFS ~ACPI_PROC_EVENT"
+ local WARNING_ACPI_PROCFS="CONFIG_ACPI_PROCFS:\tis not set (required for HAL)\n"
+ local WARNING_ACPI_PROC_EVENT="CONFIG_ACPI_PROC_EVENT:\tis not set (required for HAL)\n"
+ check_extra_config
+}
+
+pkg_setup() {
+ if use kernel_linux ; then
+ if [[ -e "${ROOT}/usr/src/linux/.config" ]] ; then
+ kernel_is ge 2 6 19 || ewarn "HAL requires a kernel version 2.6.19 or newer"
+
+ if kernel_is lt 2 6 23 && use acpi ; then
+ check_acpi_proc
+ fi
+ fi
+
+ check_hotplug_net
+ check_inotify
+ fi
+
+ # http://devmanual.gentoo.org/ebuild-writing/functions/
+ # http://bugs.gentoo.org/show_bug.cgi?id=191605
+
+ # Create groups for hotplugging and HAL
+ enewgroup haldaemon || die "Problem adding haldaemon group"
+ enewgroup plugdev || die "Problem adding plugdev group"
+
+ # HAL drops priviledges by default now ...
+ # ... so we must make sure it can read disk/cdrom info (ie. be in ${HALDAEMON_GROUPS} groups)
+ if use kernel_linux; then
+ enewuser haldaemon -1 "-1" /dev/null ${HALDAEMON_GROUPS_LINUX} || die "Problem adding haldaemon user"
+ elif use kernel_FreeBSD; then
+ enewuser haldaemon -1 "-1" /dev/null ${HALDAEMON_GROUPS_FREEBSD} || die "Problem addding haldaemon user"
+ fi
+
+ # Make sure that the haldaemon user is in the ${HALDAEMON_GROUPS}
+ # If users have a problem with this, let them file a bug
+ if [[ ${ROOT} == / ]] ; then
+ if use kernel_linux; then
+ usermod -G ${HALDAEMON_GROUPS_LINUX} haldaemon
+ elif use kernel_FreeBSD; then
+ pw usermod haldaemon -G ${HALDAEMON_GROUPS_FREEBSD}
+ fi
+ fi
+}
+
+S="${WORKDIR}/${PF/_/}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ EPATCH_MULTI_MSG="Applying Gentoo Patchset ..." \
+ EPATCH_SUFFIX="patch" \
+ EPATCH_SOURCE="${WORKDIR}/hal-0.5.11-patches/" \
+ EPATCH_FORCE="yes" \
+ epatch
+
+ eautoreconf
+}
+
+src_compile() {
+ local acpi="$(use_enable acpi)"
+ local backend=
+ local hardware=
+
+ append-flags -rdynamic
+
+ if use kernel_linux ; then
+ backend="linux"
+ elif use kernel_FreeBSD ; then
+ backend="freebsd"
+ else
+ eerror "Invalid backend"
+ fi
+
+ if use kernel_linux ; then
+ if use acpi ; then
+ # Using IBM ACPI and Toshiba ACPI results in double notification as this
+ # was merged into the Linux Kernel 2.6.22
+ if kernel_is lt 2 6 22 ; then
+ acpi="$acpi --enable-acpi-ibm --enable-acpi-toshiba"
+ else
+ acpi="$acpi --disable-acpi-ibm --disable-acpi-toshiba"
+ fi
+
+ acpi="$acpi --enable-acpi-proc --enable-acpi-acpid"
+ else
+ acpi="$acpi --disable-acpi-ibm --disable-acpi-toshiba"
+ acpi="$acpi --disable-acpi-proc --disable-acpi-acpid"
+ fi
+
+ hardware="--with-cpufreq --with-usb-csr --with-keymaps"
+ use arm && hardware="$hardware --enable-omap"
+
+ if use dell ; then
+ hardware="$hardware --with-dell-backlight"
+ else
+ hardware="$hardware --without-dell-backlight"
+ fi
+ else
+ hardware="--without-cpufreq --without-usb-csr --without-keymaps"
+ hardware="$hardware --disable-omap"
+ hardware="$hardware --without-dell-backlight"
+ hardware="$hardware --enable-acpi-ibm --enable-acpi-toshiba"
+ fi
+
+ econf --with-backend=${backend} \
+ --with-os-type=gentoo \
+ --with-pid-file=/var/run/hald.pid \
+ --with-hwdata=/usr/share/misc \
+ --with-socket-dir=/var/run/hald \
+ --enable-umount-helper \
+ --enable-man-pages \
+ --disable-policy-kit \
+ --disable-console-kit \
+ --disable-acl-management \
+ --enable-pci \
+ --enable-sonypic \
+ $(use_enable apm) \
+ $(use_enable arm pmu) \
+ $(use_enable arm omap) \
+ $(use_enable debug verbose-mode) \
+ $(use_enable disk-partition parted) \
+ $(use_enable doc docbook-docs) \
+ $(use_enable doc doxygen-docs) \
+ --docdir=/usr/share/doc/${PF} \
+ --localstatedir=/var \
+ ${acpi} ${hardware} \
+ || die "configure failed"
+
+ emake || die "make failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog NEWS README
+
+ # hal umount for unclean unmounts
+ exeinto /lib/udev/
+ newexe "${FILESDIR}/hal-unmount.dev" hal_unmount
+
+ # initscript
+ newinitd "${FILESDIR}/0.5.10-hald.rc" hald
+
+ # configuration
+ cp "${FILESDIR}/0.5.10-hald.conf" "${WORKDIR}/"
+
+ if use debug; then
+ sed -e 's:HALD_VERBOSE="no":HALD_VERBOSE="yes":' \
+ -i "${WORKDIR}/0.5.10-hald.conf"
+ fi
+ newconfd "${WORKDIR}/0.5.10-hald.conf" hald
+
+ # New Configuration Snippets
+ dodoc "${WORKDIR}"/hal-0.5.10-extras/*.fdi
+ dobin "${WORKDIR}"/hal-0.5.10-extras/migrate-xorg-to-fdi.py
+
+ # Authomagic conversion!
+ elog "Migrating xorg.conf Core Keyboard configuration to HAL FDI file..."
+ "${WORKDIR}/hal-0.5.10-extras/migrate-xorg-to-fdi.py" 2> /dev/null > "${D}/etc/hal/fdi/policy/10-x11-input.fdi"
+
+ # We now create and keep /media here as both gnome-mount and pmount
+ # use these directories, to avoid collision.
+ keepdir /media
+
+ # We also need to create and keep /etc/fdi/{information,policy,preprobe}
+ # or else hal bombs.
+ keepdir /etc/hal/fdi/{information,policy,preprobe}
+
+ # HAL stores it's fdi cache in /var/lib/cache/hald
+ keepdir /var/lib/cache/hald
+
+ # HAL keeps its unix socket here
+ keepdir /var/run/hald
+ keepdir /var/lib/hal
+}
+
+pkg_postinst() {
+ # Despite what people keep changing this location. Either one works.. it doesn't matter
+ # http://dev.gentoo.org/~plasmaroo/devmanual/ebuild-writing/functions/
+
+ elog "The HAL daemon needs to be running for certain applications to"
+ elog "work. Suggested is to add the init script to your start-up"
+ elog "scripts, this should be done like this :"
+ elog "\`rc-update add hald default\`"
+ echo
+ elog "Looking for automounting support? Add yourself to the plugdev group"
+ echo
+ elog "IF you have additional applications which consume ACPI events, you"
+ elog "should consider installing acpid to allow applications to share ACPI"
+ elog "events."
+ echo
+ elog "If you wish to use a non US layout, you may do so by executing:"
+ elog "setxkbmap <layout> or by utilizing your Desktop Environment's"
+ elog "Keyboard Layout Settings mechanism."
+ elog "Under GNOME, this is gnome-keyboard-properties, and under KDE"
+ elog "it is kxkb."
+ echo
+ elog "In order have suspend/hibernate function with HAL or apps that use HAL"
+ elog "(such as gnome-power-manager), you should build HAL with the laptop"
+ elog "useflag which will install pm-utils."
+ echo
+ elog "X Input Hotplugging (if you build xorg-server with the HAL useflag)"
+ elog "reads user specific configuration from /etc/hal/fdi/policy/."
+ if [[ $(cat "${ROOT}etc/hal/fdi/policy/10-x11-input.fdi" | wc -c) -gt 0 ]]
+ then
+ elog "We have converted your existing xorg.conf rules and the FDI is stored"
+ elog "at /etc/hal/fdi/policy/10-x11-input.fdi"
+ fi
+ elog "You should remove the Input sections from your xorg.conf once you have"
+ elog "migrated the rules to a HAL fdi file."
+
+ ebeep 5
+ epause 5
+}