summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/hal/hal-0.5.10-r1.ebuild')
-rw-r--r--sys-apps/hal/hal-0.5.10-r1.ebuild10
1 files changed, 9 insertions, 1 deletions
diff --git a/sys-apps/hal/hal-0.5.10-r1.ebuild b/sys-apps/hal/hal-0.5.10-r1.ebuild
index a2a317a..bcb944c 100644
--- a/sys-apps/hal/hal-0.5.10-r1.ebuild
+++ b/sys-apps/hal/hal-0.5.10-r1.ebuild
@@ -266,7 +266,7 @@ src_install() {
dodoc "${WORKDIR}"/hal-0.5.10-extras/*
# Authomagic conversion!
- einfo "Migrating xorg.conf..."
+ elog "Migrating xorg.conf Core Keyboard configuration to HAL FDI file..."
"${WORKDIR}/hal-0.5.10-extras/migrate-xorg-to-fdi.py" 2> /dev/null > "${D}/etc/hal/fdi/policy/10-x11-input.fdi"
# We now create and keep /media here as both gnome-mount and pmount
@@ -309,4 +309,12 @@ pkg_postinst() {
elog "In order have suspend/hibernate function with HAL or apps that use HAL"
elog "(such as gnome-power-manager), you should build HAL with the laptop"
elog "useflag which will install pm-utils."
+
+ elog "X Input Hotplugging (if you build xorg-server with the HAL useflag)"
+ elog "reads user specific configuration from /etc/hal/fdi/policy/."
+ if [[ $(cat ${ROOT}etc/hal/fdi/policy/10-x11-input.fdi | wc -c) -gt 0 ]]
+ then
+ elog "We have converted your existing xorg.conf rules and is stored"
+ elog "in /etc/hal/fdi/policy/10-x11-input.fdi"
+ fi
}