aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/plan9port/Manifest2
-rw-r--r--dev-util/plan9port/plan9port-99999999.ebuild75
2 files changed, 77 insertions, 0 deletions
diff --git a/dev-util/plan9port/Manifest b/dev-util/plan9port/Manifest
new file mode 100644
index 0000000..c73e391
--- /dev/null
+++ b/dev-util/plan9port/Manifest
@@ -0,0 +1,2 @@
+DIST plan9port.tgz 53848055 RMD160 36affa5d4f636dd853bd1a5e837c6fac9c03fc7f SHA1 de1a5c65bc907bc27036ddf7b518cccc40cf4908 SHA256 79bd0d7a82a18b44bde3da997129a6e92ad8153ef9852c9aa5e14eb6965fe7c3
+EBUILD plan9port-99999999.ebuild 2165 RMD160 26214b7da32c6285601006faaf02dbf4f8cf0acd SHA1 c1d8b01d81990d1a1db9f8c49f6cf252aa449e47 SHA256 997b099310eaddd72b40b14dde4ef4e85eb38fa26410b9af4d4e8eea94d35310
diff --git a/dev-util/plan9port/plan9port-99999999.ebuild b/dev-util/plan9port/plan9port-99999999.ebuild
new file mode 100644
index 0000000..e118ddf
--- /dev/null
+++ b/dev-util/plan9port/plan9port-99999999.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/plan9port/plan9port-20080130.ebuild,v 1.1 2008/03/11 13:03:53 coldwind Exp $
+
+EAPI="4"
+
+inherit eutils
+
+DESCRIPTION="Port of many Plan 9 programs and libraries"
+HOMEPAGE="http://swtch.com/plan9port/"
+SRC_URI="http://swtch.com/plan9port/plan9port.tgz"
+
+LICENSE="9base"
+SLOT="0"
+KEYWORDS="~amd64 x86"
+IUSE=""
+
+DEPEND="x11-apps/xauth"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/plan9"
+
+PLAN9=/usr/lib/plan9
+
+src_prepare()
+{
+ #epatch "${FILESDIR}/${PN}-"{9660srv-errno,no-lex,noexecstack}".patch"
+
+ # Fix paths, done in place of ./INSTALL -c
+ einfo "Fixing hard-coded /usr/local/plan9 paths"
+ find -type f -exec sed -i "s!/usr/local/plan9!${PLAN9}!g" "{}" ";"
+}
+
+src_compile() {
+ # Convert -j5 to NPROC=5 for mk
+ export NPROC="$(echo "$MAKEOPTS" | sed -r -n 's/.*(^| )-j([0-9]*).*/\2/p')"
+
+ # The INSTALL script builds mk then [re]builds everything using that
+ einfo "Compiling Plan 9 from User Space can take a very long time"
+ einfo "depending on the speed of your computer. Please be patient!"
+ ./INSTALL -b
+}
+
+src_install() {
+ dodir "${PLAN9}"
+
+ # P9P's man does not handle compression
+ docompress -x $PLAN9/man
+
+ # do* plays with the executable bit, and we should not modify them
+ cp -a * "${D}/${PLAN9}"
+
+ # build the environment variables and install them in env.d
+ cat > "${T}/30plan9" <<-EOF
+ PLAN9="${PLAN9}"
+ PATH="${PLAN9}/bin"
+ ROOTPATH="${PLAN9}/bin"
+ MANPATH="${PLAN9}/man"
+ EOF
+ doenvd "${T}/30plan9"
+}
+
+pkg_postinst() {
+ elog "Plan 9 from User Space has been successfully installed into"
+ elog "${PLAN9}. Your PLAN9 and PATH environment variables have"
+ elog "also been appropriately set, please use env-update and"
+ elog "source /etc/profile to bring that into immediate effect."
+ elog
+ elog "Please note that ${PLAN9}/bin has been appended to the"
+ elog "*end* or your PATH to prevent conflicts. To use the Plan9"
+ elog "versions of common UNIX tools, use the absolute path:"
+ elog "${PLAN9}/bin or the 9 command (eg: 9 troff)"
+ elog
+ elog "Please report any bugs to bugs.gentoo.org, NOT Plan9Port."
+}