summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-crypt/seahorse-plugins/Manifest2
-rw-r--r--app-crypt/seahorse-plugins/seahorse-plugins-9999.ebuild48
-rw-r--r--app-crypt/seahorse/Manifest2
-rw-r--r--app-crypt/seahorse/seahorse-9999.ebuild34
4 files changed, 46 insertions, 40 deletions
diff --git a/app-crypt/seahorse-plugins/Manifest b/app-crypt/seahorse-plugins/Manifest
index 86dfe67..93bd8da 100644
--- a/app-crypt/seahorse-plugins/Manifest
+++ b/app-crypt/seahorse-plugins/Manifest
@@ -1,2 +1,2 @@
AUX 70-seahorse-agent 241 RMD160 d28490016ed259ef29416cb101ccddd76e195ed5 SHA1 2b40525f543741dc0a453a8241e3b7c83f45da6f SHA256 2e70cbb034fde8ddd5c69baf97570ad706bec2e04bd7dd2c86f462b9a594e3c6
-EBUILD seahorse-plugins-9999.ebuild 1770 RMD160 74305a605e49b0e198be08fc5e44dcc0522a98cb SHA1 14b41c806e8a063a5ba0ea2708e2d50fe9564be7 SHA256 f02d98557a42603fd7a11f7a0c6dc2c9d56e58de64cdc2e29a55b274290d0f50
+EBUILD seahorse-plugins-9999.ebuild 1843 RMD160 d9e6778085a9e1a52efe9f010e9b2bd3d845293a SHA1 f87bed09d86b5dfe2eb39a859745c67665602cc3 SHA256 c54756407fb96fd0027576a91e4a76f5a3203daef58940b6c7c11c9e8c948a5f
diff --git a/app-crypt/seahorse-plugins/seahorse-plugins-9999.ebuild b/app-crypt/seahorse-plugins/seahorse-plugins-9999.ebuild
index 803611a..b1e7f33 100644
--- a/app-crypt/seahorse-plugins/seahorse-plugins-9999.ebuild
+++ b/app-crypt/seahorse-plugins/seahorse-plugins-9999.ebuild
@@ -1,54 +1,54 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-MODPATH="seahorse/${PN}/trunk"
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/seahorse-plugins/seahorse-plugins-2.26.1.ebuild,v 1.1 2009/05/14 09:18:18 nirbheek Exp $
inherit gnome2 gnome2-live
DESCRIPTION="A GNOME application for managing encryption keys"
-HOMEPAGE="http://www.gnome.org/projects/seahorse/"
+HOMEPAGE="http://www.gnome.org/projects/seahorse/index.html"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="applet debug epiphany gedit libnotify nautilus test xulrunner"
+IUSE="applet debug epiphany gedit libnotify nautilus test"
RDEPEND="
>=gnome-base/libglade-2.0
>=gnome-base/gconf-2.0
>=x11-libs/gtk+-2.10
>=dev-libs/glib-2.16
+ >=dev-libs/dbus-glib-0.72
+ >=app-crypt/gpgme-1.0.0
+ >=app-crypt/seahorse-2.25
+ >=gnome-base/gnome-keyring-2.25
+ >=gnome-extra/evolution-data-server-1.8
+
|| (
=app-crypt/gnupg-1.4*
=app-crypt/gnupg-2.0* )
- >=app-crypt/gpgme-1.0.0
+
nautilus? ( >=gnome-base/nautilus-2.12 )
- >=gnome-base/gnome-keyring-2.23.6
- >=dev-libs/dbus-glib-0.72
epiphany? (
- >=www-client/epiphany-2.22
- xulrunner? ( =net-libs/xulrunner-1.8* )
- !xulrunner? ( =www-client/mozilla-firefox-2* )
+ >=www-client/epiphany-2.24
>=dev-libs/libxml2-2.6.0 )
gedit? ( >=app-editors/gedit-2.16 )
applet? ( >=gnome-base/gnome-panel-2.10 )
- >=app-crypt/seahorse-2.23.92
- libnotify? ( >=x11-libs/libnotify-0.3.2 )
- >=gnome-extra/evolution-data-server-1.8"
+ libnotify? ( >=x11-libs/libnotify-0.3.2 )"
DEPEND="${RDEPEND}
- sys-devel/gettext
- >=app-text/gnome-doc-utils-0.3.2
- >=app-text/scrollkeeper-0.3
- >=dev-util/pkgconfig-0.20
- >=dev-util/intltool-0.35"
+ sys-devel/gettext
+ >=app-text/gnome-doc-utils-0.3.2
+ >=app-text/scrollkeeper-0.3
+ >=dev-util/pkgconfig-0.20
+ >=dev-util/intltool-0.35"
pkg_setup() {
if use epiphany ; then
- if use xulrunner ; then
- G2CONF="${G2CONF} --with-gecko=xulrunner"
+ if has_version '>=www-client/epiphany-2.24.3-r10'; then
+ G2CONF="${G2CONF} --with-gecko=libxul-unstable"
else
- G2CONF="${G2CONF} --with-gecko=firefox"
+ # Now, epiphany could be using xul-1.8, xul-1.9 or ff-2
+ # Let it auto-detect.
+ :
fi
fi
@@ -68,5 +68,5 @@ src_install() {
gnome2_src_install
exeinto /etc/X11/xinit/xinitrc.d/
- doexe "${FILESDIR}/70-seahorse-agent" || die "doexe failed"
+ doexe "${FILESDIR}/70-seahorse-agent" || die "doexe failed"
}
diff --git a/app-crypt/seahorse/Manifest b/app-crypt/seahorse/Manifest
index a523398..ea49ad9 100644
--- a/app-crypt/seahorse/Manifest
+++ b/app-crypt/seahorse/Manifest
@@ -1 +1 @@
-EBUILD seahorse-9999.ebuild 1417 RMD160 156b9ccaa3e49205990269c8ee5fa2d406b66bb4 SHA1 bb521507300370162e535d57cad04ff8c5a89ef5 SHA256 289f69e6cf1eddac35c22d7fc9db8afab2e02b3435d47e54ad9ada2bce788ac5
+EBUILD seahorse-9999.ebuild 1667 RMD160 d36ea8b841524b52c75b4b6dc545d5756775939b SHA1 0ebfea034999571299361d3f27e32e0b6b996760 SHA256 77e6507ec20d6840c4382d1cde52ed18302a91a4cc4cf1a3a322867b4e1fb81c
diff --git a/app-crypt/seahorse/seahorse-9999.ebuild b/app-crypt/seahorse/seahorse-9999.ebuild
index 3142995..e7af9e0 100644
--- a/app-crypt/seahorse/seahorse-9999.ebuild
+++ b/app-crypt/seahorse/seahorse-9999.ebuild
@@ -1,41 +1,44 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/seahorse/seahorse-2.26.1.ebuild,v 1.1 2009/05/14 08:53:16 nirbheek Exp $
EAPI="1"
-inherit eutils gnome2 gnome2-live
+inherit gnome2 gnome2-live
DESCRIPTION="A GNOME application for managing encryption keys"
-HOMEPAGE="http://www.gnome.org/projects/seahorse/"
+HOMEPAGE="http://www.gnome.org/projects/seahorse/index.html"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="avahi debug ldap libnotify"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="avahi debug doc ldap libnotify test"
RDEPEND=">=gnome-base/libglade-2.0
>=gnome-base/gconf-2.0
>=dev-libs/glib-2.10
>=x11-libs/gtk+-2.10
+ >=dev-libs/dbus-glib-0.72
+ >=gnome-base/gnome-keyring-2.25.5
net-libs/libsoup:2.4
+ x11-misc/shared-mime-info
+
+ net-misc/openssh
+ >=app-crypt/gpgme-1.0.0
|| (
=app-crypt/gnupg-1.4*
=app-crypt/gnupg-2.0* )
- >=app-crypt/gpgme-1.0.0
- net-misc/openssh
+
avahi? ( >=net-dns/avahi-0.6 )
- >=dev-libs/dbus-glib-0.72
- >=gnome-base/gnome-keyring-2.23.6
ldap? ( net-nds/openldap )
- libnotify? ( >=x11-libs/libnotify-0.3.2 )
- x11-misc/shared-mime-info"
+ libnotify? ( >=x11-libs/libnotify-0.3.2 )"
DEPEND="${RDEPEND}
sys-devel/gettext
>=app-text/gnome-doc-utils-0.3.2
>=app-text/scrollkeeper-0.3
>=dev-util/pkgconfig-0.20
- >=dev-util/intltool-0.35"
+ >=dev-util/intltool-0.35
+ doc? ( >=dev-util/gtk-doc-1.9 )"
DOCS="AUTHORS ChangeLog NEWS README TODO THANKS"
@@ -50,10 +53,13 @@ pkg_setup() {
$(use_enable avahi sharing)
$(use_enable debug)
$(use_enable ldap)
- $(use_enable libnotify)"
+ $(use_enable libnotify)
+ $(use_enable test tests)"
}
pkg_postinst() {
einfo "The seahorse-agent tool has been moved to app-crypt/seahorse-plugins"
einfo "Use that if you want seahorse to manage your terminal SSH keys"
+
+ gnome2-live_pkg_postinst
}