summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2019-02-24 14:22:36 +0200
committerMart Raudsepp <leio@gentoo.org>2019-02-24 14:22:36 +0200
commit0a86a60b478f31b585276b61baebf6a19b4d540a (patch)
tree5e02d0da6fefa16042c3b09d7e8fc6b57c1c498f
parentgnome2-live.eclass: Update repo URI to gitlab (diff)
downloadgnome-0a86a60b478f31b585276b61baebf6a19b4d540a.tar.gz
gnome-0a86a60b478f31b585276b61baebf6a19b4d540a.tar.bz2
gnome-0a86a60b478f31b585276b61baebf6a19b4d540a.zip
x11-misc/colord: remove outdated live ebuild
Upstream uses meson now and it's hosted elsewhere than the ebuild had as repo location. Signed-off-by: Mart Raudsepp <leio@gentoo.org>
-rw-r--r--x11-misc/colord/colord-9999.ebuild152
-rw-r--r--x11-misc/colord/metadata.xml15
2 files changed, 0 insertions, 167 deletions
diff --git a/x11-misc/colord/colord-9999.ebuild b/x11-misc/colord/colord-9999.ebuild
deleted file mode 100644
index ac125cb8..00000000
--- a/x11-misc/colord/colord-9999.ebuild
+++ /dev/null
@@ -1,152 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="5"
-GCONF_DEBUG="no"
-GNOME2_LA_PUNT="yes"
-VALA_USE_DEPEND="vapigen"
-VALA_MIN_API_VERSION="0.18"
-
-inherit bash-completion-r1 check-reqs eutils gnome2 user systemd udev vala
-if [[ ${PV} = 9999 ]]; then
- GCONF_DEBUG="no"
- inherit gnome2-live # need all the hacks from gnome2-live_src_prepare
-fi
-
-DESCRIPTION="System service to accurately color manage input and output devices"
-HOMEPAGE="http://www.freedesktop.org/software/colord/"
-if [[ ${PV} = 9999 ]]; then
- EGIT_REPO_URI="git://gitorious.org/colord/master.git"
-else
- SRC_URI="http://www.freedesktop.org/software/colord/releases/${P}.tar.xz"
-fi
-
-LICENSE="GPL-2+"
-SLOT="0/2" # subslot = libcolord soname version
-
-# We prefer policykit enabled by default, bug #448058
-IUSE="examples extra-print-profiles +gusb +introspection +policykit scanner systemd +udev vala"
-REQUIRED_USE="
- gusb? ( udev )
- scanner? ( udev )
- vala? ( introspection )
-"
-if [[ ${PV} = 9999 ]]; then
- KEYWORDS=""
- IUSE="${IUSE} doc"
-else
- KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
-fi
-
-COMMON_DEPEND="
- dev-db/sqlite:3=
- >=dev-libs/glib-2.36:2
- >=media-libs/lcms-2.6:2=
- gusb? ( >=dev-libs/libgusb-0.1.1[introspection?] )
- introspection? ( >=dev-libs/gobject-introspection-0.9.8 )
- policykit? ( >=sys-auth/polkit-0.103 )
- scanner? ( media-gfx/sane-backends )
- systemd? ( >=sys-apps/systemd-44:0= )
- udev? (
- virtual/udev
- virtual/libgudev:=
- virtual/libudev:=
- )
-"
-RDEPEND="${COMMON_DEPEND}
- !media-gfx/shared-color-profiles
- !<=media-gfx/colorhug-client-0.1.13
-"
-DEPEND="${COMMON_DEPEND}
- dev-libs/libxslt
- >=dev-util/gtk-doc-am-1.9
- >=dev-util/intltool-0.35
- >=sys-devel/gettext-0.17
- virtual/pkgconfig
- extra-print-profiles? ( media-gfx/argyllcms )
- vala? ( $(vala_depend) )
-"
-if [[ ${PV} =~ 9999 ]]; then
- # Needed for generating man pages, not needed for tarballs
- DEPEND="${DEPEND}
- app-text/docbook-sgml-utils
- doc? (
- app-text/docbook-xml-dtd:4.1.2
- >=dev-util/gtk-doc-1.9 )"
-fi
-
-# FIXME: needs pre-installed dbus service files
-RESTRICT="test"
-
-# According to upstream comment in colord.spec.in, building the extra print
-# profiles requires >=4G of memory
-CHECKREQS_MEMORY="4G"
-
-pkg_pretend() {
- use extra-print-profiles && check-reqs_pkg_pretend
-}
-
-pkg_setup() {
- use extra-print-profiles && check-reqs_pkg_setup
- enewgroup colord
- enewuser colord -1 -1 /var/lib/colord colord
-}
-
-src_prepare() {
- # Adapt to Gentoo paths
- sed -i -e 's/spotread/argyll-spotread/' src/sensors/cd-sensor-argyll.c || die
-
- use vala && vala_src_prepare
- gnome2_src_prepare
-}
-
-src_configure() {
- local myconf=""
- [[ ${PV} = 9999 ]] && myconf="${myconf} $(use_enable doc gtk-doc)"
- # Reverse tools require gusb
- # bash-completion test does not work on gentoo
- gnome2_src_configure \
- --disable-bash-completion \
- --disable-examples \
- --disable-static \
- --enable-libcolordcompat \
- --with-daemon-user=colord \
- --localstatedir="${EPREFIX}"/var \
- $(use_enable extra-print-profiles print-profiles) \
- $(usex extra-print-profiles COLPROF="$(type -P argyll-colprof)" "") \
- $(use_enable gusb) \
- $(use_enable gusb reverse) \
- $(use_enable introspection) \
- $(use_enable policykit polkit) \
- $(use_enable scanner sane) \
- $(use_enable systemd systemd-login) \
- $(use_enable udev) \
- --with-udevrulesdir="$(get_udevdir)"/rules.d \
- $(use_enable vala) \
- "$(systemd_with_unitdir)" \
- ${myconf}
-
- if [[ ${PV} = 9999 ]]; then
- # parallel make fails in doc/api
- use doc && MAKEOPTS="${MAKEOPTS} -j1"
- fi
-}
-
-src_install() {
- DOCS="AUTHORS ChangeLog MAINTAINERS NEWS README.md TODO"
- gnome2_src_install
-
- newbashcomp data/colormgr colormgr
- rm -vr "${ED}etc/bash_completion.d"
-
- # Ensure config and profile directories exist and /var/lib/colord/*
- # is writable by colord user
- keepdir /var/lib/color{,d}/icc
- fowners colord:colord /var/lib/colord{,/icc}
-
- if use examples; then
- insinto /usr/share/doc/${PF}/examples
- doins examples/*.c
- fi
-}
diff --git a/x11-misc/colord/metadata.xml b/x11-misc/colord/metadata.xml
deleted file mode 100644
index 2ca10f47..00000000
--- a/x11-misc/colord/metadata.xml
+++ /dev/null
@@ -1,15 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>gnome@gentoo.org</email>
- <name>Gentoo GNOME Desktop</name>
- </maintainer>
- <use>
- <flag name="argyllcms">Enable ArgyllCMS sensor</flag>
- <flag name="extra-print-profiles">Generate extra print profiles.
- Warning: significant build time and memory requirements.</flag>
- <flag name="gusb">Enable <pkg>dev-libs/libgusb</pkg> support, needed for
- colorimeter drivers</flag>
- </use>
-</pkgmetadata>