summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOle Reifschneider <tranquility@gentoo.org>2018-04-15 20:59:19 +0200
committerOle Reifschneider <tranquility@gentoo.org>2018-04-15 20:59:19 +0200
commit701322756148546c3ae0c7171be359a1256c2079 (patch)
treef759ac2a87e00ff31035483fe7b56ba8f5bf9094
parentgnome-base/gnome-core-libs: Bump version to 3.26.2 (diff)
downloadgnome-701322756148546c3ae0c7171be359a1256c2079.tar.gz
gnome-701322756148546c3ae0c7171be359a1256c2079.tar.bz2
gnome-701322756148546c3ae0c7171be359a1256c2079.zip
gnome-base/gnome-light: Bump version to 3.26.1
Package-Manager: Portage-2.3.28, Repoman-2.3.9 Manifest-Sign-Key: 0xE9E568677E8B4D42
-rw-r--r--gnome-base/gnome-light/gnome-light-3.26.1.ebuild59
-rw-r--r--gnome-base/gnome-light/metadata.xml12
2 files changed, 71 insertions, 0 deletions
diff --git a/gnome-base/gnome-light/gnome-light-3.26.1.ebuild b/gnome-base/gnome-light/gnome-light-3.26.1.ebuild
new file mode 100644
index 00000000..b7c56e23
--- /dev/null
+++ b/gnome-base/gnome-light/gnome-light-3.26.1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit versionator
+
+P_RELEASE="$(get_version_components 2)"
+
+DESCRIPTION="Meta package for GNOME-Light, merge this package to install"
+HOMEPAGE="https://www.gnome.org/"
+LICENSE="metapackage"
+SLOT="2.0"
+IUSE="cups +gnome-shell"
+
+# when unmasking for an arch
+# double check none of the deps are still masked !
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~x86"
+
+# XXX: Note to developers:
+# This is a wrapper for the 'light' GNOME 3 desktop, and should only consist of
+# the bare minimum of libs/apps needed. It is basically gnome-base/gnome without
+# any apps, but shouldn't be used by users unless they know what they are doing.
+RDEPEND="!gnome-base/gnome
+ >=gnome-base/gnome-core-libs-${PV}[cups?]
+
+ >=gnome-base/gnome-session-${PV}
+ >=gnome-base/gnome-settings-daemon-${PV}[cups?]
+ >=gnome-base/gnome-control-center-${PV}[cups?]
+
+ >=gnome-base/nautilus-${PV}
+
+ gnome-shell? (
+ >=x11-wm/mutter-${PV}
+ >=gnome-base/gnome-shell-${PV} )
+
+ >=x11-themes/adwaita-icon-theme-${P_RELEASE}
+ >=x11-themes/gnome-themes-standard-3.22.3
+ >=x11-themes/gnome-backgrounds-${P_RELEASE}
+
+ >=x11-terms/gnome-terminal-${PV}
+"
+DEPEND=""
+PDEPEND=">=gnome-base/gvfs-1.32.1"
+S="${WORKDIR}"
+
+pkg_pretend() {
+ if ! use gnome-shell; then
+ # Users probably want to use e16, sawfish, etc
+ ewarn "You're not installing GNOME Shell"
+ ewarn "You will have to install and manage a window manager by yourself"
+ fi
+}
+
+pkg_postinst() {
+ # Remember people where to find our project information
+ elog "Please remember to look at https://wiki.gentoo.org/wiki/Project:GNOME"
+ elog "for information about the project and documentation."
+}
diff --git a/gnome-base/gnome-light/metadata.xml b/gnome-base/gnome-light/metadata.xml
new file mode 100644
index 00000000..b0d8e7f7
--- /dev/null
+++ b/gnome-base/gnome-light/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>gnome@gentoo.org</email>
+ <name>Gentoo GNOME Desktop</name>
+</maintainer>
+<use>
+ <flag name="gnome-shell">Install <pkg>gnome-base/gnome-shell</pkg> and
+ <pkg>x11-wm/mutter</pkg> for the standard GNOME 3 desktop mode</flag>
+</use>
+</pkgmetadata>