summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSobhan Mohammadpour <sobhan@gentoo.org>2018-10-09 23:01:02 +0330
committerSobhan Mohammadpour <sobhan@gentoo.org>2018-10-09 23:01:02 +0330
commita17cc07893b943215811c965b28ed672f1a69d91 (patch)
treee0bff8fac5c160eadfe249d1e27cf1fe84489e13
parentx11-terms/gnome-terminal-9999: sync in dep updates from 3.30.1 (diff)
downloadgnome-a17cc07893b943215811c965b28ed672f1a69d91.tar.gz
gnome-a17cc07893b943215811c965b28ed672f1a69d91.tar.bz2
gnome-a17cc07893b943215811c965b28ed672f1a69d91.zip
sys-apps/bubblewrap: new ebuild
imported from "foo-overlay" /var/lib/layman/foo-overlay. test don't work but the package seems to work
-rw-r--r--sys-apps/bubblewrap/bubblewrap-0.3.1.ebuild51
-rw-r--r--sys-apps/bubblewrap/metadata.xml8
2 files changed, 59 insertions, 0 deletions
diff --git a/sys-apps/bubblewrap/bubblewrap-0.3.1.ebuild b/sys-apps/bubblewrap/bubblewrap-0.3.1.ebuild
new file mode 100644
index 00000000..dde2efec
--- /dev/null
+++ b/sys-apps/bubblewrap/bubblewrap-0.3.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="7"
+
+inherit autotools bash-completion-r1 linux-info
+
+DESCRIPTION="Unprivileged sandboxing tool, namespaces-powered chroot-like solution"
+HOMEPAGE="https://github.com/projectatomic/bubblewrap"
+SRC_URI="https://github.com/projectatomic/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="selinux"
+
+DEPEND="
+ dev-libs/libxslt
+ sys-libs/libseccomp
+ sys-libs/libcap
+ selinux? ( >=sys-libs/libselinux-2.1.9 )
+"
+# FIXME: we don't need bashcomp righ??
+RDEPEND="${DEPEND}"
+# FIXME: bash comp is not working
+# FIXME: test is not working
+pkg_setup() {
+ if [[ ${MERGE_TYPE} != buildonly ]]; then
+ CONFIG_CHECK="~UTS_NS ~IPC_NS ~USER_NS ~PID_NS ~NET_NS"
+ linux-info_pkg_setup
+ fi
+}
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+
+ econf \
+ $(use_enable selinux) \
+ "--enable-man" \
+ "--with-bash-completion-dir=${get_bashcompdir}" \
+ "--with-priv-mode=none"
+}
+
+pkg_postinst() {
+ einfo "bashcomp can be used with >=app-shells/bash-completion-2.0"
+ einfo "probably needs namespaces"
+}
diff --git a/sys-apps/bubblewrap/metadata.xml b/sys-apps/bubblewrap/metadata.xml
new file mode 100644
index 00000000..39980802
--- /dev/null
+++ b/sys-apps/bubblewrap/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>gnome@gentoo.org</email>
+ <name>Gentoo GNOME Desktop</name>
+</maintainer>
+</pkgmetadata>