summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2018-12-11 14:13:32 +0100
committerGilles Dartiguelongue <eva@gentoo.org>2018-12-11 14:13:40 +0100
commitb2cc62b2025b163bef0d11dd8df8210f86030eaa (patch)
treee0f6dfc96676d7388696ca431b2a72216db80f06
parentgnome-extra/gnome-power-manager: sync live ebuild with ::gentoo (diff)
downloadgnome-b2cc62b2025b163bef0d11dd8df8210f86030eaa.tar.gz
gnome-b2cc62b2025b163bef0d11dd8df8210f86030eaa.tar.bz2
gnome-b2cc62b2025b163bef0d11dd8df8210f86030eaa.zip
gnome-extra/gnome-documents: update live ebuild
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Manifest-Sign-Key: 0x5A56C8CD0C13248A Signed-off-by: Gilles Dartiguelongue <eva@gentoo.org>
-rw-r--r--gnome-extra/gnome-documents/gnome-documents-9999.ebuild53
1 files changed, 36 insertions, 17 deletions
diff --git a/gnome-extra/gnome-documents/gnome-documents-9999.ebuild b/gnome-extra/gnome-documents/gnome-documents-9999.ebuild
index 77c590d8..2d8cee6a 100644
--- a/gnome-extra/gnome-documents/gnome-documents-9999.ebuild
+++ b/gnome-extra/gnome-documents/gnome-documents-9999.ebuild
@@ -1,10 +1,12 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit gnome2
+inherit gnome.org gnome2-utils meson xdg
if [[ ${PV} = 9999 ]]; then
- inherit gnome2-live
+ inherit git-r3
+ SRC_URI=""
+ EGIT_REPO_URI="https://gitlab.gnome.org/GNOME/${GNOME_ORG_MODULE}"
fi
DESCRIPTION="A document manager application for GNOME"
@@ -21,22 +23,22 @@ fi
# cairo-1.14 for cairo_surface_set_device_scale check and usage
COMMON_DEPEND="
- >=app-text/evince-3.13.3[introspection]
- >=net-libs/webkit-gtk-2.6:4[introspection]
>=dev-libs/gjs-1.48
+ >=app-text/evince-3.13.3[introspection]
>=dev-libs/glib-2.39.3:2
+ gnome-base/gnome-desktop:3=[introspection]
>=dev-libs/gobject-introspection-1.31.6:=
>=x11-libs/gtk+-3.22.15:3[introspection]
>=net-libs/libsoup-2.41.3:2.4
- gnome-base/gnome-desktop:3=[introspection]
>=app-misc/tracker-2:=
- >=x11-libs/cairo-1.14
+ >=net-libs/webkit-gtk-2.6:4[introspection]
+
>=dev-libs/libgdata-0.13.3:=[crypt,gnome-online-accounts,introspection]
- x11-libs/gdk-pixbuf:2[introspection]
+ >=app-text/libgepub-0.6[introspection]
>=net-libs/gnome-online-accounts-3.2.0[introspection]
- x11-libs/pango[introspection]
>=net-libs/libzapojit-0.0.2[introspection]
- >=app-text/libgepub-0.5[introspection]
+
+ >=x11-libs/cairo-1.14
"
RDEPEND="${COMMON_DEPEND}
>=app-misc/tracker-miners-2[miner-fs]
@@ -44,17 +46,34 @@ RDEPEND="${COMMON_DEPEND}
sys-apps/dbus
x11-themes/adwaita-icon-theme
"
-# libxml2+gdk-pixbuf required for glib-compile-resources
DEPEND="${COMMON_DEPEND}
- dev-libs/libxml2
+ dev-libs/appstream-glib
+ app-text/docbook-xml-dtd:4.2
+ app-text/docbook-xsl-stylesheets
+ dev-libs/libxml2:2
+ x11-libs/gdk-pixbuf:2
dev-libs/libxslt
>=sys-devel/gettext-0.19.8
dev-util/itstool
virtual/pkgconfig
"
-if [[ ${PV} = 9999 ]]; then
- DEPEND="${DEPEND}
- app-text/yelp-tools
- "
-fi
+src_configure() {
+ local emesonargs=(
+ -Ddocumentation=true
+ -Dgetting_started=false
+ )
+ meson_src_configure
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+ gnome2_icon_cache_update
+}