summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2013-12-12 23:41:43 +0100
committerGilles Dartiguelongue <eva@gentoo.org>2013-12-13 00:20:46 +0100
commit35fe897a40b432673c0ed00e7c5a26d75af82bbc (patch)
treef9d5148b9e55787cc32715cdbfa61bc12bb18acd /app-cdr
parentx11-libs/pango: 1.34.1 → 1.36.1 (diff)
downloadgnome-35fe897a40b432673c0ed00e7c5a26d75af82bbc.tar.gz
gnome-35fe897a40b432673c0ed00e7c5a26d75af82bbc.tar.bz2
gnome-35fe897a40b432673c0ed00e7c5a26d75af82bbc.zip
app-cdr/brasero: 3.8.0 → 3.10.0
Diffstat (limited to 'app-cdr')
-rw-r--r--app-cdr/brasero/Manifest11
-rw-r--r--app-cdr/brasero/brasero-3.10.0.ebuild82
-rw-r--r--app-cdr/brasero/brasero-9999.ebuild69
3 files changed, 129 insertions, 33 deletions
diff --git a/app-cdr/brasero/Manifest b/app-cdr/brasero/Manifest
new file mode 100644
index 00000000..6e303288
--- /dev/null
+++ b/app-cdr/brasero/Manifest
@@ -0,0 +1,11 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA512
+
+DIST brasero-3.10.0.tar.xz 3374492 SHA256 88fd9135e796f58caeb484d00f5d95916c67f97505e68d2027ab84d3f9245f37 SHA512 5a9470d983a78f30fb3072cfd4a6c78dc8aeb5a277aacf32cc642282653ed2712cd7dbb1be32e542d0a6029bbfc17a053de5022900a999b202d5dfcdebf64f00 WHIRLPOOL b663e676ae764e835e39c1217435a0a1a0061496bfed6ba3281274c4291e37d84870cd208cc79651ada3dfbcce07f93e3a2ed561239c02ba5bdf0ee09ad45d16
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2.0.22 (GNU/Linux)
+
+iEYEAREKAAYFAlKqO6gACgkQ1fmVwcYIWAaH6gCgwwuOe5PYsKsGGXxFQ0fb0qEm
+/WAAoKaRkrjekfG4fTAHMH2DVgvOTzeK
+=FW5H
+-----END PGP SIGNATURE-----
diff --git a/app-cdr/brasero/brasero-3.10.0.ebuild b/app-cdr/brasero/brasero-3.10.0.ebuild
new file mode 100644
index 00000000..ca325660
--- /dev/null
+++ b/app-cdr/brasero/brasero-3.10.0.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2
+
+DESCRIPTION="CD/DVD burning application for the GNOME desktop"
+HOMEPAGE="http://projects.gnome.org/brasero/"
+
+LICENSE="GPL-2+ CC-BY-SA-3.0"
+SLOT="0/3.1" # subslot is 3.suffix of libbrasero-burn3
+IUSE="+css +introspection +libburn mp3 nautilus packagekit playlist test tracker"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+COMMON_DEPEND="
+ >=dev-libs/glib-2.29.14:2
+ >=x11-libs/gtk+-3:3[introspection?]
+ media-libs/gstreamer:1.0
+ media-libs/gst-plugins-base:1.0
+ >=dev-libs/libxml2-2.6:2
+ >=x11-libs/libnotify-0.6.1:=
+
+ media-libs/libcanberra[gtk3]
+ x11-libs/libICE
+ x11-libs/libSM
+
+ introspection? ( >=dev-libs/gobject-introspection-0.6.3 )
+ libburn? (
+ >=dev-libs/libburn-0.4:=
+ >=dev-libs/libisofs-0.6.4:= )
+ nautilus? ( >=gnome-base/nautilus-2.91.90 )
+ playlist? ( >=dev-libs/totem-pl-parser-2.29.1:= )
+ tracker? ( >=app-misc/tracker-0.12:= )
+"
+RDEPEND="${COMMON_DEPEND}
+ media-libs/gst-plugins-good:1.0
+ media-plugins/gst-plugins-meta:1.0
+ x11-themes/hicolor-icon-theme
+ css? ( media-libs/libdvdcss:1.2 )
+ !libburn? (
+ app-cdr/cdrdao
+ app-cdr/dvd+rw-tools
+ virtual/cdrtools )
+ mp3? (
+ media-libs/gst-plugins-ugly:1.0
+ media-plugins/gst-plugins-mad:1.0 )
+ packagekit? ( app-admin/packagekit-base )
+"
+DEPEND="${COMMON_DEPEND}
+ app-text/yelp-tools
+ dev-util/intltool
+ >=dev-util/gtk-doc-am-1.12
+ gnome-base/gnome-common:3
+ sys-devel/gettext
+ virtual/pkgconfig
+ test? ( app-text/docbook-xml-dtd:4.3 )
+"
+# eautoreconf deps
+# app-text/yelp-tools
+# gnome-base/gnome-common
+
+PDEPEND="gnome-base/gvfs"
+
+src_configure() {
+ DOCS="AUTHORS ChangeLog MAINTAINERS NEWS README"
+ gnome2_src_configure \
+ --disable-caches \
+ $(use_enable !libburn cdrtools) \
+ $(use_enable !libburn cdrkit) \
+ $(use_enable !libburn cdrdao) \
+ $(use_enable !libburn growisofs) \
+ $(use_enable introspection) \
+ $(use_enable libburn libburnia) \
+ $(use_enable nautilus) \
+ $(use_enable playlist) \
+ $(use_enable tracker search) \
+ ITSTOOL=$(type -P true)
+}
diff --git a/app-cdr/brasero/brasero-9999.ebuild b/app-cdr/brasero/brasero-9999.ebuild
index 77a321a4..8030853d 100644
--- a/app-cdr/brasero/brasero-9999.ebuild
+++ b/app-cdr/brasero/brasero-9999.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-EAPI="4"
+EAPI="5"
GCONF_DEBUG="no"
GNOME2_LA_PUNT="yes"
@@ -11,11 +11,11 @@ if [[ ${PV} = 9999 ]]; then
inherit gnome2-live
fi
-DESCRIPTION="Brasero (aka Bonfire) is yet another application to burn CD/DVD for the gnome desktop."
+DESCRIPTION="CD/DVD burning application for the GNOME desktop"
HOMEPAGE="http://projects.gnome.org/brasero/"
-LICENSE="GPL-2"
-SLOT="0"
+LICENSE="GPL-2+ CC-BY-SA-3.0"
+SLOT="0/3.1" # subslot is 3.suffix of libbrasero-burn3
IUSE="+css +introspection +libburn mp3 nautilus packagekit playlist test tracker"
if [[ ${PV} = 9999 ]]; then
IUSE="${IUSE} doc"
@@ -26,11 +26,11 @@ fi
COMMON_DEPEND="
>=dev-libs/glib-2.29.14:2
- >=x11-libs/gtk+-3.0.0:3[introspection?]
+ >=x11-libs/gtk+-3:3[introspection?]
media-libs/gstreamer:1.0
media-libs/gst-plugins-base:1.0
>=dev-libs/libxml2-2.6:2
- >=x11-libs/libnotify-0.6.1
+ >=x11-libs/libnotify-0.6.1:=
media-libs/libcanberra[gtk3]
x11-libs/libICE
@@ -38,13 +38,15 @@ COMMON_DEPEND="
introspection? ( >=dev-libs/gobject-introspection-0.6.3 )
libburn? (
- >=dev-libs/libburn-0.4
- >=dev-libs/libisofs-0.6.4 )
+ >=dev-libs/libburn-0.4:=
+ >=dev-libs/libisofs-0.6.4:= )
nautilus? ( >=gnome-base/nautilus-2.91.90 )
- playlist? ( >=dev-libs/totem-pl-parser-2.29.1 )
- tracker? ( >=app-misc/tracker-0.12 )"
+ playlist? ( >=dev-libs/totem-pl-parser-2.29.1:= )
+ tracker? ( >=app-misc/tracker-0.12:= )
+"
RDEPEND="${COMMON_DEPEND}
media-libs/gst-plugins-good:1.0
+ media-plugins/gst-plugins-meta:1.0
x11-themes/hicolor-icon-theme
css? ( media-libs/libdvdcss:1.2 )
!libburn? (
@@ -54,7 +56,8 @@ RDEPEND="${COMMON_DEPEND}
mp3? (
media-libs/gst-plugins-ugly:1.0
media-plugins/gst-plugins-mad:1.0 )
- packagekit? ( app-admin/packagekit-base )"
+ packagekit? ( app-admin/packagekit-base )
+"
DEPEND="${COMMON_DEPEND}
app-text/yelp-tools
dev-util/intltool
@@ -62,37 +65,37 @@ DEPEND="${COMMON_DEPEND}
gnome-base/gnome-common:3
sys-devel/gettext
virtual/pkgconfig
- test? ( app-text/docbook-xml-dtd:4.3 )"
+ test? ( app-text/docbook-xml-dtd:4.3 )
+"
# eautoreconf deps
+# app-text/yelp-tools
# gnome-base/gnome-common
+
PDEPEND="gnome-base/gvfs"
if [[ ${PV} = 9999 ]]; then
DEPEND="${DEPEND}
+ app-text/yelp-tools
+ gnome-base/gnome-common
doc? ( >=dev-util/gtk-doc-1.12 )"
fi
src_configure() {
- DOCS="AUTHORS ChangeLog MAINTAINERS NEWS README"
- G2CONF="${G2CONF}
- --disable-caches
- $(use_enable !libburn cdrtools)
- $(use_enable !libburn cdrkit)
- $(use_enable !libburn cdrdao)
- $(use_enable !libburn growisofs)
- $(use_enable introspection)
- $(use_enable libburn libburnia)
- $(use_enable nautilus)
- $(use_enable playlist)
- $(use_enable tracker search)"
+ local myconf=""
- gnome2_src_configure
-}
+ [[ ${PV} != 9999 ]] && myconf="${myconf} ITSTOOL=$(type -P true)"
-pkg_postinst() {
- gnome2_pkg_postinst
-
- echo
- elog "If ${PN} doesn't handle some music or video format, please check"
- elog "your USE flags on media-plugins/gst-plugins-meta"
+ DOCS="AUTHORS ChangeLog MAINTAINERS NEWS README"
+ gnome2_src_configure \
+ --disable-caches \
+ $(use_enable !libburn cdrtools) \
+ $(use_enable !libburn cdrkit) \
+ $(use_enable !libburn cdrdao) \
+ $(use_enable !libburn growisofs) \
+ $(use_enable introspection) \
+ $(use_enable libburn libburnia) \
+ $(use_enable nautilus) \
+ $(use_enable playlist) \
+ $(use_enable tracker search) \
+ ${myconf}
}