summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2014-04-20 22:00:07 +0200
committerGilles Dartiguelongue <eva@gentoo.org>2014-04-21 00:55:10 +0200
commitf4d45bc8a7474a2f9915f5ab83c7bb0f521189de (patch)
tree3565b5722ab5ac2d92f84cbe786b8fde414d3ad8 /app-cdr
parentapp-misc/bijiben: 3.10.2 → 3.12.0 (diff)
downloadgnome-f4d45bc8a7474a2f9915f5ab83c7bb0f521189de.tar.gz
gnome-f4d45bc8a7474a2f9915f5ab83c7bb0f521189de.tar.bz2
gnome-f4d45bc8a7474a2f9915f5ab83c7bb0f521189de.zip
app-cdr/brasero: 3.10.0 → 3.11.3
Diffstat (limited to 'app-cdr')
-rw-r--r--app-cdr/brasero/Manifest11
-rw-r--r--app-cdr/brasero/brasero-3.11.3.ebuild92
2 files changed, 103 insertions, 0 deletions
diff --git a/app-cdr/brasero/Manifest b/app-cdr/brasero/Manifest
new file mode 100644
index 00000000..62d07856
--- /dev/null
+++ b/app-cdr/brasero/Manifest
@@ -0,0 +1,11 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA512
+
+DIST brasero-3.11.3.tar.xz 3362000 SHA256 0b6fa557d67845b7a4f9978b565a6769e1a023c397a73f2891a8f1c7c55e2d4c SHA512 ac4e5948c27b0925a0ac9ae1a39afbadd7075cb221ea748750b0c1400489a2dac82fc96f317ab82c1243b29346f4ec889f2b0819e7c2459d79bb771dd9129813 WHIRLPOOL 63593dd8fc7b03fab29dfa3e63224012a80310dc909c165bf7cefc7e967f8f1f3cbbfb0c8fbc24fe8ab944814ccebe4915a7ced57ac8a1e5b60e6dff9e403f67
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2.0.22 (GNU/Linux)
+
+iEYEAREKAAYFAlNUJ0cACgkQ1fmVwcYIWAaJDgCgrRJ9qzw3Ju7BgnVVSJPIQYCj
+Yd0An3/OIZLGipdy0dY581UHnq31W8ay
+=HMLB
+-----END PGP SIGNATURE-----
diff --git a/app-cdr/brasero/brasero-3.11.3.ebuild b/app-cdr/brasero/brasero-3.11.3.ebuild
new file mode 100644
index 00000000..4e4f6459
--- /dev/null
+++ b/app-cdr/brasero/brasero-3.11.3.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit autotools gnome2
+
+DESCRIPTION="CD/DVD burning application for the GNOME desktop"
+HOMEPAGE="http://projects.gnome.org/brasero/"
+
+LICENSE="GPL-2+ CC-BY-SA-3.0"
+SLOT="0/3.1" # subslot is 3.suffix of libbrasero-burn3
+IUSE="+css +introspection +libburn mp3 nautilus packagekit playlist test tracker"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+COMMON_DEPEND="
+ >=dev-libs/glib-2.29.14:2
+ >=x11-libs/gtk+-3:3[introspection?]
+ media-libs/gstreamer:1.0
+ media-libs/gst-plugins-base:1.0
+ >=dev-libs/libxml2-2.6:2
+ >=x11-libs/libnotify-0.6.1:=
+
+ media-libs/libcanberra[gtk3]
+ x11-libs/libICE
+ x11-libs/libSM
+
+ introspection? ( >=dev-libs/gobject-introspection-0.6.3 )
+ libburn? (
+ >=dev-libs/libburn-0.4:=
+ >=dev-libs/libisofs-0.6.4:= )
+ nautilus? ( >=gnome-base/nautilus-2.91.90 )
+ playlist? ( >=dev-libs/totem-pl-parser-2.29.1:= )
+ tracker? ( >=app-misc/tracker-0.12:0= )
+"
+RDEPEND="${COMMON_DEPEND}
+ media-libs/gst-plugins-good:1.0
+ media-plugins/gst-plugins-meta:1.0
+ x11-themes/hicolor-icon-theme
+ css? ( media-libs/libdvdcss:1.2 )
+ !libburn? (
+ app-cdr/cdrdao
+ app-cdr/dvd+rw-tools
+ virtual/cdrtools )
+ mp3? (
+ media-libs/gst-plugins-ugly:1.0
+ media-plugins/gst-plugins-mad:1.0 )
+ packagekit? ( app-admin/packagekit-base )
+"
+DEPEND="${COMMON_DEPEND}
+ app-text/yelp-tools
+ >=dev-util/intltool-0.50
+ >=dev-util/gtk-doc-am-1.12
+ gnome-base/gnome-common:3
+ sys-devel/gettext
+ virtual/pkgconfig
+ test? ( app-text/docbook-xml-dtd:4.3 )
+"
+# eautoreconf deps
+# app-text/yelp-tools
+# gnome-base/gnome-common
+
+PDEPEND="gnome-base/gvfs"
+
+
+src_prepare() {
+ # Allow building against tracker-1.0
+ sed -e 's/\[0\.18\]\]/[0.18], [1.0]]/' \
+ -i configure.ac || die
+
+ eautoreconf
+ gnome2_src_configure
+}
+
+src_configure() {
+ DOCS="AUTHORS ChangeLog MAINTAINERS NEWS README"
+ gnome2_src_configure \
+ --disable-caches \
+ $(use_enable !libburn cdrtools) \
+ $(use_enable !libburn cdrkit) \
+ $(use_enable !libburn cdrdao) \
+ $(use_enable !libburn growisofs) \
+ $(use_enable introspection) \
+ $(use_enable libburn libburnia) \
+ $(use_enable nautilus) \
+ $(use_enable playlist) \
+ $(use_enable tracker search) \
+ ITSTOOL=$(type -P true)
+}