summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@gentoo.org>2012-04-20 06:12:56 +0530
committerNirbheek Chauhan <nirbheek@gentoo.org>2012-04-20 06:12:56 +0530
commit42ab97ce1842e469a0588c0b2e45a24f32429418 (patch)
tree7dcdc3210739ea207cbae73f635ad0a20a817093 /app-dicts
parentdev-libs/gobject-introspection: moved to gx86 + sync 9999 with gx86 (diff)
downloadgnome-42ab97ce1842e469a0588c0b2e45a24f32429418.tar.gz
gnome-42ab97ce1842e469a0588c0b2e45a24f32429418.tar.bz2
gnome-42ab97ce1842e469a0588c0b2e45a24f32429418.zip
gnome-extra/gnome-utils: add all the new split packages as new ebuilds
Diffstat (limited to 'app-dicts')
-rw-r--r--app-dicts/gnome-dictionary/Manifest3
-rw-r--r--app-dicts/gnome-dictionary/gnome-dictionary-3.4.0.ebuild39
-rw-r--r--app-dicts/gnome-dictionary/gnome-dictionary-9999.ebuild39
3 files changed, 81 insertions, 0 deletions
diff --git a/app-dicts/gnome-dictionary/Manifest b/app-dicts/gnome-dictionary/Manifest
new file mode 100644
index 00000000..5f1b1042
--- /dev/null
+++ b/app-dicts/gnome-dictionary/Manifest
@@ -0,0 +1,3 @@
+DIST gnome-dictionary-3.4.0.tar.xz 2155012 RMD160 a562d053cb12d08fad89b4eaa5033801ecfa9ff0 SHA1 4ac5035cf3edbd636ac65dc33f831c8276d4f054 SHA256 70a15987617f5ae39f1fc27f7ed0a039193b4704cef7b89ed3aea30ac38f56af
+EBUILD gnome-dictionary-3.4.0.ebuild 971 RMD160 850a26811dca7654d90d6ac1dd84ceda946c87bb SHA1 f62caefd84098cfca67222c2ba96293ec55ce5eb SHA256 74ea486414437fe2fbfca54026dffd2e8838120381869f8dc3b7d6011fcc81d3
+EBUILD gnome-dictionary-9999.ebuild 971 RMD160 850a26811dca7654d90d6ac1dd84ceda946c87bb SHA1 f62caefd84098cfca67222c2ba96293ec55ce5eb SHA256 74ea486414437fe2fbfca54026dffd2e8838120381869f8dc3b7d6011fcc81d3
diff --git a/app-dicts/gnome-dictionary/gnome-dictionary-3.4.0.ebuild b/app-dicts/gnome-dictionary/gnome-dictionary-3.4.0.ebuild
new file mode 100644
index 00000000..cb23e8db
--- /dev/null
+++ b/app-dicts/gnome-dictionary/gnome-dictionary-3.4.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gnome-utils/gnome-utils-2.32.0-r1.ebuild,v 1.1 2010/12/04 18:08:10 pacho Exp $
+
+EAPI="4"
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2
+if [[ ${PV} = 9999 ]]; then
+ inherit gnome2-live
+fi
+
+DESCRIPTION="Dictionary utility for GNOME 3"
+HOMEPAGE="http://www.gnome.org/"
+
+LICENSE="GPL-2 LGPL-2.1 FDL-1.1"
+SLOT="0"
+IUSE="doc ipv6"
+if [[ ${PV} = 9999 ]]; then
+ KEYWORDS=""
+else
+ KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux"
+fi
+
+COMMON_DEPEND=">=dev-libs/glib-2.28.0:2
+ >=x11-libs/gtk+-3.0.0:3"
+
+DEPEND="${COMMON_DEPEND}
+ app-text/gnome-doc-utils
+ >=dev-util/intltool-0.40
+ >=dev-util/pkgconfig-0.22
+ >=sys-devel/gettext-0.17
+ doc? ( >=dev-util/gtk-doc-1.15 )"
+
+pkg_setup() {
+ DOCS="AUTHORS NEWS README TODO"
+ G2CONF="--disable-schemas-compile
+ $(use_enable ipv6)"
+}
diff --git a/app-dicts/gnome-dictionary/gnome-dictionary-9999.ebuild b/app-dicts/gnome-dictionary/gnome-dictionary-9999.ebuild
new file mode 100644
index 00000000..cb23e8db
--- /dev/null
+++ b/app-dicts/gnome-dictionary/gnome-dictionary-9999.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gnome-utils/gnome-utils-2.32.0-r1.ebuild,v 1.1 2010/12/04 18:08:10 pacho Exp $
+
+EAPI="4"
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2
+if [[ ${PV} = 9999 ]]; then
+ inherit gnome2-live
+fi
+
+DESCRIPTION="Dictionary utility for GNOME 3"
+HOMEPAGE="http://www.gnome.org/"
+
+LICENSE="GPL-2 LGPL-2.1 FDL-1.1"
+SLOT="0"
+IUSE="doc ipv6"
+if [[ ${PV} = 9999 ]]; then
+ KEYWORDS=""
+else
+ KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux"
+fi
+
+COMMON_DEPEND=">=dev-libs/glib-2.28.0:2
+ >=x11-libs/gtk+-3.0.0:3"
+
+DEPEND="${COMMON_DEPEND}
+ app-text/gnome-doc-utils
+ >=dev-util/intltool-0.40
+ >=dev-util/pkgconfig-0.22
+ >=sys-devel/gettext-0.17
+ doc? ( >=dev-util/gtk-doc-1.15 )"
+
+pkg_setup() {
+ DOCS="AUTHORS NEWS README TODO"
+ G2CONF="--disable-schemas-compile
+ $(use_enable ipv6)"
+}