summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2014-10-13 23:40:55 +0200
committerGilles Dartiguelongue <eva@gentoo.org>2014-10-13 23:47:44 +0200
commitcc545e02f46c9493b1b25d24111ce4852e26eb72 (patch)
treec66979060c67daf546f7d7a5d94f709304acaf9a /app-emulation
parentapp-text/yelp-tools: 3.14.0 → 3.14.1 (diff)
downloadgnome-cc545e02f46c9493b1b25d24111ce4852e26eb72.tar.gz
gnome-cc545e02f46c9493b1b25d24111ce4852e26eb72.tar.bz2
gnome-cc545e02f46c9493b1b25d24111ce4852e26eb72.zip
app-emulation/libvirt-glib: 0.1.8 → 0.1.9
Required by gnome-boxes-3.14
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/libvirt-glib/Manifest11
-rw-r--r--app-emulation/libvirt-glib/libvirt-glib-0.1.9.ebuild63
-rw-r--r--app-emulation/libvirt-glib/libvirt-glib-9999.ebuild7
3 files changed, 79 insertions, 2 deletions
diff --git a/app-emulation/libvirt-glib/Manifest b/app-emulation/libvirt-glib/Manifest
new file mode 100644
index 00000000..8fe0dc49
--- /dev/null
+++ b/app-emulation/libvirt-glib/Manifest
@@ -0,0 +1,11 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA512
+
+DIST libvirt-glib-0.1.9.tar.gz 830344 SHA256 053b36260ea70d740e27fe99ac67d714d23cf93d563c3342fa00593ec185a958 SHA512 f90aff63c30758524211392f6767292e4fa042d896716866b9272cdf1169ea0fd4cacaf47f4f985d429dea4f002686cb19b1930d7882dd4c88d5d038a5ce602c WHIRLPOOL 4ecaefb9a50f43c48f1061f4422bc4e490b95c1a78a47fc85a9fc4ea7c35817ff278af799c286060166b5194c79b1a16adea48ba1831250c0f4019d731e07956
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2
+
+iEYEAREKAAYFAlQ8RugACgkQ1fmVwcYIWAbiqwCgitfIYAnFS0T1J4bfm+/qc9DV
+IbUAoJR5LImbqZApMU++qlcN7RCX+sbN
+=sKlD
+-----END PGP SIGNATURE-----
diff --git a/app-emulation/libvirt-glib/libvirt-glib-0.1.9.ebuild b/app-emulation/libvirt-glib/libvirt-glib-0.1.9.ebuild
new file mode 100644
index 00000000..3b5db721
--- /dev/null
+++ b/app-emulation/libvirt-glib/libvirt-glib-0.1.9.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+VALA_MIN_API_VERSION="0.14"
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit gnome2 python-single-r1 vala
+
+DESCRIPTION="GLib and GObject mappings for libvirt"
+HOMEPAGE="http://libvirt.org/git/?p=libvirt-glib.git"
+SRC_URI="ftp://libvirt.org/libvirt/glib/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+introspection python +vala"
+REQUIRED_USE="
+ python? ( ${PYTHON_REQUIRED_USE} )
+ vala? ( introspection )
+"
+
+# https://bugzilla.redhat.com/show_bug.cgi?id=1093633
+RESTRICT="test"
+
+RDEPEND="
+ dev-libs/libxml2:2
+ >=app-emulation/libvirt-0.9.10:=
+ >=dev-libs/glib-2.38.0:2
+ introspection? ( >=dev-libs/gobject-introspection-0.10.8:= )
+ python? ( ${PYTHON_DEPS} )
+"
+DEPEND="${RDEPEND}
+ dev-util/gtk-doc-am
+ >=dev-util/intltool-0.35.0
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )
+"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-test-coverage \
+ --disable-static \
+ $(use_enable introspection) \
+ $(use_enable vala) \
+ $(use_with python)
+}
+
+src_compile() {
+ # https://bugzilla.redhat.com/show_bug.cgi?id=1093631
+ if use vala; then
+ MAKEOPTS="${MAKEOPTS} -j1" gnome2_src_compile
+ else
+ gnome2_src_compile
+ fi
+}
diff --git a/app-emulation/libvirt-glib/libvirt-glib-9999.ebuild b/app-emulation/libvirt-glib/libvirt-glib-9999.ebuild
index abbf986d..a4c7d2d9 100644
--- a/app-emulation/libvirt-glib/libvirt-glib-9999.ebuild
+++ b/app-emulation/libvirt-glib/libvirt-glib-9999.ebuild
@@ -26,12 +26,15 @@ else
KEYWORDS="~amd64 ~x86"
fi
IUSE="+introspection python +vala"
-REQUIRED_USE="vala? ( introspection )"
+REQUIRED_USE="
+ python? ( ${PYTHON_REQUIRED_USE} )
+ vala? ( introspection )
+"
RDEPEND="
dev-libs/libxml2:2
>=app-emulation/libvirt-0.9.10:=
- >=dev-libs/glib-2.10:2
+ >=dev-libs/glib-2.38.0:2
introspection? ( >=dev-libs/gobject-introspection-0.10.8:= )
python? ( ${PYTHON_DEPS} )
"