summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2015-05-13 00:30:34 +0200
committerGilles Dartiguelongue <eva@gentoo.org>2015-05-13 00:30:34 +0200
commit6ccf29e190163b459cb7ea4d38d63ef27973175f (patch)
treed026d8e6b4626025861f779f79d3d3d085b71e75 /dev-libs
parentapp-misc/gnote: drop la files for plugins (diff)
downloadgnome-6ccf29e190163b459cb7ea4d38d63ef27973175f.tar.gz
gnome-6ccf29e190163b459cb7ea4d38d63ef27973175f.tar.bz2
gnome-6ccf29e190163b459cb7ea4d38d63ef27973175f.zip
dev-libs/folks: 0.10.1-r1 → 0.11.0
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/folks/Manifest11
-rw-r--r--dev-libs/folks/folks-0.11.0.ebuild89
-rw-r--r--dev-libs/folks/folks-9999.ebuild24
3 files changed, 112 insertions, 12 deletions
diff --git a/dev-libs/folks/Manifest b/dev-libs/folks/Manifest
new file mode 100644
index 00000000..e6f27459
--- /dev/null
+++ b/dev-libs/folks/Manifest
@@ -0,0 +1,11 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA512
+
+DIST folks-0.11.0.tar.xz 1928320 SHA256 7f6306344f305538ffda263b1085bdcb7039ec0551825dd503f6a3a18cb73061 SHA512 a297a266d63e2365309df7305fc06695a2e03e333f5952cb28328dc15466dd4ec7d705db0187f84dd96e90f2145a2ba40b34256f32f6da839a6aeef0286dcc3e WHIRLPOOL eb1a638753e2f66145a7ddd5d13c3e636626921608c545157979e6feabe67862b65785d293e822e2ea76f1a05dd4f9678f2c64ef1f46afe2f905998b97861015
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2
+
+iEYEAREKAAYFAlVSfwoACgkQ1fmVwcYIWAZg7gCeMp++spp+cltMvbB2ThTrMdak
+VusAoLoE77vR4VDgkYFOIFefzayokTsh
+=0l+d
+-----END PGP SIGNATURE-----
diff --git a/dev-libs/folks/folks-0.11.0.ebuild b/dev-libs/folks/folks-0.11.0.ebuild
new file mode 100644
index 00000000..5ac2afc5
--- /dev/null
+++ b/dev-libs/folks/folks-0.11.0.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="5"
+GCONF_DEBUG="yes"
+GNOME2_LA_PUNT="yes"
+VALA_MIN_API_VERSION="0.22"
+VALA_USE_DEPEND="vapigen"
+
+inherit gnome2 vala virtualx
+
+DESCRIPTION="Library for aggregating people from multiple sources"
+HOMEPAGE="https://wiki.gnome.org/Projects/Folks"
+
+LICENSE="LGPL-2.1+"
+SLOT="0/25" # subslot = libfolks soname version
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-linux"
+
+# TODO: --enable-profiling
+# Vala isn't really optional, https://bugzilla.gnome.org/show_bug.cgi?id=701099
+IUSE="bluetooth eds +telepathy test tracker utils zeitgeist"
+REQUIRED_USE="bluetooth? ( eds )"
+
+COMMON_DEPEND="
+ $(vala_depend)
+ >=dev-libs/glib-2.40:2
+ dev-libs/dbus-glib
+ >=dev-libs/libgee-0.10:0.8[introspection]
+ dev-libs/libxml2
+ sys-libs/ncurses:=
+ sys-libs/readline:=
+
+ bluetooth? ( >=net-wireless/bluez-5 )
+ eds? ( >=gnome-extra/evolution-data-server-3.13.90:=[vala] )
+ telepathy? ( >=net-libs/telepathy-glib-0.19.9[vala] )
+ tracker? ( >=app-misc/tracker-1:0= )
+ zeitgeist? ( >=gnome-extra/zeitgeist-0.9.14 )
+"
+# telepathy-mission-control needed at runtime; it is used by the telepathy
+# backend via telepathy-glib's AccountManager binding.
+RDEPEND="${COMMON_DEPEND}
+ net-im/telepathy-mission-control
+"
+# folks socialweb backend requires that libsocialweb be built with USE=vala,
+# even when building folks with --disable-vala.
+#
+# FIXME:
+# test? ( bluetooth? ( dbusmock is missing in the tree ) )
+DEPEND="${COMMON_DEPEND}
+ >=dev-libs/gobject-introspection-1.30
+ >=dev-util/intltool-0.50.0
+ sys-devel/gettext
+ virtual/pkgconfig
+
+ test? (
+ sys-apps/dbus
+ bluetooth? (
+ >=gnome-extra/evolution-data-server-3.9.1
+ >=dev-libs/glib-2.40 ) )
+ !<dev-lang/vala-0.22.1:0.22
+"
+
+src_prepare() {
+ vala_src_prepare
+ gnome2_src_prepare
+}
+
+src_configure() {
+ # Rebuilding docs needs valadoc, which has no release
+ gnome2_src_configure \
+ $(use_enable bluetooth bluez-backend) \
+ $(use_enable eds eds-backend) \
+ $(use_enable eds ofono-backend) \
+ $(use_enable telepathy telepathy-backend) \
+ $(use_enable tracker tracker-backend) \
+ $(use_enable utils inspect-tool) \
+ $(use_enable test modular-tests) \
+ $(use_enable zeitgeist) \
+ --enable-vala \
+ --enable-import-tool \
+ --disable-docs \
+ --disable-fatal-warnings \
+ --disable-libsocialweb-backend
+}
+
+src_test() {
+ dbus-launch Xemake check
+}
diff --git a/dev-libs/folks/folks-9999.ebuild b/dev-libs/folks/folks-9999.ebuild
index d5424057..edb18167 100644
--- a/dev-libs/folks/folks-9999.ebuild
+++ b/dev-libs/folks/folks-9999.ebuild
@@ -1,9 +1,10 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
EAPI="5"
GCONF_DEBUG="yes"
+GNOME2_LA_PUNT="yes"
VALA_MIN_API_VERSION="0.22"
VALA_USE_DEPEND="vapigen"
@@ -24,12 +25,12 @@ else
fi
# TODO: --enable-profiling
# Vala isn't really optional, https://bugzilla.gnome.org/show_bug.cgi?id=701099
-IUSE="bluetooth eds socialweb +telepathy test tracker utils zeitgeist"
+IUSE="bluetooth eds +telepathy test tracker utils zeitgeist"
REQUIRED_USE="bluetooth? ( eds )"
COMMON_DEPEND="
$(vala_depend)
- >=dev-libs/glib-2.38.2:2
+ >=dev-libs/glib-2.40:2
dev-libs/dbus-glib
>=dev-libs/libgee-0.10:0.8[introspection]
dev-libs/libxml2
@@ -37,9 +38,8 @@ COMMON_DEPEND="
sys-libs/readline:=
bluetooth? ( >=net-wireless/bluez-5 )
- eds? ( >=gnome-extra/evolution-data-server-3.9.1:=[vala] )
- socialweb? ( >=net-libs/libsocialweb-0.25.20 )
- telepathy? ( >=net-libs/telepathy-glib-0.19[vala] )
+ eds? ( >=gnome-extra/evolution-data-server-3.13.90:=[vala] )
+ telepathy? ( >=net-libs/telepathy-glib-0.19.9[vala] )
tracker? ( >=app-misc/tracker-1:0= )
zeitgeist? ( >=gnome-extra/zeitgeist-0.9.14 )
"
@@ -59,11 +59,11 @@ DEPEND="${COMMON_DEPEND}
sys-devel/gettext
virtual/pkgconfig
- socialweb? ( >=net-libs/libsocialweb-0.25.15[vala] )
- test? ( sys-apps/dbus
+ test? (
+ sys-apps/dbus
bluetooth? (
>=gnome-extra/evolution-data-server-3.9.1
- >=dev-libs/glib-2.39.2 ) )
+ >=dev-libs/glib-2.40 ) )
!<dev-lang/vala-0.22.1:0.22
"
@@ -78,16 +78,16 @@ src_configure() {
$(use_enable bluetooth bluez-backend) \
$(use_enable eds eds-backend) \
$(use_enable eds ofono-backend) \
- $(use_enable socialweb libsocialweb-backend) \
$(use_enable telepathy telepathy-backend) \
$(use_enable tracker tracker-backend) \
$(use_enable utils inspect-tool) \
- $(use_enable test tests) \
+ $(use_enable test modular-tests) \
$(use_enable zeitgeist) \
--enable-vala \
--enable-import-tool \
--disable-docs \
- --disable-fatal-warnings
+ --disable-fatal-warnings \
+ --disable-libsocialweb-backend
}
src_test() {