summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2013-11-25 23:44:15 +0100
committerGilles Dartiguelongue <eva@gentoo.org>2013-11-26 00:14:21 +0100
commit5dab79e5344641e02bd371bd5f2a6d8e476ac7d4 (patch)
treea7c3dcf8d8d62ec4349b5207600b8bee3d534054 /dev-python
parentprofiles: add use masks for libpeas (diff)
downloadgnome-5dab79e5344641e02bd371bd5f2a6d8e476ac7d4.tar.gz
gnome-5dab79e5344641e02bd371bd5f2a6d8e476ac7d4.tar.bz2
gnome-5dab79e5344641e02bd371bd5f2a6d8e476ac7d4.zip
dev-python/pygobject: 3.8.3 → 3.10.2
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pygobject/Manifest11
-rw-r--r--dev-python/pygobject/files/pygobject-3.0.3-disable-new-gi-tests.patch69
-rw-r--r--dev-python/pygobject/files/pygobject-3.4.1.1-make_check.patch84
-rw-r--r--dev-python/pygobject/pygobject-3.10.2.ebuild97
-rw-r--r--dev-python/pygobject/pygobject-9999.ebuild63
5 files changed, 137 insertions, 187 deletions
diff --git a/dev-python/pygobject/Manifest b/dev-python/pygobject/Manifest
new file mode 100644
index 00000000..bc37d4d4
--- /dev/null
+++ b/dev-python/pygobject/Manifest
@@ -0,0 +1,11 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA512
+
+DIST pygobject-3.10.2.tar.xz 672092 SHA256 75608f2c4052f0277508fc79debef026d9e84cb9261de2b922387c093d32c326 SHA512 d404916fd9b59c035be093de7ebcc04dbeacb339d1d9284aca7ee569cecee34202a1e0f4e87f301bc0161c7a3a7820987a6a69ff1428c6fda2e99933a32dc96a WHIRLPOOL ece501defc3ffd2af79b1fff7c7d289c4dbb6bd17a577c0369399876957ad3f83455197c1c7c991725a588498fe37c56262c68a1fe2c985a9dea8b799d321138
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2.0.21 (GNU/Linux)
+
+iEYEAREKAAYFAlKT0r8ACgkQ1fmVwcYIWAbgEwCgk3S3HKrFhsaAxV3Gc9Jy5ORO
+Q4wAoJsThl/43lfqfFwpvIRwgYnTn4ft
+=QikC
+-----END PGP SIGNATURE-----
diff --git a/dev-python/pygobject/files/pygobject-3.0.3-disable-new-gi-tests.patch b/dev-python/pygobject/files/pygobject-3.0.3-disable-new-gi-tests.patch
deleted file mode 100644
index a4453742..00000000
--- a/dev-python/pygobject/files/pygobject-3.0.3-disable-new-gi-tests.patch
+++ /dev/null
@@ -1,69 +0,0 @@
-Disable tests requiring >=gobject-introspection-1.31
-
-diff --git a/tests/test_everything.py b/tests/test_everything.py
-index 43735e5..ecfdef4 100644
---- a/tests/test_everything.py
-+++ b/tests/test_everything.py
-@@ -507,22 +507,3 @@ class TestAdvancedInterfaces(unittest.TestCase):
- self.assertEquals(ret[0], 51);
- self.assertEquals(ret[1], 61);
- self.assertEquals(ret[2], 32);
--
-- def test_obj_skip_return_val_no_out(self):
-- obj = Everything.TestObj();
-- # raises an error for 0, succeeds for any other value
-- self.assertRaises(GLib.GError, obj.skip_return_val_no_out, 0)
--
-- ret = obj.skip_return_val_no_out(1)
-- self.assertEquals(ret, None)
--
--class TestSignals(unittest.TestCase):
-- def test_object_param_signal(self):
-- obj = Everything.TestObj();
--
-- def callback (obj_param):
-- self.assertEquals(obj_param.props.int, 3)
-- self.assertEquals(obj_param.__grefcount__, 2)
--
-- obj.connect('sig-with-obj', callback)
-- obj.emit_sig_with_obj()
-diff --git a/tests/test_gi.py b/tests/test_gi.py
-index 0a9b1b2..7e24778 100644
---- a/tests/test_gi.py
-+++ b/tests/test_gi.py
-@@ -770,18 +770,6 @@ class TestArray(unittest.TestCase):
- def test_gstrv_inout(self):
- self.assertEquals(['-1', '0', '1', '2'], GIMarshallingTests.gstrv_inout(['0', '1', '2']))
-
-- def test_array_gvariant_none_in(self):
-- v = [GLib.Variant("i", 27), GLib.Variant("s", "Hello")]
-- self.assertEquals([27, "Hello"], map(GLib.Variant.unpack, GIMarshallingTests.array_gvariant_none_in(v)))
--
-- def test_array_gvariant_container_in(self):
-- v = [GLib.Variant("i", 27), GLib.Variant("s", "Hello")]
-- self.assertEquals([27, "Hello"], map(GLib.Variant.unpack, GIMarshallingTests.array_gvariant_none_in(v)))
--
-- def test_array_gvariant_full_in(self):
-- v = [GLib.Variant("i", 27), GLib.Variant("s", "Hello")]
-- self.assertEquals([27, "Hello"], map(GLib.Variant.unpack, GIMarshallingTests.array_gvariant_none_in(v)))
--
- def test_bytearray_gvariant(self):
- v = GLib.Variant.new_bytestring("foo")
- self.assertEquals(v.get_bytestring(), "foo")
-@@ -1651,16 +1639,6 @@ class TestPythonGObject(unittest.TestCase):
- def do_method_not_a_vfunc(self):
- pass
-
-- def test_subsubobject(self):
-- class SubSubSubObject(GIMarshallingTests.SubSubObject):
-- def do_method_deep_hierarchy(self, num):
-- self.props.int = num * 2
--
-- sub_sub_sub_object = SubSubSubObject()
-- GIMarshallingTests.SubSubObject.do_method_deep_hierarchy(sub_sub_sub_object, 5)
-- self.assertEqual(sub_sub_sub_object.props.int, 5)
--
--
- class TestMultiOutputArgs(unittest.TestCase):
-
- def test_int_out_out(self):
diff --git a/dev-python/pygobject/files/pygobject-3.4.1.1-make_check.patch b/dev-python/pygobject/files/pygobject-3.4.1.1-make_check.patch
deleted file mode 100644
index 7aa70581..00000000
--- a/dev-python/pygobject/files/pygobject-3.4.1.1-make_check.patch
+++ /dev/null
@@ -1,84 +0,0 @@
-From d0885d5757f02f53dbc8036054a1ced7f727eb08 Mon Sep 17 00:00:00 2001
-From: Gilles Dartiguelongue <eva@gentoo.org>
-Date: Fri, 5 Nov 2010 23:39:08 +0100
-Subject: [PATCH] Do not build tests unless needed
-
-[Alexandre Rostovtsev <tetromino@gmail.com>: port to 2.90.1]
----
- tests/Makefile.am | 12 ++++++------
- tests/runtests.py | 3 +++
- 2 files changed, 9 insertions(+), 6 deletions(-)
-
-diff --git a/tests/Makefile.am b/tests/Makefile.am
-index 7a619bf..a3cbf57 100644
---- a/tests/Makefile.am
-+++ b/tests/Makefile.am
-@@ -1,5 +1,5 @@
- CLEANFILES =
--noinst_LTLIBRARIES = libgimarshallingtests.la
-+check_LTLIBRARIES = libgimarshallingtests.la
- test_typelibs = GIMarshallingTests-1.0.typelib
-
- nodist_libgimarshallingtests_la_SOURCES = $(GI_DATADIR)/tests/gimarshallingtests.c $(GI_DATADIR)/tests/gimarshallingtests.h
-@@ -23,7 +23,7 @@ GIMarshallingTests-1.0.typelib: GIMarshallingTests-1.0.gir Makefile
-
- # regress.c needs cairo
- if ENABLE_CAIRO
--noinst_LTLIBRARIES += libregress.la
-+check_LTLIBRARIES += libregress.la
- test_typelibs += Regress-1.0.typelib
- nodist_libregress_la_SOURCES = $(GI_DATADIR)/tests/regress.c $(GI_DATADIR)/tests/regress.h
- libregress_la_CFLAGS = $(GIO_CFLAGS) $(CAIRO_CFLAGS)
-@@ -52,7 +52,7 @@ gschemas.compiled: org.gnome.test.gschema.xml
-
- CLEANFILES += Regress-1.0.gir Regress-1.0.typelib GIMarshallingTests-1.0.gir GIMarshallingTests-1.0.typelib gschemas.compiled
-
--noinst_LTLIBRARIES += testhelper.la
-+check_LTLIBRARIES += testhelper.la
-
- testhelper_la_CFLAGS = -I$(top_srcdir)/gi/_gobject -I$(top_srcdir)/gi/_glib $(PYTHON_INCLUDES) $(GLIB_CFLAGS)
- testhelper_la_LDFLAGS = -module -avoid-version
-@@ -72,7 +72,7 @@ testhelper.la: $(testhelper_la_OBJECTS) $(testhelper_la_DEPENDENCIES)
- test -L $@ || $(LN_S) .libs/$@ $@
-
-
--all: $(LTLIBRARIES:.la=.so)
-+all: $(check_LTLIBRARIES:.la=.so)
-
- EXTRA_DIST = \
- compathelper.py \
-@@ -112,7 +112,7 @@ EXTRA_DIST = \
- $(NULL)
-
- clean-local:
-- rm -f $(LTLIBRARIES:.la=.so) file.txt~
-+ rm -f $(check_LTLIBRARIES:.la=.so) file.txt~
-
- DBUS_LAUNCH=$(shell which dbus-launch)
- RUN_TESTS_ENV_VARS= \
-@@ -123,7 +123,7 @@ RUN_TESTS_ENV_VARS= \
- MALLOC_PERTURB_=85 \
- TESTS_BUILDDIR=$(builddir)
-
--check-local: $(LTLIBRARIES:.la=.so) $(test_typelibs) gschemas.compiled
-+check-local: $(check_LTLIBRARIES:.la=.so) $(test_typelibs) gschemas.compiled
- @echo " CHECK Pyflakes"
- @if type pyflakes >/dev/null 2>&1; then pyflakes $(top_srcdir); else echo "skipped, pyflakes not installed"; fi
- @echo " CHECK PEP8"
-diff --git a/tests/runtests.py b/tests/runtests.py
-index c518fcc..35bb5c4 100755
---- a/tests/runtests.py
-+++ b/tests/runtests.py
-@@ -34,6 +34,9 @@ if sys.version_info[:2] == (2, 6):
- unittest.TestCase.assertGreater = assertGreater
- unittest.TestCase.assertIsInstance = assertIsInstance
-
-+# Some tests fail with translated messages.
-+os.environ["LC_ALL"] = "C"
-+
- if '--help' in sys.argv:
- print("Usage: ./runtests.py <testfiles>")
- sys.exit(0)
---
-1.7.12.4
-
diff --git a/dev-python/pygobject/pygobject-3.10.2.ebuild b/dev-python/pygobject/pygobject-3.10.2.ebuild
new file mode 100644
index 00000000..730eb8fe
--- /dev/null
+++ b/dev-python/pygobject/pygobject-3.10.2.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+PYTHON_COMPAT=( python{2_7,3_2,3_3} )
+
+inherit gnome2 python-r1 virtualx
+
+DESCRIPTION="GLib's GObject library bindings for Python"
+HOMEPAGE="http://www.pygtk.org/"
+
+LICENSE="LGPL-2.1+"
+SLOT="3"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="+cairo examples test +threads"
+
+REQUIRED_USE="
+ ${PYTHON_REQUIRED_USE}
+ test? ( cairo )
+"
+
+COMMON_DEPEND="
+ >=dev-libs/glib-2.35.9:2
+ >=dev-libs/gobject-introspection-1.35.9
+ virtual/libffi:=
+ cairo? ( >=dev-python/pycairo-1.10.0[${PYTHON_USEDEP}] )
+ ${PYTHON_DEPS}
+"
+DEPEND="${COMMON_DEPEND}
+ x11-libs/cairo[glib]
+ virtual/pkgconfig
+ test? (
+ dev-libs/atk[introspection]
+ media-fonts/font-cursor-misc
+ media-fonts/font-misc-misc
+ virtual/python-unittest2[${PYTHON_USEDEP}]
+ x11-libs/gdk-pixbuf:2[introspection]
+ x11-libs/gtk+:3[introspection]
+ x11-libs/pango[introspection] )
+"
+# gnome-base/gnome-common required by eautoreconf
+
+# We now disable introspection support in slot 2 per upstream recommendation
+# (see https://bugzilla.gnome.org/show_bug.cgi?id=642048#c9); however,
+# older versions of slot 2 installed their own site-packages/gi, and
+# slot 3 will collide with them.
+RDEPEND="${COMMON_DEPEND}
+ !<dev-python/pygtk-2.13
+ !<dev-python/pygobject-2.28.6-r50:2[introspection]"
+
+src_prepare() {
+ gnome2_src_prepare
+ python_copy_sources
+}
+
+src_configure() {
+ # Hard-enable libffi support since both gobject-introspection and
+ # glib-2.29.x rdepend on it anyway
+ # docs disabled by upstream default since they are very out of date
+ python_foreach_impl run_in_build_dir \
+ gnome2_src_configure \
+ --with-ffi \
+ $(use_enable cairo) \
+ $(use_enable threads thread)
+}
+
+src_compile() {
+ python_foreach_impl run_in_build_dir gnome2_src_compile
+}
+
+src_test() {
+ unset DBUS_SESSION_BUS_ADDRESS
+ export GIO_USE_VFS="local" # prevents odd issues with deleting ${T}/.gvfs
+ export GIO_USE_VOLUME_MONITOR="unix" # prevent udisks-related failures in chroots, bug #449484
+
+ testing() {
+ export XDG_CACHE_HOME="${T}/${EPYTHON}"
+ run_in_build_dir Xemake check
+ unset XDG_CACHE_HOME
+ }
+ python_foreach_impl testing
+ unset GIO_USE_VFS
+}
+
+src_install() {
+ DOCS="AUTHORS ChangeLog* NEWS README"
+
+ python_foreach_impl run_in_build_dir gnome2_src_install
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}
diff --git a/dev-python/pygobject/pygobject-9999.ebuild b/dev-python/pygobject/pygobject-9999.ebuild
index 3b3ba4ce..664a5d37 100644
--- a/dev-python/pygobject/pygobject-9999.ebuild
+++ b/dev-python/pygobject/pygobject-9999.ebuild
@@ -1,13 +1,13 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
EAPI="5"
GCONF_DEBUG="no"
GNOME2_LA_PUNT="yes"
-PYTHON_COMPAT=( python{2_6,2_7,3_1,3_2,3_3} )
+PYTHON_COMPAT=( python{2_7,3_2,3_3} )
-inherit autotools eutils gnome2 python-r1 virtualx
+inherit gnome2 python-r1 virtualx
if [[ ${PV} = 9999 ]]; then
inherit gnome2-live
fi
@@ -20,18 +20,22 @@ SLOT="3"
if [[ ${PV} = 9999 ]]; then
KEYWORDS=""
else
- KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
fi
IUSE="+cairo examples test +threads"
-REQUIRED_USE="test? ( cairo )"
+REQUIRED_USE="
+ ${PYTHON_REQUIRED_USE}
+ test? ( cairo )
+"
-COMMON_DEPEND=">=dev-libs/glib-2.31.0:2
- >=dev-libs/gobject-introspection-1.34.1.1
+COMMON_DEPEND="
+ >=dev-libs/glib-2.35.9:2
+ >=dev-libs/gobject-introspection-1.35.9
virtual/libffi:=
- cairo? ( >=dev-python/pycairo-1.10.0 )
- ${PYTHON_DEPS}"
-# TODO: should be >=dev-python/pycairo-1.10.0[${PYTHON_USEDEP}]
+ cairo? ( >=dev-python/pycairo-1.10.0[${PYTHON_USEDEP}] )
+ ${PYTHON_DEPS}
+"
DEPEND="${COMMON_DEPEND}
x11-libs/cairo[glib]
virtual/pkgconfig
@@ -39,9 +43,12 @@ DEPEND="${COMMON_DEPEND}
dev-libs/atk[introspection]
media-fonts/font-cursor-misc
media-fonts/font-misc-misc
+ virtual/python-unittest2[${PYTHON_USEDEP}]
x11-libs/gdk-pixbuf:2[introspection]
x11-libs/gtk+:3[introspection]
- x11-libs/pango[introspection] )"
+ x11-libs/pango[introspection] )
+"
+# gnome-base/gnome-common required by eautoreconf
# We now disable introspection support in slot 2 per upstream recommendation
# (see https://bugzilla.gnome.org/show_bug.cgi?id=642048#c9); however,
@@ -52,37 +59,29 @@ RDEPEND="${COMMON_DEPEND}
!<dev-python/pygobject-2.28.6-r50:2[introspection]"
src_prepare() {
- DOCS="AUTHORS ChangeLog* NEWS README"
- # Hard-enable libffi support since both gobject-introspection and
- # glib-2.29.x rdepend on it anyway
- # docs disabled by upstream default since they are very out of date
- G2CONF="${G2CONF}
- --disable-dependency-tracking
- --with-ffi
- $(use_enable cairo)
- $(use_enable threads thread)"
-
- # Do not build tests if unneeded, bug #226345
- epatch "${FILESDIR}/${PN}-3.4.1.1-make_check.patch"
-
- [[ ${PV} != 9999 ]] && eautoreconf
gnome2_src_prepare
-
python_copy_sources
}
src_configure() {
- python_foreach_impl run_in_build_dir gnome2_src_configure
+ # Hard-enable libffi support since both gobject-introspection and
+ # glib-2.29.x rdepend on it anyway
+ # docs disabled by upstream default since they are very out of date
+ python_foreach_impl run_in_build_dir \
+ gnome2_src_configure \
+ --with-ffi \
+ $(use_enable cairo) \
+ $(use_enable threads thread)
}
src_compile() {
python_foreach_impl run_in_build_dir gnome2_src_compile
}
-# FIXME: With python multiple ABI support, tests return 1 even when they pass
src_test() {
unset DBUS_SESSION_BUS_ADDRESS
export GIO_USE_VFS="local" # prevents odd issues with deleting ${T}/.gvfs
+ export GIO_USE_VOLUME_MONITOR="unix" # prevent udisks-related failures in chroots, bug #449484
testing() {
export XDG_CACHE_HOME="${T}/${EPYTHON}"
@@ -94,6 +93,8 @@ src_test() {
}
src_install() {
+ DOCS="AUTHORS ChangeLog* NEWS README"
+
python_foreach_impl run_in_build_dir gnome2_src_install
if use examples; then
@@ -101,9 +102,3 @@ src_install() {
doins -r examples
fi
}
-
-run_in_build_dir() {
- pushd "${BUILD_DIR}" > /dev/null || die
- "$@"
- popd > /dev/null
-}