summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2013-11-15 02:14:17 +0100
committerGilles Dartiguelongue <eva@gentoo.org>2013-11-15 02:17:12 +0100
commitbfe417e47cecb9cf26ae179c905c127d0aea16e9 (patch)
treef3d0ac0d8a539aca3f529158ea3ae7335b0e406a /sys-apps
parentx11-themes/gnome-backgrounds: 3.10.0 → 3.10.1 (diff)
downloadgnome-bfe417e47cecb9cf26ae179c905c127d0aea16e9.tar.gz
gnome-bfe417e47cecb9cf26ae179c905c127d0aea16e9.tar.bz2
gnome-bfe417e47cecb9cf26ae179c905c127d0aea16e9.zip
Revert commit 255f0218..92e8d28f
Those commits are improperly tested and were not meant to be pushed yet.
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/baobab/Manifest11
-rw-r--r--sys-apps/baobab/baobab-3.10.ebuild39
-rw-r--r--sys-apps/baobab/baobab-9999.ebuild22
3 files changed, 13 insertions, 59 deletions
diff --git a/sys-apps/baobab/Manifest b/sys-apps/baobab/Manifest
deleted file mode 100644
index 62723584..00000000
--- a/sys-apps/baobab/Manifest
+++ /dev/null
@@ -1,11 +0,0 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA512
-
-DIST baobab-3.10.tar.xz 861592 SHA256 6f4e309073c3834f957b957b03d388fd89900a1622a001d238ad6105c6e303ee SHA512 78cb89cbd03a515f313dba3be3aa53d6a8ccc484dc7360b8c294ffeb29b281cef63195d52178af4ad1a55a1ddc680766fbd7cda5cd96317575d5ff79d2dee343 WHIRLPOOL 34527380a826c02caaec076a1bedd84a2e38efd68cf19c51c452d584d9d44fac6a7110d2a828805a1e0aefb7d1e1ebfde5717ba9aa4df28e5e665d214970519b
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v2.0.21 (GNU/Linux)
-
-iEYEAREKAAYFAlJZ1CcACgkQ1fmVwcYIWAaBtwCffudtOv1AMWWdV5/A50jcCO3u
-BbcAoOTgHhVNGuAerFh/I3rvW+AxQvd7
-=3nGu
------END PGP SIGNATURE-----
diff --git a/sys-apps/baobab/baobab-3.10.ebuild b/sys-apps/baobab/baobab-3.10.ebuild
deleted file mode 100644
index 4d364b83..00000000
--- a/sys-apps/baobab/baobab-3.10.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI="5"
-GCONF_DEBUG="no"
-
-inherit gnome2
-
-DESCRIPTION="Disk usage browser for GNOME"
-HOMEPAGE="https://live.gnome.org/Baobab"
-
-LICENSE="GPL-2+ FDL-1.1+"
-SLOT="0"
-IUSE=""
-KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux"
-
-COMMON_DEPEND="
- >=dev-libs/glib-2.37.5:2
- >=x11-libs/gtk+-3.9.10:3
-"
-RDEPEND="${COMMON_DEPEND}
- gnome-base/gsettings-desktop-schemas
- !<gnome-extra/gnome-utils-3.4
-"
-# ${PN} was part of gnome-utils before 3.4
-DEPEND="${COMMON_DEPEND}
- >=dev-util/intltool-0.40
- >=sys-devel/gettext-0.17
- virtual/pkgconfig
-"
-
-src_configure() {
- gnome2_src_configure \
- ITSTOOL=$(type -P true) \
- XMLLINT=$(type -P true) \
- VALAC=$(type -P true) \
- VAPIGEN=$(type -P true)
-}
diff --git a/sys-apps/baobab/baobab-9999.ebuild b/sys-apps/baobab/baobab-9999.ebuild
index c977af5f..94044132 100644
--- a/sys-apps/baobab/baobab-9999.ebuild
+++ b/sys-apps/baobab/baobab-9999.ebuild
@@ -1,19 +1,20 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
EAPI="5"
GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
inherit gnome2
if [[ ${PV} = 9999 ]]; then
- VALA_MIN_API_VERSION="0.22s"
+ VALA_MIN_API_VERSION="0.18"
VALA_USE_DEPEND="vapigen"
inherit gnome2-live vala
fi
-DESCRIPTION="Disk usage browser for GNOME"
-HOMEPAGE="https://live.gnome.org/Baobab"
+DESCRIPTION="Disk usage browser for GNOME 3"
+HOMEPAGE="https://live.gnome.org/GnomeUtils"
LICENSE="GPL-2+ FDL-1.1+"
SLOT="0"
@@ -25,8 +26,12 @@ else
fi
COMMON_DEPEND="
- >=dev-libs/glib-2.37.5:2
- >=x11-libs/gtk+-3.9.10:3
+ >=dev-libs/glib-2.30.0:2
+ gnome-base/libgtop:2=
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf
+ >=x11-libs/gtk+-3.5.9:3
+ x11-libs/pango
"
RDEPEND="${COMMON_DEPEND}
gnome-base/gsettings-desktop-schemas
@@ -52,13 +57,12 @@ src_prepare() {
}
src_configure() {
- local myconf=""
if [[ ${PV} != 9999 ]]; then
- myconf="${myconf}
+ G2CONF="${G2CONF}
ITSTOOL=$(type -P true)
XMLLINT=$(type -P true)
VALAC=$(type -P true)
VAPIGEN=$(type -P true)"
fi
- gnome2_src_configure ${myconf}
+ gnome2_src_configure
}