summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2014-04-22 22:47:35 +0200
committerGilles Dartiguelongue <eva@gentoo.org>2014-04-22 22:47:35 +0200
commit7b51b96075702e441e06473dcf9571c867f7bd78 (patch)
tree766c34f36114c3a4b3324342fd5bcbf43c37de91 /www-client
parentgnome-extra/gnome-calculator: 3.12.0 → 3.12.1 (diff)
downloadgnome-7b51b96075702e441e06473dcf9571c867f7bd78.tar.gz
gnome-7b51b96075702e441e06473dcf9571c867f7bd78.tar.bz2
gnome-7b51b96075702e441e06473dcf9571c867f7bd78.zip
www-client/epiphany: fix webextension underlinking
Diffstat (limited to 'www-client')
-rw-r--r--www-client/epiphany/epiphany-3.12.0.ebuild10
-rw-r--r--www-client/epiphany/files/epiphany-3.12.0-missing-symbol.patch39
2 files changed, 48 insertions, 1 deletions
diff --git a/www-client/epiphany/epiphany-3.12.0.ebuild b/www-client/epiphany/epiphany-3.12.0.ebuild
index a98962b9..e5a1b60f 100644
--- a/www-client/epiphany/epiphany-3.12.0.ebuild
+++ b/www-client/epiphany/epiphany-3.12.0.ebuild
@@ -6,7 +6,7 @@ EAPI="5"
GCONF_DEBUG="yes"
GNOME2_LA_PUNT="yes"
-inherit eutils gnome2 pax-utils versionator virtualx
+inherit autotools eutils gnome2 pax-utils versionator virtualx
DESCRIPTION="GNOME webbrowser based on Webkit"
HOMEPAGE="http://projects.gnome.org/epiphany/"
@@ -57,6 +57,14 @@ DEPEND="${COMMON_DEPEND}
# Tests refuse to run with the gsettings trick for some reason
RESTRICT="test"
+src_prepare() {
+ # Fix missing symbol in webextensio.so
+ epatch "${FILESDIR}"/${P}-missing-symbol.patch
+
+ eautoreconf
+ gnome2_src_prepare
+}
+
src_configure() {
gnome2_src_configure \
--enable-shared \
diff --git a/www-client/epiphany/files/epiphany-3.12.0-missing-symbol.patch b/www-client/epiphany/files/epiphany-3.12.0-missing-symbol.patch
new file mode 100644
index 00000000..6f2d8350
--- /dev/null
+++ b/www-client/epiphany/files/epiphany-3.12.0-missing-symbol.patch
@@ -0,0 +1,39 @@
+From 267ec3e2d7ca0f1881cb76d702ac673727f7507a Mon Sep 17 00:00:00 2001
+From: Gilles Dartiguelongue <eva@gentoo.org>
+Date: Tue, 22 Apr 2014 21:15:42 +0200
+Subject: [PATCH] Add missing files to webextension library
+
+Otherwise, results in:
+
+avril 22 21:09:36 kanae epiphany.desktop[32013]: Error loading module
+'/usr/lib64/epiphany/3.12/web-extensions/libephywebextension.so':
+/usr/lib64/epiphany/3.12/web-extensions/libephywebextension.so:
+undefined symbol: ephy_profile_utils_set_migration_version
+---
+ embed/web-extension/Makefile.am | 3 +++
+ 1 file changed, 3 insertions(+)
+
+diff --git a/embed/web-extension/Makefile.am b/embed/web-extension/Makefile.am
+index 5bdb174..be4b08f 100644
+--- a/embed/web-extension/Makefile.am
++++ b/embed/web-extension/Makefile.am
+@@ -22,6 +22,8 @@ libephywebextension_la_SOURCES = \
+ $(top_srcdir)/lib/ephy-file-helpers.h \
+ $(top_srcdir)/lib/ephy-form-auth-data.c \
+ $(top_srcdir)/lib/ephy-form-auth-data.h \
++ $(top_srcdir)/lib/ephy-profile-utils.c \
++ $(top_srcdir)/lib/ephy-profile-utils.h \
+ $(top_srcdir)/lib/ephy-settings.c \
+ $(top_srcdir)/lib/ephy-settings.h \
+ $(top_srcdir)/lib/ephy-string.c \
+@@ -39,6 +41,7 @@ libephywebextension_la_CPPFLAGS = \
+ libephywebextension_la_CFLAGS = \
+ -DSHARE_DIR=\"$(pkgdatadir)\" \
+ -DTOP_SRC_DATADIR=\"$(top_srcdir)/data\" \
++ -DABS_TOP_BUILD_DIR=\"$(abs_top_builddir)\" \
+ $(WEB_EXTENSION_CFLAGS)
+
+ libephywebextension_la_LIBADD = \
+--
+1.9.0
+