summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2014-04-24 23:34:17 +0200
committerGilles Dartiguelongue <eva@gentoo.org>2014-04-24 23:35:43 +0200
commita2b962b085fbca81ebc0b7ef5f448b233e165956 (patch)
tree9a71806994f5cefe64a92acb54af2383a2c46b93 /x11-terms
parentdev-libs/libgweather: 3.10.2 → 3.12.1 (diff)
downloadgnome-a2b962b085fbca81ebc0b7ef5f448b233e165956.tar.gz
gnome-a2b962b085fbca81ebc0b7ef5f448b233e165956.tar.bz2
gnome-a2b962b085fbca81ebc0b7ef5f448b233e165956.zip
x11-terms/gnome-terminal: fix empty tab title
Following upstream move as explained in https://bugzilla.gnome.org/show_bug.cgi?id=724110 and relevant commits.
Diffstat (limited to 'x11-terms')
-rw-r--r--x11-terms/gnome-terminal/files/gnome-terminal-3.12.0-appmenu-parameter.patch26
-rw-r--r--x11-terms/gnome-terminal/files/gnome-terminal-3.12.0-fallback-title-1.patch29
-rw-r--r--x11-terms/gnome-terminal/files/gnome-terminal-3.12.0-fallback-title-2.patch28
-rw-r--r--x11-terms/gnome-terminal/files/gnome-terminal-3.12.0-remove-set-title-feature-0.patch131
-rw-r--r--x11-terms/gnome-terminal/files/gnome-terminal-3.12.0-remove-set-title-feature-1.patch214
-rw-r--r--x11-terms/gnome-terminal/files/gnome-terminal-3.12.0-remove-set-title-feature-2.patch217
-rw-r--r--x11-terms/gnome-terminal/files/gnome-terminal-3.12.0-remove-set-title-feature-3.patch181
-rw-r--r--x11-terms/gnome-terminal/gnome-terminal-3.12.0-r1.ebuild (renamed from x11-terms/gnome-terminal/gnome-terminal-3.12.0.ebuild)14
-rw-r--r--x11-terms/gnome-terminal/gnome-terminal-9999.ebuild4
9 files changed, 841 insertions, 3 deletions
diff --git a/x11-terms/gnome-terminal/files/gnome-terminal-3.12.0-appmenu-parameter.patch b/x11-terms/gnome-terminal/files/gnome-terminal-3.12.0-appmenu-parameter.patch
new file mode 100644
index 00000000..46a0b8ff
--- /dev/null
+++ b/x11-terms/gnome-terminal/files/gnome-terminal-3.12.0-appmenu-parameter.patch
@@ -0,0 +1,26 @@
+From d58bc01a2e891e31e11f03eb0d6ae9b5ff260b2b Mon Sep 17 00:00:00 2001
+From: Christian Persch <chpe@gnome.org>
+Date: Mon, 24 Mar 2014 15:16:22 +0100
+Subject: [PATCH 02/61] appmenu: Fix action parameter
+
+https://bugzilla.gnome.org/show_bug.cgi?id=726942
+---
+ src/terminal-appmenu.ui | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/terminal-appmenu.ui b/src/terminal-appmenu.ui
+index 148c640..01ff5a8 100644
+--- a/src/terminal-appmenu.ui
++++ b/src/terminal-appmenu.ui
+@@ -21,7 +21,7 @@
+ <item>
+ <attribute name="label" translatable="yes">_New Terminal</attribute>
+ <attribute name="action">win.new-terminal</attribute>
+- <attribute name="target">'default'</attribute>
++ <attribute name="target" type="(ss)">('default','default')</attribute>
+ </item>
+ </section>
+ <section>
+--
+1.9.0
+
diff --git a/x11-terms/gnome-terminal/files/gnome-terminal-3.12.0-fallback-title-1.patch b/x11-terms/gnome-terminal/files/gnome-terminal-3.12.0-fallback-title-1.patch
new file mode 100644
index 00000000..67dd15eb
--- /dev/null
+++ b/x11-terms/gnome-terminal/files/gnome-terminal-3.12.0-fallback-title-1.patch
@@ -0,0 +1,29 @@
+From fe7230e2113510596be5e773f9c1074ed650e858 Mon Sep 17 00:00:00 2001
+From: Christian Persch <chpe@gnome.org>
+Date: Sun, 20 Apr 2014 20:21:04 +0200
+Subject: [PATCH 56/61] window: Use fallback tab title for empty terminal title
+
+https://bugzilla.gnome.org/show_bug.cgi?id=706816
+---
+ src/terminal-tab-label.c | 5 +++--
+ 1 file changed, 3 insertions(+), 2 deletions(-)
+
+diff --git a/src/terminal-tab-label.c b/src/terminal-tab-label.c
+index 90bab28..a83d94f 100644
+--- a/src/terminal-tab-label.c
++++ b/src/terminal-tab-label.c
+@@ -75,8 +75,9 @@ sync_tab_label (TerminalScreen *screen,
+ title = terminal_screen_get_title (screen);
+ hbox = gtk_widget_get_parent (label);
+
+- gtk_label_set_text (GTK_LABEL (label), title);
+-
++ gtk_label_set_text (GTK_LABEL (label),
++ title && title[0] ? title : _("Terminal"));
++
+ gtk_widget_set_tooltip_text (hbox, title);
+ }
+
+--
+1.9.0
+
diff --git a/x11-terms/gnome-terminal/files/gnome-terminal-3.12.0-fallback-title-2.patch b/x11-terms/gnome-terminal/files/gnome-terminal-3.12.0-fallback-title-2.patch
new file mode 100644
index 00000000..cec57309
--- /dev/null
+++ b/x11-terms/gnome-terminal/files/gnome-terminal-3.12.0-fallback-title-2.patch
@@ -0,0 +1,28 @@
+From 0d52fef0ca60483debbdedec43bd07a8e9f76bfa Mon Sep 17 00:00:00 2001
+From: Christian Persch <chpe@gnome.org>
+Date: Sun, 20 Apr 2014 20:21:04 +0200
+Subject: [PATCH 57/61] window: Use fallback tab title for empty terminal title
+
+https://bugzilla.gnome.org/show_bug.cgi?id=706816
+---
+ src/terminal-tabs-menu.c | 4 +++-
+ 1 file changed, 3 insertions(+), 1 deletion(-)
+
+diff --git a/src/terminal-tabs-menu.c b/src/terminal-tabs-menu.c
+index ed5fc7b..fb2b966 100644
+--- a/src/terminal-tabs-menu.c
++++ b/src/terminal-tabs-menu.c
+@@ -176,7 +176,9 @@ sync_tab_title (TerminalScreen *screen,
+
+ title = terminal_screen_get_title (screen);
+
+- g_object_set (action, "label", title, NULL);
++ g_object_set (action,
++ "label", title && title[0] ? title : _("Terminal"),
++ NULL);
+ }
+
+ static void
+--
+1.9.0
+
diff --git a/x11-terms/gnome-terminal/files/gnome-terminal-3.12.0-remove-set-title-feature-0.patch b/x11-terms/gnome-terminal/files/gnome-terminal-3.12.0-remove-set-title-feature-0.patch
new file mode 100644
index 00000000..88ce2d96
--- /dev/null
+++ b/x11-terms/gnome-terminal/files/gnome-terminal-3.12.0-remove-set-title-feature-0.patch
@@ -0,0 +1,131 @@
+From de0dc7c2649c42e2aa02a66e4be27d262b34452d Mon Sep 17 00:00:00 2001
+From: Debarshi Ray <debarshir@gnome.org>
+Date: Fri, 11 Apr 2014 15:52:23 +0200
+Subject: [PATCH 45/61] Remove unused code to create terminals with custom
+ titles
+
+Irrespective of how you create a new terminal (over D-Bus using
+$bindir/gnome-terminal, ctrl+shift n, or the application menu), the
+code to set a custom title during construction was unused. Possibly
+as a result of f27bf0135a2d18ba22158d28bf1f8c5f6ec066c8
+
+https://bugzilla.gnome.org/show_bug.cgi?id=724110
+---
+ src/terminal-app.c | 3 +--
+ src/terminal-app.h | 1 -
+ src/terminal-gdbus.c | 6 ++----
+ src/terminal-screen.c | 4 ----
+ src/terminal-screen.h | 1 -
+ src/terminal-window.c | 2 +-
+ 6 files changed, 4 insertions(+), 13 deletions(-)
+
+diff --git a/src/terminal-app.c b/src/terminal-app.c
+index 9ded6fc..57a6f15 100644
+--- a/src/terminal-app.c
++++ b/src/terminal-app.c
+@@ -527,7 +527,6 @@ terminal_app_new_terminal (TerminalApp *app,
+ TerminalWindow *window,
+ GSettings *profile,
+ char **override_command,
+- const char *title,
+ const char *working_dir,
+ char **child_env,
+ double zoom)
+@@ -537,7 +536,7 @@ terminal_app_new_terminal (TerminalApp *app,
+ g_return_val_if_fail (TERMINAL_IS_APP (app), NULL);
+ g_return_val_if_fail (TERMINAL_IS_WINDOW (window), NULL);
+
+- screen = terminal_screen_new (profile, override_command, title,
++ screen = terminal_screen_new (profile, override_command,
+ working_dir, child_env, zoom);
+
+ terminal_window_add_screen (window, screen, -1);
+diff --git a/src/terminal-app.h b/src/terminal-app.h
+index 6da6036..9502845 100644
+--- a/src/terminal-app.h
++++ b/src/terminal-app.h
+@@ -75,7 +75,6 @@ TerminalScreen *terminal_app_new_terminal (TerminalApp *app,
+ TerminalWindow *window,
+ GSettings *profile,
+ char **override_command,
+- const char *title,
+ const char *working_dir,
+ char **child_env,
+ double zoom);
+diff --git a/src/terminal-gdbus.c b/src/terminal-gdbus.c
+index b801b9e..7b68a85 100644
+--- a/src/terminal-gdbus.c
++++ b/src/terminal-gdbus.c
+@@ -368,7 +368,7 @@ terminal_factory_impl_create_instance (TerminalFactory *factory,
+ TerminalObjectSkeleton *skeleton;
+ char *object_path;
+ GSettings *profile = NULL;
+- const char *profile_uuid, *title;
++ const char *profile_uuid;
+ gboolean zoom_set = FALSE;
+ gdouble zoom = 1.0;
+ guint window_id;
+@@ -456,12 +456,10 @@ terminal_factory_impl_create_instance (TerminalFactory *factory,
+
+ g_assert (window != NULL);
+
+- if (!g_variant_lookup (options, "title", "&s", &title))
+- title = NULL;
+ if (g_variant_lookup (options, "zoom", "d", &zoom))
+ zoom_set = TRUE;
+
+- screen = terminal_screen_new (profile, NULL, title, NULL, NULL,
++ screen = terminal_screen_new (profile, NULL, NULL, NULL,
+ zoom_set ? zoom : 1.0);
+ terminal_window_add_screen (window, screen, -1);
+ terminal_window_switch_screen (window, screen);
+diff --git a/src/terminal-screen.c b/src/terminal-screen.c
+index c504881..bb05924 100644
+--- a/src/terminal-screen.c
++++ b/src/terminal-screen.c
+@@ -622,7 +622,6 @@ terminal_screen_finalize (GObject *object)
+ TerminalScreen *
+ terminal_screen_new (GSettings *profile,
+ char **override_command,
+- const char *title,
+ const char *working_dir,
+ char **child_env,
+ double zoom)
+@@ -643,9 +642,6 @@ terminal_screen_new (GSettings *profile,
+ g_settings_get_int (profile, TERMINAL_PROFILE_DEFAULT_SIZE_ROWS_KEY));
+ }
+
+- if (title)
+- terminal_screen_set_user_title (screen, title);
+-
+ priv->initial_working_directory = g_strdup (working_dir);
+
+ if (override_command)
+diff --git a/src/terminal-screen.h b/src/terminal-screen.h
+index d0341c8..2a0d391 100644
+--- a/src/terminal-screen.h
++++ b/src/terminal-screen.h
+@@ -76,7 +76,6 @@ const char *terminal_screen_get_uuid (TerminalScreen *screen);
+
+ TerminalScreen *terminal_screen_new (GSettings *profile,
+ char **override_command,
+- const char *title,
+ const char *working_dir,
+ char **child_env,
+ double zoom);
+diff --git a/src/terminal-window.c b/src/terminal-window.c
+index 0a611a7..9c209f7 100644
+--- a/src/terminal-window.c
++++ b/src/terminal-window.c
+@@ -400,7 +400,7 @@ action_new_terminal_cb (GSimpleAction *action,
+
+ new_working_directory = terminal_screen_get_current_dir (priv->active_screen);
+ terminal_app_new_terminal (app, window, profile,
+- NULL, NULL,
++ NULL,
+ new_working_directory,
+ terminal_screen_get_initial_environment (priv->active_screen),
+ 1.0);
+--
+1.9.0
+
diff --git a/x11-terms/gnome-terminal/files/gnome-terminal-3.12.0-remove-set-title-feature-1.patch b/x11-terms/gnome-terminal/files/gnome-terminal-3.12.0-remove-set-title-feature-1.patch
new file mode 100644
index 00000000..aa59ed1c
--- /dev/null
+++ b/x11-terms/gnome-terminal/files/gnome-terminal-3.12.0-remove-set-title-feature-1.patch
@@ -0,0 +1,214 @@
+From 9bbe19e98f62aa3c9020913a3a5a8080a5177505 Mon Sep 17 00:00:00 2001
+From: Debarshi Ray <debarshir@gnome.org>
+Date: Wed, 16 Apr 2014 15:04:38 +0200
+Subject: [PATCH 47/61] Remove the action and shortcut to set a static title
+ from the menus
+
+Setting a static title does not work because there is no code
+listening to changes in TerminalScreen:description. The title is
+dynamically set via escape sequences, usually from a suitable
+PROMPT_COMMAND, which is noticed by VteTerminal.
+
+If you want to customize the title of a particular terminal, please use
+the escape sequence. This is what you had to use before, anyway.
+
+https://bugzilla.gnome.org/show_bug.cgi?id=724110
+---
+ src/migration.c | 1 -
+ src/org.gnome.Terminal.gschema.xml | 4 --
+ src/terminal-accels.c | 2 -
+ src/terminal-window.c | 88 --------------------------------------
+ src/terminal.xml | 3 --
+ 5 files changed, 98 deletions(-)
+
+diff --git a/src/migration.c b/src/migration.c
+index 7a7a773..b626ec5 100644
+--- a/src/migration.c
++++ b/src/migration.c
+@@ -541,7 +541,6 @@ migrate_accels (GSettings *global_settings,
+ { "zoom_in", "zoom-in" },
+ { "zoom_out", "zoom-out" },
+ { "zoom_normal", "zoom-normal" },
+- { "set_window_title", "set-terminal-title" },
+ { "reset", "reset" },
+ { "reset_and_clear", "reset-and-clear" },
+ { "prev_tab", "prev-tab" },
+diff --git a/src/org.gnome.Terminal.gschema.xml b/src/org.gnome.Terminal.gschema.xml
+index 1b926a6..be8f104 100644
+--- a/src/org.gnome.Terminal.gschema.xml
++++ b/src/org.gnome.Terminal.gschema.xml
+@@ -374,10 +374,6 @@
+ <default>'disabled'</default>
+ <summary>Keyboard shortcut to toggle the visibility of the menubar</summary>
+ </key>
+- <key name="set-terminal-title" type="s">
+- <default>'disabled'</default>
+- <summary>Keyboard shortcut to set the terminal title</summary>
+- </key>
+ <key name="reset" type="s">
+ <default>'disabled'</default>
+ <summary>Keyboard shortcut to reset the terminal</summary>
+diff --git a/src/terminal-accels.c b/src/terminal-accels.c
+index a3a8034..65d56bd 100644
+--- a/src/terminal-accels.c
++++ b/src/terminal-accels.c
+@@ -70,7 +70,6 @@
+ #define KEY_RESET_AND_CLEAR "reset-and-clear"
+ #define KEY_RESET "reset"
+ #define KEY_SAVE_CONTENTS "save-contents"
+-#define KEY_SET_TERMINAL_TITLE "set-terminal-title"
+ #define KEY_TOGGLE_MENUBAR "toggle-menubar"
+ #define KEY_ZOOM_IN "zoom-in"
+ #define KEY_ZOOM_NORMAL "zoom-normal"
+@@ -144,7 +143,6 @@ static KeyEntry view_entries[] = {
+ };
+
+ static KeyEntry terminal_entries[] = {
+- ENTRY (N_("Set Title"), KEY_SET_TERMINAL_TITLE, "set-title", NULL, NULL ),
+ ENTRY (N_("Reset"), KEY_RESET, "reset", "b", "false"),
+ ENTRY (N_("Reset and Clear"), KEY_RESET_AND_CLEAR, "reset", "b", "true" ),
+ };
+diff --git a/src/terminal-window.c b/src/terminal-window.c
+index 9c209f7..93145ac 100644
+--- a/src/terminal-window.c
++++ b/src/terminal-window.c
+@@ -179,8 +179,6 @@ static void view_zoom_out_callback (GtkAction *action,
+ TerminalWindow *window);
+ static void view_zoom_normal_callback (GtkAction *action,
+ TerminalWindow *window);
+-static void terminal_set_title_callback (GtkAction *action,
+- TerminalWindow *window);
+ static void terminal_add_encoding_callback (GtkAction *action,
+ TerminalWindow *window);
+ static void terminal_reset_callback (GtkAction *action,
+@@ -718,88 +716,6 @@ action_move_tab_cb (GSimpleAction *action,
+ }
+
+ static void
+-terminal_set_title_dialog_response_cb (GtkWidget *dialog,
+- int response,
+- TerminalScreen *screen)
+-{
+- if (response == GTK_RESPONSE_OK)
+- {
+- GtkEntry *entry;
+- const char *text;
+-
+- entry = GTK_ENTRY (g_object_get_data (G_OBJECT (dialog), "title-entry"));
+- text = gtk_entry_get_text (entry);
+- terminal_screen_set_user_title (screen, text);
+- }
+-
+- gtk_widget_destroy (dialog);
+-}
+-
+-static void
+-action_set_title_cb (GSimpleAction *action,
+- GVariant *parameter,
+- gpointer user_data)
+-{
+- TerminalWindow *window = user_data;
+- TerminalWindowPrivate *priv = window->priv;
+- GtkWidget *dialog, *message_area, *hbox, *label, *entry;
+-
+- if (priv->active_screen == NULL)
+- return;
+-
+- /* FIXME: hook the screen up so this dialogue closes if the terminal screen closes */
+-
+- dialog = gtk_message_dialog_new (GTK_WINDOW (window),
+- GTK_DIALOG_MODAL | GTK_DIALOG_DESTROY_WITH_PARENT,
+- GTK_MESSAGE_OTHER,
+- GTK_BUTTONS_OK_CANCEL,
+- "%s", "");
+-
+- gtk_window_set_title (GTK_WINDOW (dialog), _("Set Title"));
+- gtk_window_set_resizable (GTK_WINDOW (dialog), FALSE);
+- gtk_window_set_role (GTK_WINDOW (dialog), "gnome-terminal-change-title");
+- gtk_dialog_set_default_response (GTK_DIALOG (dialog), GTK_RESPONSE_OK);
+- /* Alternative button order was set automatically by GtkMessageDialog */
+-
+- g_signal_connect (dialog, "response",
+- G_CALLBACK (terminal_set_title_dialog_response_cb), priv->active_screen);
+- g_signal_connect (dialog, "delete-event",
+- G_CALLBACK (terminal_util_dialog_response_on_delete), NULL);
+-
+- message_area = gtk_message_dialog_get_message_area (GTK_MESSAGE_DIALOG (dialog));
+- gtk_container_foreach (GTK_CONTAINER (message_area), (GtkCallback) gtk_widget_hide, NULL);
+-
+- hbox = gtk_box_new (GTK_ORIENTATION_HORIZONTAL, 12);
+- gtk_box_pack_start (GTK_BOX (message_area), hbox, FALSE, FALSE, 0);
+-
+- label = gtk_label_new_with_mnemonic (_("_Title:"));
+- gtk_misc_set_alignment (GTK_MISC (label), 0.0, 0.5);
+- gtk_box_pack_start (GTK_BOX (hbox), label, FALSE, FALSE, 0);
+-
+- entry = gtk_entry_new ();
+- gtk_entry_set_width_chars (GTK_ENTRY (entry), 32);
+- gtk_entry_set_activates_default (GTK_ENTRY (entry), TRUE);
+- gtk_label_set_mnemonic_widget (GTK_LABEL (label), entry);
+- gtk_box_pack_start (GTK_BOX (hbox), entry, TRUE, TRUE, 0);
+- gtk_widget_show_all (hbox);
+-
+- gtk_widget_grab_focus (entry);
+- gtk_entry_set_text (GTK_ENTRY (entry), terminal_screen_get_user_title (priv->active_screen));
+- gtk_editable_select_region (GTK_EDITABLE (entry), 0, -1);
+- g_object_set_data (G_OBJECT (dialog), "title-entry", entry);
+-
+- gtk_window_present (GTK_WINDOW (dialog));
+-}
+-
+-static void
+-terminal_set_title_callback (GtkAction *action,
+- TerminalWindow *window)
+-{
+- g_action_activate (g_action_map_lookup_action (G_ACTION_MAP (window), "set-title"),
+- NULL);
+-}
+-
+-static void
+ action_zoom_cb (GSimpleAction *action,
+ GVariant *parameter,
+ gpointer user_data)
+@@ -2423,7 +2339,6 @@ terminal_window_init (TerminalWindow *window)
+ { "reset", action_reset_cb, "b", NULL, NULL },
+ { "switch-tab", action_switch_tab_cb, "i", NULL, NULL },
+ { "move-tab", action_move_tab_cb, "i", NULL, NULL },
+- { "set-title", action_set_title_cb, NULL, NULL, NULL },
+ { "zoom", action_zoom_cb, "i", NULL, NULL },
+ { "detach-tab", action_detach_tab_cb, NULL, NULL, NULL },
+ { "find", action_find_cb, "s", NULL, NULL },
+@@ -2528,9 +2443,6 @@ terminal_window_init (TerminalWindow *window)
+
+ /* Terminal menu */
+ { "TerminalProfiles", NULL, N_("Change _Profile") },
+- { "TerminalSetTitle", NULL, N_("_Set Title…"), NULL,
+- NULL,
+- G_CALLBACK (terminal_set_title_callback) },
+ { "TerminalSetEncoding", NULL, N_("Set _Character Encoding") },
+ { "TerminalReset", NULL, N_("_Reset"), NULL,
+ NULL,
+diff --git a/src/terminal.xml b/src/terminal.xml
+index 6743393..72cef17 100644
+--- a/src/terminal.xml
++++ b/src/terminal.xml
+@@ -46,7 +46,6 @@
+ </menu>
+ <menu action="Terminal">
+ <menu action="TerminalProfiles" />
+- <menuitem action="TerminalSetTitle" />
+ <menu action="TerminalSetEncoding" >
+ <placeholder name="EncodingsPH" />
+ <separator />
+@@ -100,8 +99,6 @@
+ <menuitem action="TabsMoveLeft"/>
+ <menuitem action="TabsMoveRight"/>
+ <separator />
+- <menuitem action="TerminalSetTitle" />
+- <separator />
+ <menuitem action="FileCloseTab"/>
+ </popup>
+ </ui>
+--
+1.9.0
+
diff --git a/x11-terms/gnome-terminal/files/gnome-terminal-3.12.0-remove-set-title-feature-2.patch b/x11-terms/gnome-terminal/files/gnome-terminal-3.12.0-remove-set-title-feature-2.patch
new file mode 100644
index 00000000..69a4fbab
--- /dev/null
+++ b/x11-terms/gnome-terminal/files/gnome-terminal-3.12.0-remove-set-title-feature-2.patch
@@ -0,0 +1,217 @@
+From e9cb8fea14a849704074c5d69f173bcf4dc2fb27 Mon Sep 17 00:00:00 2001
+From: Debarshi Ray <debarshir@gnome.org>
+Date: Wed, 16 Apr 2014 16:01:56 +0200
+Subject: [PATCH 48/61] Remove the static title setting from profile
+ preferences
+
+The static title setting does not work because TerminalWindow hardcodes
+the title as "Terminal" in the absence of VteTerminal:window-title,
+which is set dynamically via escape sequences. Usually the escape
+sequence is emitted from a suitable PROMPT_COMMAND. You can do the same
+if you want a customized title.
+
+https://bugzilla.gnome.org/show_bug.cgi?id=724110
+---
+ src/migration.c | 3 --
+ src/org.gnome.Terminal.gschema.xml | 5 ---
+ src/profile-editor.c | 3 --
+ src/profile-preferences.ui | 86 --------------------------------------
+ src/terminal-schemas.h | 1 -
+ src/terminal-screen.c | 9 ----
+ 6 files changed, 107 deletions(-)
+
+diff --git a/src/migration.c b/src/migration.c
+index b626ec5..ecd1493 100644
+--- a/src/migration.c
++++ b/src/migration.c
+@@ -86,7 +86,6 @@ enum {
+ #define KEY_SCROLL_ON_KEYSTROKE "scroll_on_keystroke"
+ #define KEY_SCROLL_ON_OUTPUT "scroll_on_output"
+ #define KEY_SILENT_BELL "silent_bell"
+-#define KEY_TITLE "title"
+ #define KEY_UPDATE_RECORDS "update_records"
+ #define KEY_USE_CUSTOM_COMMAND "use_custom_command"
+ #define KEY_USE_CUSTOM_DEFAULT_SIZE "use_custom_default_size"
+@@ -395,8 +394,6 @@ migrate_profile (TerminalSettingsList *list,
+ migrate_bool (client, path, KEY_BOLD_COLOR_SAME_AS_FG,
+ settings, TERMINAL_PROFILE_BOLD_COLOR_SAME_AS_FG_KEY,
+ FALSE);
+- migrate_string (client, path, KEY_TITLE,
+- settings, TERMINAL_PROFILE_TITLE_KEY);
+ migrate_bool (client, path, KEY_ALLOW_BOLD,
+ settings, TERMINAL_PROFILE_ALLOW_BOLD_KEY,
+ FALSE);
+diff --git a/src/org.gnome.Terminal.gschema.xml b/src/org.gnome.Terminal.gschema.xml
+index be8f104..af7f418 100644
+--- a/src/org.gnome.Terminal.gschema.xml
++++ b/src/org.gnome.Terminal.gschema.xml
+@@ -116,11 +116,6 @@
+ <summary>Whether bold text should use the same color as normal text</summary>
+ <description>If true, boldface text will be rendered using the same color as normal text.</description>
+ </key>
+- <key name="title" type="s">
+- <default l10n="messages" context="title">'Terminal'</default>
+- <summary>Title for terminal</summary>
+- <description>Title to display for the terminal window or tab. This title may be replaced by or combined with the title set by the application inside the terminal, depending on the title_mode setting.</description>
+- </key>
+ <key name="allow-bold" type="b">
+ <default>true</default>
+ <summary>Whether to allow bold text</summary>
+diff --git a/src/profile-editor.c b/src/profile-editor.c
+index 4bc1f7f..70a1afa 100644
+--- a/src/profile-editor.c
++++ b/src/profile-editor.c
+@@ -1014,9 +1014,6 @@ terminal_profile_edit (GSettings *profile,
+ gtk_builder_get_object (builder,
+ "system-font-checkbutton"),
+ "active", G_SETTINGS_BIND_GET | G_SETTINGS_BIND_SET);
+- g_settings_bind (profile, TERMINAL_PROFILE_TITLE_KEY,
+- gtk_builder_get_object (builder, "title-entry"), "text",
+- G_SETTINGS_BIND_GET | G_SETTINGS_BIND_SET);
+ g_settings_bind (profile, TERMINAL_PROFILE_UPDATE_RECORDS_KEY,
+ gtk_builder_get_object (builder,
+ "update-records-checkbutton"),
+diff --git a/src/profile-preferences.ui b/src/profile-preferences.ui
+index 02889a3..e730681 100644
+--- a/src/profile-preferences.ui
++++ b/src/profile-preferences.ui
+@@ -579,92 +579,6 @@
+ <property name="border_width">12</property>
+ <property name="spacing">18</property>
+ <child>
+- <object class="GtkVBox" id="vbox79">
+- <property name="visible">True</property>
+- <property name="can_focus">False</property>
+- <property name="spacing">6</property>
+- <child>
+- <object class="GtkLabel" id="label33">
+- <property name="visible">True</property>
+- <property name="can_focus">False</property>
+- <property name="xalign">0</property>
+- <property name="label" translatable="yes">Title</property>
+- <attributes>
+- <attribute name="weight" value="bold"/>
+- </attributes>
+- </object>
+- <packing>
+- <property name="expand">False</property>
+- <property name="fill">False</property>
+- <property name="position">0</property>
+- </packing>
+- </child>
+- <child>
+- <object class="GtkAlignment" id="alignment10108">
+- <property name="visible">True</property>
+- <property name="can_focus">False</property>
+- <property name="left_padding">12</property>
+- <child>
+- <object class="GtkVBox" id="vbox93">
+- <property name="visible">True</property>
+- <property name="can_focus">False</property>
+- <property name="spacing">6</property>
+- <child>
+- <object class="GtkHBox" id="hbox137">
+- <property name="visible">True</property>
+- <property name="can_focus">False</property>
+- <property name="spacing">12</property>
+- <child>
+- <object class="GtkLabel" id="title-entry-label">
+- <property name="visible">True</property>
+- <property name="can_focus">False</property>
+- <property name="xalign">0</property>
+- <property name="label" translatable="yes">_Title:</property>
+- <property name="use_underline">True</property>
+- <property name="justify">center</property>
+- <property name="mnemonic_widget">title-entry</property>
+- </object>
+- <packing>
+- <property name="expand">False</property>
+- <property name="fill">False</property>
+- <property name="position">0</property>
+- </packing>
+- </child>
+- <child>
+- <object class="GtkEntry" id="title-entry">
+- <property name="visible">True</property>
+- <property name="can_focus">True</property>
+- </object>
+- <packing>
+- <property name="expand">True</property>
+- <property name="fill">True</property>
+- <property name="position">1</property>
+- </packing>
+- </child>
+- </object>
+- <packing>
+- <property name="expand">False</property>
+- <property name="fill">True</property>
+- <property name="position">0</property>
+- </packing>
+- </child>
+- </object>
+- </child>
+- </object>
+- <packing>
+- <property name="expand">False</property>
+- <property name="fill">True</property>
+- <property name="position">1</property>
+- </packing>
+- </child>
+- </object>
+- <packing>
+- <property name="expand">False</property>
+- <property name="fill">True</property>
+- <property name="position">0</property>
+- </packing>
+- </child>
+- <child>
+ <object class="GtkVBox" id="vbox80">
+ <property name="visible">True</property>
+ <property name="can_focus">False</property>
+diff --git a/src/terminal-schemas.h b/src/terminal-schemas.h
+index 7673da1..0bddcab 100644
+--- a/src/terminal-schemas.h
++++ b/src/terminal-schemas.h
+@@ -56,7 +56,6 @@ G_BEGIN_DECLS
+ #define TERMINAL_PROFILE_SCROLLBAR_POLICY_KEY "scrollbar-policy"
+ #define TERMINAL_PROFILE_SCROLL_ON_KEYSTROKE_KEY "scroll-on-keystroke"
+ #define TERMINAL_PROFILE_SCROLL_ON_OUTPUT_KEY "scroll-on-output"
+-#define TERMINAL_PROFILE_TITLE_KEY "title"
+ #define TERMINAL_PROFILE_UPDATE_RECORDS_KEY "update-records"
+ #define TERMINAL_PROFILE_USE_CUSTOM_COMMAND_KEY "use-custom-command"
+ #define TERMINAL_PROFILE_USE_CUSTOM_DEFAULT_SIZE_KEY "use-custom-default-size"
+diff --git a/src/terminal-screen.c b/src/terminal-screen.c
+index bb05924..d03ed80 100644
+--- a/src/terminal-screen.c
++++ b/src/terminal-screen.c
+@@ -717,14 +717,11 @@ char *
+ terminal_screen_get_description (TerminalScreen *screen)
+ {
+ TerminalScreenPrivate *priv = screen->priv;
+- gs_free char *title_string = NULL;
+ const char *title;
+
+ /* use --title argument if one was supplied, otherwise ask the profile */
+ if (priv->title)
+ title = priv->title;
+- else
+- title = title_string = g_settings_get_string (priv->profile, TERMINAL_PROFILE_TITLE_KEY);
+
+ return g_strdup_printf ("%s — %d",
+ title && title[0] ? title : _("Terminal"),
+@@ -772,12 +769,6 @@ terminal_screen_profile_changed_cb (GSettings *profile,
+ vte_terminal_set_cjk_ambiguous_width (vte_terminal, (int) width);
+ }
+
+- if (!prop_name ||
+- prop_name == I_(TERMINAL_PROFILE_TITLE_KEY))
+- {
+- g_object_notify (object, "description");
+- }
+-
+ if (gtk_widget_get_realized (GTK_WIDGET (screen)) &&
+ (!prop_name ||
+ prop_name == I_(TERMINAL_PROFILE_USE_SYSTEM_FONT_KEY) ||
+--
+1.9.0
+
diff --git a/x11-terms/gnome-terminal/files/gnome-terminal-3.12.0-remove-set-title-feature-3.patch b/x11-terms/gnome-terminal/files/gnome-terminal-3.12.0-remove-set-title-feature-3.patch
new file mode 100644
index 00000000..82507421
--- /dev/null
+++ b/x11-terms/gnome-terminal/files/gnome-terminal-3.12.0-remove-set-title-feature-3.patch
@@ -0,0 +1,181 @@
+From 3bb41272b7509a16ec2a5cd93e44f73d5743b626 Mon Sep 17 00:00:00 2001
+From: Debarshi Ray <debarshir@gnome.org>
+Date: Wed, 16 Apr 2014 17:39:39 +0200
+Subject: [PATCH 49/61] screen: Remove unused description and user_title API
+
+These were used by various parts of the static title code, which has
+now been removed.
+
+https://bugzilla.gnome.org/show_bug.cgi?id=724110
+---
+ src/terminal-screen.c | 63 ---------------------------------------------------
+ src/terminal-screen.h | 6 -----
+ 2 files changed, 69 deletions(-)
+
+diff --git a/src/terminal-screen.c b/src/terminal-screen.c
+index d03ed80..e35914c 100644
+--- a/src/terminal-screen.c
++++ b/src/terminal-screen.c
+@@ -77,7 +77,6 @@ struct _TerminalScreenPrivate
+ GSettings *profile; /* never NULL */
+ guint profile_changed_id;
+ guint profile_forgotten_id;
+- char *title;
+ char *initial_working_directory;
+ char **initial_env;
+ char **override_command;
+@@ -102,7 +101,6 @@ enum {
+ PROP_ICON_TITLE,
+ PROP_ICON_TITLE_SET,
+ PROP_TITLE,
+- PROP_DESCRIPTION,
+ PROP_INITIAL_ENVIRONMENT
+ };
+
+@@ -390,9 +388,6 @@ terminal_screen_get_property (GObject *object,
+ case PROP_TITLE:
+ g_value_set_string (value, terminal_screen_get_title (screen));
+ break;
+- case PROP_DESCRIPTION:
+- g_value_take_string (value, terminal_screen_get_description (screen));
+- break;
+ default:
+ G_OBJECT_WARN_INVALID_PROPERTY_ID (object, prop_id, pspec);
+ break;
+@@ -418,7 +413,6 @@ terminal_screen_set_property (GObject *object,
+ case PROP_ICON_TITLE:
+ case PROP_ICON_TITLE_SET:
+ case PROP_TITLE:
+- case PROP_DESCRIPTION:
+ /* not writable */
+ default:
+ G_OBJECT_WARN_INVALID_PROPERTY_ID (object, prop_id, pspec);
+@@ -517,13 +511,6 @@ terminal_screen_class_init (TerminalScreenClass *klass)
+ NULL,
+ G_PARAM_READABLE | G_PARAM_STATIC_NAME | G_PARAM_STATIC_NICK | G_PARAM_STATIC_BLURB));
+
+- g_object_class_install_property (object_class,
+- PROP_DESCRIPTION,
+- g_param_spec_string ("description", NULL, NULL,
+- NULL,
+- G_PARAM_READABLE |
+- G_PARAM_STATIC_STRINGS));
+-
+ g_object_class_install_property
+ (object_class,
+ PROP_INITIAL_ENVIRONMENT,
+@@ -606,7 +593,6 @@ terminal_screen_finalize (GObject *object)
+
+ terminal_screen_set_profile (screen, NULL);
+
+- g_free (priv->title);
+ g_free (priv->initial_working_directory);
+ g_strfreev (priv->override_command);
+ g_strfreev (priv->initial_env);
+@@ -713,21 +699,6 @@ terminal_screen_get_icon_title_set (TerminalScreen *screen)
+ return vte_terminal_get_icon_title (VTE_TERMINAL (screen)) != NULL;
+ }
+
+-char *
+-terminal_screen_get_description (TerminalScreen *screen)
+-{
+- TerminalScreenPrivate *priv = screen->priv;
+- const char *title;
+-
+- /* use --title argument if one was supplied, otherwise ask the profile */
+- if (priv->title)
+- title = priv->title;
+-
+- return g_strdup_printf ("%s — %d",
+- title && title[0] ? title : _("Terminal"),
+- screen->priv->child_pid);
+-}
+-
+ static void
+ terminal_screen_profile_changed_cb (GSettings *profile,
+ const char *prop_name,
+@@ -949,7 +920,6 @@ terminal_screen_set_profile (TerminalScreen *screen,
+ g_object_unref (old_profile);
+
+ g_object_notify (G_OBJECT (screen), "profile");
+- g_object_notify (G_OBJECT (screen), "description");
+ }
+
+ GSettings*
+@@ -1359,8 +1329,6 @@ out:
+ g_strfreev (env);
+ free_fd_setup_data (data);
+
+- g_object_notify (G_OBJECT (screen), "description");
+-
+ return result;
+ }
+
+@@ -1543,35 +1511,6 @@ terminal_screen_button_press (GtkWidget *widget,
+ return FALSE;
+ }
+
+-void
+-terminal_screen_set_user_title (TerminalScreen *screen,
+- const char *title)
+-{
+- TerminalScreenPrivate *priv = screen->priv;
+-
+- g_return_if_fail (TERMINAL_IS_SCREEN (screen));
+-
+- if (g_strcmp0 (priv->title, title) == 0)
+- return;
+-
+- g_free (priv->title);
+- priv->title = title && title[0] ? g_strdup (title) : NULL;
+-
+- g_object_notify (G_OBJECT (screen), "description");
+-}
+-
+-const char*
+-terminal_screen_get_user_title (TerminalScreen *screen)
+-{
+- TerminalScreenPrivate *priv;
+-
+- g_return_val_if_fail (TERMINAL_IS_SCREEN (screen), NULL);
+-
+- priv = screen->priv;
+-
+- return priv->title ? priv->title : _("Terminal");
+-}
+-
+ /**
+ * terminal_screen_get_current_dir:
+ * @screen:
+@@ -1629,8 +1568,6 @@ terminal_screen_child_exited (VteTerminal *terminal,
+
+ priv->child_pid = -1;
+
+- g_object_notify (G_OBJECT (screen), "description");
+-
+ action = g_settings_get_enum (priv->profile, TERMINAL_PROFILE_EXIT_ACTION_KEY);
+
+ switch (action)
+diff --git a/src/terminal-screen.h b/src/terminal-screen.h
+index 2a0d391..96f0a0d 100644
+--- a/src/terminal-screen.h
++++ b/src/terminal-screen.h
+@@ -100,15 +100,9 @@ void terminal_screen_set_initial_environment (TerminalScreen *screen,
+ char **argv);
+ char ** terminal_screen_get_initial_environment (TerminalScreen *screen);
+
+-const char *terminal_screen_get_user_title (TerminalScreen *screen);
+ const char* terminal_screen_get_title (TerminalScreen *screen);
+ const char* terminal_screen_get_icon_title (TerminalScreen *screen);
+ gboolean terminal_screen_get_icon_title_set (TerminalScreen *screen);
+-char * terminal_screen_get_description (TerminalScreen *screen);
+-
+-void terminal_screen_set_user_title (TerminalScreen *screen,
+- const char *text);
+-
+
+ char *terminal_screen_get_current_dir (TerminalScreen *screen);
+
+--
+1.9.0
+
diff --git a/x11-terms/gnome-terminal/gnome-terminal-3.12.0.ebuild b/x11-terms/gnome-terminal/gnome-terminal-3.12.0-r1.ebuild
index a2b2d2f6..2d66ac46 100644
--- a/x11-terms/gnome-terminal/gnome-terminal-3.12.0.ebuild
+++ b/x11-terms/gnome-terminal/gnome-terminal-3.12.0-r1.ebuild
@@ -33,6 +33,7 @@ RDEPEND="
# gtk+:2 needed for gtk-builder-convert, bug 356239
DEPEND="${RDEPEND}
app-text/yelp-tools
+ dev-util/appdata-tools
|| ( dev-util/gtk-builder-convert <=x11-libs/gtk+-2.24.10:2 )
>=dev-util/intltool-0.50
sys-devel/gettext
@@ -43,6 +44,18 @@ DOC_CONTENTS="To get previous working directory inherited in new opened
tab you will need to add the following line to your ~/.bashrc:\n
. /etc/profile.d/vte.sh"
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-appmenu-parameter.patch \
+ "${FILESDIR}"/${P}-remove-set-title-feature-0.patch \
+ "${FILESDIR}"/${P}-remove-set-title-feature-1.patch \
+ "${FILESDIR}"/${P}-remove-set-title-feature-2.patch \
+ "${FILESDIR}"/${P}-remove-set-title-feature-3.patch \
+ "${FILESDIR}"/${P}-fallback-title-1.patch \
+ "${FILESDIR}"/${P}-fallback-title-2.patch
+
+ gnome2_src_prepare
+}
src_configure() {
# FIXME: leave smclient configure unset until it accepts values from the
# switch and not from GDK_TARGET, bug #363033
@@ -51,7 +64,6 @@ src_configure() {
--enable-migration \
$(use_enable gnome-shell search-provider) \
$(use_with nautilus nautilus-extension) \
- APPDATA_VALIDATE=$(type -P true) \
# Docs are broken in this release.
#ITSTOOL=$(type -P true) \
#XMLLINT=$(type -P true)
diff --git a/x11-terms/gnome-terminal/gnome-terminal-9999.ebuild b/x11-terms/gnome-terminal/gnome-terminal-9999.ebuild
index dcc8ba01..8fb1bbf1 100644
--- a/x11-terms/gnome-terminal/gnome-terminal-9999.ebuild
+++ b/x11-terms/gnome-terminal/gnome-terminal-9999.ebuild
@@ -16,7 +16,7 @@ HOMEPAGE="https://help.gnome.org/users/gnome-terminal/"
LICENSE="GPL-3+"
SLOT="0"
-IUSE="+nautilus"
+IUSE="+gnome-shell +nautilus"
if [[ ${PV} = 9999 ]]; then
KEYWORDS=""
else
@@ -56,7 +56,7 @@ DOC_CONTENTS="To get previous working directory inherited in new opened
src_configure() {
local myconf=""
- if [[ ${PV} = 9999 ]]; then
+ if [[ ${PV} != 9999 ]]; then
myconf="${myconf}
ITSTOOL=$(type -P true)
XMLLINT=$(type -P true)