summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2014-04-12 23:02:41 +0200
committerGilles Dartiguelongue <eva@gentoo.org>2014-04-16 00:00:26 +0200
commitb3e08a04dafac5ab7721de1f5adf2626891f9ed1 (patch)
tree84cdf6f6b9d94a2c1019b0d99a490e429036be64 /x11-terms
parentnet-libs/glib-networking: 2.38.2 → 2.40.0 (diff)
downloadgnome-b3e08a04dafac5ab7721de1f5adf2626891f9ed1.tar.gz
gnome-b3e08a04dafac5ab7721de1f5adf2626891f9ed1.tar.bz2
gnome-b3e08a04dafac5ab7721de1f5adf2626891f9ed1.zip
x11-terms/gnome-terminal: 3.10.2 → 3.12.0
Documentation fails to build/install so let it be regenerated. App data is the new annoyance, just silence it.
Diffstat (limited to 'x11-terms')
-rw-r--r--x11-terms/gnome-terminal/Manifest11
-rw-r--r--x11-terms/gnome-terminal/gnome-terminal-3.12.0.ebuild77
-rw-r--r--x11-terms/gnome-terminal/gnome-terminal-9999.ebuild27
3 files changed, 107 insertions, 8 deletions
diff --git a/x11-terms/gnome-terminal/Manifest b/x11-terms/gnome-terminal/Manifest
new file mode 100644
index 00000000..b1a0f85d
--- /dev/null
+++ b/x11-terms/gnome-terminal/Manifest
@@ -0,0 +1,11 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA512
+
+DIST gnome-terminal-3.12.0.tar.xz 1720200 SHA256 ce690ed798a3e940f2f3a173a7946181e48d899214048d3282c671535c87cea7 SHA512 150acfd4752f478b7b8d8a5bcdcee13ca222ea5c5419bf320560ee201b5fe44d4a48a5e7e533df8cd782341121f6c2d1f728c156e0568099be6fcd093f1a5401 WHIRLPOOL 6a1aaa867b2e955c6ac2cba409860fd83f67c6c834eb0c72ca7ab31e9101169a04c6db699324982148750a91508853cd0a02d6cc584186681a9a4cb2fa5818cd
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2.0.22 (GNU/Linux)
+
+iEYEAREKAAYFAlNJqfIACgkQ1fmVwcYIWAbdbgCg6rnZsWsgRZvwPxAcuthruRJZ
+vc0AnR0ttVmhH9hvDJE/NT1Hg3/T7dV3
+=x9x/
+-----END PGP SIGNATURE-----
diff --git a/x11-terms/gnome-terminal/gnome-terminal-3.12.0.ebuild b/x11-terms/gnome-terminal/gnome-terminal-3.12.0.ebuild
new file mode 100644
index 00000000..a2b2d2f6
--- /dev/null
+++ b/x11-terms/gnome-terminal/gnome-terminal-3.12.0.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2 readme.gentoo
+
+DESCRIPTION="The Gnome Terminal"
+HOMEPAGE="https://help.gnome.org/users/gnome-terminal/"
+
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE="+gnome-shell +nautilus"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux"
+
+# FIXME: automagic dependency on gtk+[X]
+RDEPEND="
+ >=dev-libs/glib-2.39.2:2
+ >=x11-libs/gtk+-3.9.9:3[X]
+ >=x11-libs/vte-0.36:2.90
+ >=gnome-base/dconf-0.14
+ >=gnome-base/gconf-2.31.3
+ >=gnome-base/gsettings-desktop-schemas-0.1.0
+ sys-apps/util-linux
+ x11-libs/libSM
+ x11-libs/libICE
+ gnome-shell? ( gnome-base/gnome-shell )
+ nautilus? ( >=gnome-base/nautilus-3 )
+"
+# gtk+:2 needed for gtk-builder-convert, bug 356239
+DEPEND="${RDEPEND}
+ app-text/yelp-tools
+ || ( dev-util/gtk-builder-convert <=x11-libs/gtk+-2.24.10:2 )
+ >=dev-util/intltool-0.50
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+DOC_CONTENTS="To get previous working directory inherited in new opened
+ tab you will need to add the following line to your ~/.bashrc:\n
+ . /etc/profile.d/vte.sh"
+
+src_configure() {
+ # FIXME: leave smclient configure unset until it accepts values from the
+ # switch and not from GDK_TARGET, bug #363033
+ gnome2_src_configure \
+ --disable-static \
+ --enable-migration \
+ $(use_enable gnome-shell search-provider) \
+ $(use_with nautilus nautilus-extension) \
+ APPDATA_VALIDATE=$(type -P true) \
+ # Docs are broken in this release.
+ #ITSTOOL=$(type -P true) \
+ #XMLLINT=$(type -P true)
+}
+
+src_install() {
+ DOCS="AUTHORS ChangeLog HACKING NEWS"
+ gnome2_src_install
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ if [[ ${REPLACING_VERSIONS} < 3.6.1-r1 && ${REPLACING_VERSIONS} != 2.32.1-r1 &&
+ ${REPLACING_VERSIONS} != 3.4.1.1-r1 ]]; then
+ elog
+ elog "Gnome Terminal no longer uses login shell by default, switching"
+ elog "to upstream default. Because of this, if you have some command you"
+ elog "want to be run, be sure to have it placed in your ~/.bashrc file."
+ elog
+ fi
+ readme.gentoo_print_elog
+}
diff --git a/x11-terms/gnome-terminal/gnome-terminal-9999.ebuild b/x11-terms/gnome-terminal/gnome-terminal-9999.ebuild
index a499f596..dcc8ba01 100644
--- a/x11-terms/gnome-terminal/gnome-terminal-9999.ebuild
+++ b/x11-terms/gnome-terminal/gnome-terminal-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
@@ -25,22 +25,22 @@ fi
# FIXME: automagic dependency on gtk+[X]
RDEPEND="
- >=dev-libs/glib-2.33.2:2
- >=x11-libs/gtk+-3.6:3[X]
- >=x11-libs/vte-0.34.9:2.90
- >=gnome-base/dconf-0.12
+ >=dev-libs/glib-2.39.2:2
+ >=x11-libs/gtk+-3.9.9:3[X]
+ >=x11-libs/vte-0.36:2.90
+ >=gnome-base/dconf-0.14
>=gnome-base/gconf-2.31.3
>=gnome-base/gsettings-desktop-schemas-0.1.0
sys-apps/util-linux
x11-libs/libSM
x11-libs/libICE
+ gnome-shell? ( gnome-base/gnome-shell )
nautilus? ( >=gnome-base/nautilus-3 )
"
# gtk+:2 needed for gtk-builder-convert, bug 356239
DEPEND="${RDEPEND}
|| ( dev-util/gtk-builder-convert <=x11-libs/gtk+-2.24.10:2 )
- >=dev-util/intltool-0.40
- >=gnome-base/dconf-0.14.0
+ >=dev-util/intltool-0.50
sys-devel/gettext
virtual/pkgconfig
"
@@ -54,13 +54,24 @@ DOC_CONTENTS="To get previous working directory inherited in new opened
. /etc/profile.d/vte.sh"
src_configure() {
+ local myconf=""
+
+ if [[ ${PV} = 9999 ]]; then
+ myconf="${myconf}
+ ITSTOOL=$(type -P true)
+ XMLLINT=$(type -P true)
+ "
+ fi
+
# FIXME: leave smclient configure unset until it accepts values from the
# switch and not from GDK_TARGET, bug #363033
gnome2_src_configure \
--disable-static \
--enable-migration \
+ $(use_enable gnome-shell search-provider) \
$(use_with nautilus nautilus-extension) \
- ITSTOOL=$(type -P true)
+ APPDATA_VALIDATE=$(type -P true) \
+ ${myconf}
}
src_install() {