summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2012-11-24 19:22:23 -0500
committerAlexandre Rostovtsev <tetromino@gentoo.org>2012-11-24 19:22:23 -0500
commitd059e67eb3cf731d78b6ca5907661bc90991a3f8 (patch)
tree6f8a633b5bbdb9be54dcd13f22823ebe9eb19859 /x11-terms
parentgnome-base/gnome-menus: correctly load custom menus from "applications-merged" (diff)
downloadgnome-d059e67eb3cf731d78b6ca5907661bc90991a3f8.tar.gz
gnome-d059e67eb3cf731d78b6ca5907661bc90991a3f8.tar.bz2
gnome-d059e67eb3cf731d78b6ca5907661bc90991a3f8.zip
x11-terms/gnome-terminal: don't use login shell by default (#442062)
Stop defaulting to enable login shell as it causes problems (#442062 by Juergen Rose), with this we revert to upstream (and most distributions) default setting.
Diffstat (limited to 'x11-terms')
-rw-r--r--x11-terms/gnome-terminal/files/gnome-terminal-2.22.0-default_shell.patch11
-rw-r--r--x11-terms/gnome-terminal/files/gnome-terminal-3.7.0-default_shell.patch13
-rw-r--r--x11-terms/gnome-terminal/gnome-terminal-3.6.1-r1.ebuild (renamed from x11-terms/gnome-terminal/gnome-terminal-3.6.1.ebuild)18
-rw-r--r--x11-terms/gnome-terminal/gnome-terminal-9999.ebuild19
4 files changed, 23 insertions, 38 deletions
diff --git a/x11-terms/gnome-terminal/files/gnome-terminal-2.22.0-default_shell.patch b/x11-terms/gnome-terminal/files/gnome-terminal-2.22.0-default_shell.patch
deleted file mode 100644
index 84bac04f..00000000
--- a/x11-terms/gnome-terminal/files/gnome-terminal-2.22.0-default_shell.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/gnome-terminal.schemas.in 2003-02-21 20:06:56.000000000 -0600
-+++ src/gnome-terminal.schemas.in 2003-02-21 20:07:13.000000000 -0600
-@@ -341,7 +341,7 @@
- <applyto>/apps/gnome-terminal/profiles/Default/login_shell</applyto>
- <owner>gnome-terminal</owner>
- <type>bool</type>
-- <default>false</default>
-+ <default>true</default>
- <locale name="C">
- <short>Whether to launch the command in the terminal as a login shell</short>
- <long>
diff --git a/x11-terms/gnome-terminal/files/gnome-terminal-3.7.0-default_shell.patch b/x11-terms/gnome-terminal/files/gnome-terminal-3.7.0-default_shell.patch
deleted file mode 100644
index 92924f66..00000000
--- a/x11-terms/gnome-terminal/files/gnome-terminal-3.7.0-default_shell.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/src/org.gnome.Terminal.Preferences.gschema.xml.in b/src/org.gnome.Terminal.Preferences.gschema.xml.in
-index 6d28344..1a94921 100644
---- a/src/org.gnome.Terminal.Preferences.gschema.xml.in
-+++ b/src/org.gnome.Terminal.Preferences.gschema.xml.in
-@@ -169,7 +169,7 @@
- <_description>Possible values are "close" to close the terminal, and "restart" to restart the command.</_description>
- </key>
- <key name="login-shell" type="b">
-- <default>false</default>
-+ <default>true</default>
- <_summary>Whether to launch the command in the terminal as a login shell</_summary>
- <_description>If true, the command inside the terminal will be launched as a login shell. (argv[0] will have a hyphen in front of it.)</_description>
- </key>
diff --git a/x11-terms/gnome-terminal/gnome-terminal-3.6.1.ebuild b/x11-terms/gnome-terminal/gnome-terminal-3.6.1-r1.ebuild
index a0a85df2..347f54de 100644
--- a/x11-terms/gnome-terminal/gnome-terminal-3.6.1.ebuild
+++ b/x11-terms/gnome-terminal/gnome-terminal-3.6.1-r1.ebuild
@@ -5,10 +5,7 @@
EAPI="4"
GCONF_DEBUG="no"
-inherit eutils gnome2
-if [[ ${PV} = 9999 ]]; then
- inherit gnome2-live
-fi
+inherit gnome2
DESCRIPTION="The Gnome Terminal"
HOMEPAGE="http://www.gnome.org/"
@@ -40,8 +37,15 @@ src_prepare() {
# switch and not from GDK_TARGET, bug #363033
G2CONF="${G2CONF} --with-gtk=3.0"
- # Use login shell by default (#12900)
- epatch "${FILESDIR}"/${PN}-2.22.0-default_shell.patch
-
gnome2_src_prepare
}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ if [[ ${REPLACING_VERSIONS} < 3.6.1-r1 && ${REPLACING_VERSIONS} != 2.32.1-r1 &&
+ ${REPLACING_VERSIONS} != 3.4.1.1-r1 ]]; then
+ elog "Gnome Terminal no longer uses login shell by default, switching"
+ elog "to upstream default. Because of this, if you have some command you"
+ elog "want to be run, be sure to have it placed in your ~/.bashrc file."
+ fi
+}
diff --git a/x11-terms/gnome-terminal/gnome-terminal-9999.ebuild b/x11-terms/gnome-terminal/gnome-terminal-9999.ebuild
index 605e9e86..9d43bb73 100644
--- a/x11-terms/gnome-terminal/gnome-terminal-9999.ebuild
+++ b/x11-terms/gnome-terminal/gnome-terminal-9999.ebuild
@@ -5,7 +5,7 @@
EAPI="4"
GCONF_DEBUG="no"
-inherit eutils gnome2
+inherit gnome2
if [[ ${PV} = 9999 ]]; then
inherit gnome2-live
fi
@@ -40,15 +40,20 @@ DEPEND="${RDEPEND}
sys-devel/gettext
virtual/pkgconfig"
-pkg_setup() {
+src_prepare() {
DOCS="AUTHORS ChangeLog HACKING NEWS README"
G2CONF="${G2CONF}
$(use_with nautilus nautilus-extension)"
-}
-
-src_prepare() {
- # Use login shell by default (#12900)
- epatch "${FILESDIR}"/${PN}-3.7.0-default_shell.patch
gnome2_src_prepare
}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ if [[ ${REPLACING_VERSIONS} < 3.6.1-r1 && ${REPLACING_VERSIONS} != 2.32.1-r1 &&
+ ${REPLACING_VERSIONS} != 3.4.1.1-r1 ]]; then
+ elog "Gnome Terminal no longer uses login shell by default, switching"
+ elog "to upstream default. Because of this, if you have some command you"
+ elog "want to be run, be sure to have it placed in your ~/.bashrc file."
+ fi
+}