summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2015-05-10 17:59:34 +0200
committerGilles Dartiguelongue <eva@gentoo.org>2015-05-10 18:09:39 +0200
commit634ba168b14242bb5db4f8f883018cf5b734f978 (patch)
treeaee53b155df85a2b0dac7adbf92872ef420e8e40 /x11-themes
parentdev-libs/libpeas: 1.12.1-r1 → 1.14.0 (diff)
downloadgnome-634ba168b14242bb5db4f8f883018cf5b734f978.tar.gz
gnome-634ba168b14242bb5db4f8f883018cf5b734f978.tar.bz2
gnome-634ba168b14242bb5db4f8f883018cf5b734f978.zip
x11-themes/adwaita-icon-theme: 3.14.1-r1 → 3.16.0
Diffstat (limited to 'x11-themes')
-rw-r--r--x11-themes/adwaita-icon-theme/Manifest12
-rw-r--r--x11-themes/adwaita-icon-theme/adwaita-icon-theme-3.16.0.ebuild74
2 files changed, 86 insertions, 0 deletions
diff --git a/x11-themes/adwaita-icon-theme/Manifest b/x11-themes/adwaita-icon-theme/Manifest
new file mode 100644
index 00000000..4fa7f1bc
--- /dev/null
+++ b/x11-themes/adwaita-icon-theme/Manifest
@@ -0,0 +1,12 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA512
+
+DIST adwaita-icon-theme-3.16.0.tar.xz 18547936 SHA256 a3c8ad3b099ca571b423811a20ee9a7a43498cfa04d299719ee43cd7af6f6eb1 SHA512 5c74e14d56101cdd281191caba928016a5d62e1f554d5da95a84349ac4ab85f7cb76cc658f05bd70e4891d68b3a98ab5b157bc85e5918ceecf3f2f653784c815 WHIRLPOOL e333b228e131099704765226a74925e9f0e73b1d33bc750652bc939ceba2720c9b090e6e89d15ba75f83e5f393eeb510a02b2d369209b8a41ceff7a564623714
+DIST tango-gentoo-v1.1.tar.gz 29322 SHA256 518efa4257c8e689488399db23397a89f4dcd5990ce537ef6215860ad5606eb0 SHA512 87d47ddab68361db6d99866c51705dcb3e198f8345a1096859acf2c6cca5099dd23c7fb30d124f52c4933ea38fd45fadffbbe6ecbdfa84f5b60938a4824f9045 WHIRLPOOL 9e1635a505ea48f4fe8bdb3b8b3b43cfb9cf99e3204194c51361b198886e719921cfacbc15f9f6407aa7d0c4af178e24c74b998fc370fa2329040e5be1baf153
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2
+
+iEYEAREKAAYFAlVPgGYACgkQ1fmVwcYIWAaWWQCgyKJVvwhWUQEOA1UxyIb7tVLO
+2tUAnRXKDsdT3n9w5enQYC86kCyLrdan
+=u0Ox
+-----END PGP SIGNATURE-----
diff --git a/x11-themes/adwaita-icon-theme/adwaita-icon-theme-3.16.0.ebuild b/x11-themes/adwaita-icon-theme/adwaita-icon-theme-3.16.0.ebuild
new file mode 100644
index 00000000..2242d69e
--- /dev/null
+++ b/x11-themes/adwaita-icon-theme/adwaita-icon-theme-3.16.0.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="5"
+GCONF_DEBUG="no"
+
+inherit gnome2 versionator
+
+DESCRIPTION="GNOME default icon theme"
+HOMEPAGE="http://www.gnome.org/ http://people.freedesktop.org/~jimmac/icons/#git"
+
+SRC_URI="${SRC_URI}
+ branding? ( http://www.mail-archive.com/tango-artists@lists.freedesktop.org/msg00043/tango-gentoo-v1.1.tar.gz )"
+
+LICENSE="|| ( LGPL-3 CC-BY-SA-3.0 )
+ branding? ( CC-Sampling-Plus-1.0 )"
+SLOT="0"
+IUSE="branding"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~sparc-solaris ~x64-solaris ~x86-solaris"
+
+COMMON_DEPEND="
+ >=x11-themes/hicolor-icon-theme-0.10
+"
+RDEPEND="${COMMON_DEPEND}
+ gnome-base/librsvg:2
+ !<x11-themes/gnome-themes-standard-3.14
+"
+DEPEND="${COMMON_DEPEND}
+ >=x11-misc/icon-naming-utils-0.8.7
+ >=dev-util/intltool-0.40
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+# This ebuild does not install any binaries
+RESTRICT="binchecks strip"
+
+src_prepare() {
+ if use branding; then
+ for i in 16 22 24 32 48; do
+ cp "${WORKDIR}"/tango-gentoo-v1.1/${i}x${i}/gentoo.png \
+ "${S}"/Adwaita/${i}x${i}/places/start-here.png \
+ || die "Copying gentoo logos failed"
+ done
+ fi
+
+ # Install cursors in the right place
+ sed -e 's:^\(cursordir.*\)icons\(.*\):\1cursors/xorg-x11\2:' \
+ -i "${S}"/Makefile.am \
+ -i "${S}"/Makefile.in || die
+
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure GTK_UPDATE_ICON_CACHE=$(type -P true)
+}
+
+src_install() {
+ gnome2_src_install
+ # Buggy directory due to drop of intltool usage
+ rm -rf ${D}/usr/locale
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ elog "$PF no longer installs the"
+ elog "/usr/share/cursors/xorg-x11/default symlink. Instead, desktop"
+ elog "environments are expected to set the cursor theme using the"
+ elog "XCURSOR_THEME environment variable or other means."
+ elog "If you are seeing old-style X11 cursors in GNOME or Cinnamon,"
+ elog "make sure you have >=gnome-base/gnome-session-3.14.0-r2"
+ elog "and then log out and log in again."
+}