summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2008-07-02 07:55:54 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2008-07-02 07:55:54 +0000
commitc1efc73aa2030979b00f37dc6a2a49a42caca480 (patch)
treee40910de22c1bb6e54ad3c9066ea7392458110d2 /gnustep-apps/sogo/sogo-1.0_rc6.ebuild
parentInit script, installation instructions (diff)
downloadgnustep-c1efc73aa2030979b00f37dc6a2a49a42caca480.tar.gz
gnustep-c1efc73aa2030979b00f37dc6a2a49a42caca480.tar.bz2
gnustep-c1efc73aa2030979b00f37dc6a2a49a42caca480.zip
USE EAPI=1 for sope to enable postgres by default
Check that sope was built with USE=postrgres in sogo svn path=/overlay/; revision=371
Diffstat (limited to 'gnustep-apps/sogo/sogo-1.0_rc6.ebuild')
-rw-r--r--gnustep-apps/sogo/sogo-1.0_rc6.ebuild10
1 files changed, 10 insertions, 0 deletions
diff --git a/gnustep-apps/sogo/sogo-1.0_rc6.ebuild b/gnustep-apps/sogo/sogo-1.0_rc6.ebuild
index 8beb987..678cd02 100644
--- a/gnustep-apps/sogo/sogo-1.0_rc6.ebuild
+++ b/gnustep-apps/sogo/sogo-1.0_rc6.ebuild
@@ -22,6 +22,16 @@ need_apache2
S=${WORKDIR}/${MY_PN}
+pkg_setup() {
+ gnustep-base_pkg_setup
+
+ if ! built_with_use gnustep-libs/sope postgres; then
+ eerror "SOGo needs gnustep-libs/sope with USE=postgres enabled"
+ die "gnustep-libs/sope compiled without USE=postgres"
+ fi
+}
+
+
src_unpack() {
gnustep-base_src_unpack