summaryrefslogtreecommitdiff
path: root/eclass
diff options
context:
space:
mode:
Diffstat (limited to 'eclass')
-rw-r--r--eclass/gnustep-2.eclass23
-rw-r--r--eclass/gnustep-base.eclass240
2 files changed, 263 insertions, 0 deletions
diff --git a/eclass/gnustep-2.eclass b/eclass/gnustep-2.eclass
new file mode 100644
index 0000000..f3b9fea
--- /dev/null
+++ b/eclass/gnustep-2.eclass
@@ -0,0 +1,23 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/eclass/gnustep-2.eclass,v 1.4 2009/11/25 10:11:40 voyageur Exp $
+
+inherit gnustep-base
+
+# Eclass for GNUstep Apps, Frameworks, and Bundles build
+# EAPI >= 2 only
+#
+# maintainer: GNUstep Herd <gnustep@gentoo.org>
+
+DEPEND=">=gnustep-base/gnustep-make-2.4.0[fhs?]
+ virtual/gnustep-back"
+RDEPEND="${DEPEND}
+ debug? ( >=sys-devel/gdb-6.0 )"
+
+# The following gnustep-based EXPORT_FUNCTIONS are available:
+# * gnustep-base_pkg_setup
+# * gnustep-base_src_prepare
+# * gnustep-base_src_configure
+# * gnustep-base_src_compile
+# * gnustep-base_src_install
+# * gnustep-base_pkg_postinst
diff --git a/eclass/gnustep-base.eclass b/eclass/gnustep-base.eclass
new file mode 100644
index 0000000..e1c029d
--- /dev/null
+++ b/eclass/gnustep-base.eclass
@@ -0,0 +1,240 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/eclass/gnustep-base.eclass,v 1.15 2010/03/10 13:19:06 voyageur Exp $
+
+inherit eutils flag-o-matic
+
+# Inner gnustep eclass, should only be inherited directly by gnustep-base
+# packages
+# EAPI >= 2 only
+#
+# maintainer: GNUstep Herd <gnustep@gentoo.org>
+
+# IUSE variables across all GNUstep packages
+# "debug": enable code for debugging
+# "doc": build and install documentation, if available
+# "fhs": use FHS layout
+IUSE="debug doc +fhs"
+
+# packages needed to build any base gnustep package
+GNUSTEP_CORE_DEPEND="doc? ( virtual/texi2dvi dev-tex/latex2html app-text/texi2html )"
+
+# Where to install GNUstep (with old layout)
+GNUSTEP_PREFIX="${EPREFIX}/usr/GNUstep"
+
+# GNUstep environment array
+typeset -a GS_ENV
+
+# Ebuild function overrides
+gnustep-base_pkg_setup() {
+ if test_version_info 3.3 ; then
+ strip-unsupported-flags
+ elif test_version_info 3.4 ; then
+ # strict-aliasing is known to break obj-c stuff in gcc-3.4*
+ filter-flags -fstrict-aliasing
+ fi
+
+ # known to break ObjC (bug 86089)
+ filter-flags -fomit-frame-pointer
+}
+
+gnustep-base_src_prepare() {
+ if [[ -f ./GNUmakefile ]] ; then
+ # Kill stupid includes that are simply overdone or useless on normal
+ # Gentoo, but (may) cause major headaches on Prefixed Gentoo. If this
+ # only removes a part of a path it's good that it bails out, as we want
+ # to know when they use some direct include.
+ ebegin "Cleaning paths from GNUmakefile"
+ sed -i \
+ -e 's|-I/usr/X11R6/include||g' \
+ -e 's|-I/usr/include||g' \
+ -e 's|-L/usr/X11R6/lib||g' \
+ -e 's|-L/usr/lib||g' \
+ GNUmakefile
+ eend $?
+ fi
+}
+
+gnustep-base_src_configure() {
+ egnustep_env
+ if [[ -x ./configure ]] ; then
+ econf || die "configure failed"
+ fi
+}
+
+gnustep-base_src_compile() {
+ egnustep_env
+ egnustep_make
+}
+
+gnustep-base_src_install() {
+ egnustep_env
+ egnustep_install
+ if use doc ; then
+ egnustep_env
+ egnustep_doc
+ fi
+ egnustep_install_config
+}
+
+gnustep-base_pkg_postinst() {
+ [[ $(type -t gnustep_config_script) != "function" ]] && return 0
+
+ local SCRIPT_PATH
+ if use fhs; then
+ SCRIPT_PATH="/usr/bin"
+ else
+ SCRIPT_PATH=${GNUSTEP_SYSTEM_TOOLS}/Gentoo
+ fi
+ elog "To use this package, as *user* you should run:"
+ elog " ${SCRIPT_PATH}/config-${PN}.sh"
+}
+
+# Clean/reset an ebuild to the installed GNUstep environment
+egnustep_env() {
+ # Makefiles path
+ local GS_MAKEFILES
+ if use fhs; then
+ GS_MAKEFILES=${EPREFIX}/usr/share/GNUstep/Makefiles
+ else
+ GS_MAKEFILES=${GNUSTEP_PREFIX}/System/Library/Makefiles
+ fi
+ # Get additional variables
+ GNUSTEP_SH_EXPORT_ALL_VARIABLES="true"
+
+ if [[ -f ${GS_MAKEFILES}/GNUstep.sh ]] ; then
+ # Reset GNUstep variables
+ source "${GS_MAKEFILES}"/GNUstep-reset.sh
+ source "${GS_MAKEFILES}"/GNUstep.sh
+
+ # Needed to run installed GNUstep apps in sandbox
+ addpredict "/root/GNUstep"
+
+ if ! use fhs; then
+ # Set rpath in ldflags when available
+ case ${CHOST} in
+ *-linux-gnu|*-solaris*)
+ is-ldflagq -Wl,-rpath="${GNUSTEP_SYSTEM_LIBRARIES}" \
+ || append-ldflags \
+ -Wl,-rpath="${GNUSTEP_SYSTEM_LIBRARIES}"
+ ;;
+ esac
+ fi
+
+ # Set up env vars for make operations
+ GS_ENV=( AUXILIARY_LDFLAGS="${LDFLAGS}" \
+ ADDITIONAL_NATIVE_LIB_DIRS="${GNUSTEP_SYSTEM_LIBRARIES}" \
+ DESTDIR="${D}" \
+ HOME="${T}" \
+ GNUSTEP_USER_DIR="${T}" \
+ GNUSTEP_USER_DEFAULTS_DIR="${T}"/Defaults \
+ GNUSTEP_INSTALLATION_DOMAIN=SYSTEM \
+ TAR_OPTIONS="${TAR_OPTIONS} --no-same-owner" \
+ messages=yes )
+
+ # Parallel-make support was added in gnustep-make 2.2.0
+ has_version "<gnustep-base/gnustep-make-2.2.0" \
+ && GS_ENV=( "${GS_ENV[@]}" "-j1" )
+
+ use debug \
+ && GS_ENV=( "${GS_ENV[@]}" "debug=yes" ) \
+ || GS_ENV=( "${GS_ENV[@]}" "debug=no" )
+
+ return 0
+ fi
+ die "gnustep-make not installed!"
+}
+
+# Make utilizing GNUstep Makefiles
+egnustep_make() {
+ if [[ -f ./Makefile || -f ./makefile || -f ./GNUmakefile ]] ; then
+ emake ${*} "${GS_ENV[@]}" all || die "package make failed"
+ return 0
+ fi
+ die "no Makefile found"
+}
+
+# Make-install utilizing GNUstep Makefiles
+egnustep_install() {
+ if ! use fhs; then
+ # avoid problems due to our "weird" prefix, make sure it exists
+ mkdir -p "${D}"${GNUSTEP_SYSTEM_TOOLS}
+ fi
+ if [[ -f ./[mM]akefile || -f ./GNUmakefile ]] ; then
+ emake ${*} "${GS_ENV[@]}" install || die "package install failed"
+ return 0
+ fi
+ die "no Makefile found"
+}
+
+# Make and install docs using GNUstep Makefiles
+egnustep_doc() {
+ if [[ -d ./Documentation ]] ; then
+ # Check documentation presence
+ cd "${S}"/Documentation
+ if [[ -f ./[mM]akefile || -f ./GNUmakefile ]] ; then
+ emake "${GS_ENV[@]}" all || die "doc make failed"
+ emake "${GS_ENV[@]}" install || die "doc install failed"
+ fi
+ cd ..
+ fi
+}
+
+egnustep_install_config() {
+ [[ $(type -t gnustep_config_script) != "function" ]] && return 0
+
+ local cfile=config-${PN}.sh
+
+ cat << 'EOF' > "${T}"/${cfile}
+#!/usr/bin/env bash
+gnustep_append_default() {
+ if [[ -z $1 || -z $2 || -z $3 ]]; then
+ echo "warning: invalid script invocation"
+ return
+ fi
+ dom=$1
+ key=$2
+ val=$3
+ cur=$(defaults read ${dom} ${key}) 2> /dev/null
+ if [[ -z $cur ]] ; then
+ echo " * setting ${dom} ${key}"
+ defaults write ${dom} ${key} "( ${val} )"
+ elif [[ ${cur} != *${val}* ]] ; then
+ echo " * adding ${val} to ${dom} ${key}"
+ echo "${cur%)\'}, \"${val}\" )'" | defaults write
+ else
+ echo " * ${val} already present in ${dom} ${key}"
+ fi
+}
+
+gnustep_set_default() {
+ if [[ -z $1 || -z $2 || -z $3 ]]; then
+ echo "warning: invalid script invocation"
+ return
+ fi
+ dom=$1
+ key=$2
+ val=$3
+ echo " * setting ${dom} ${key}"
+ defaults write ${dom} ${key} ${val}
+}
+
+EOF
+
+ echo "echo \"Applying ${P} default configuration ...\"" >> "${T}"/${cfile}
+
+ gnustep_config_script | \
+ while read line ; do
+ echo "${line}" >> "${T}"/${cfile}
+ done
+ echo 'echo "done"' >> "${T}"/${cfile}
+
+ if use fhs; then
+ exeinto /usr/bin
+ else
+ exeinto ${GNUSTEP_SYSTEM_TOOLS#${EPREFIX}}/Gentoo
+ fi
+ doexe "${T}"/${cfile}
+}
+
+EXPORT_FUNCTIONS pkg_setup src_prepare src_configure src_compile src_install pkg_postinst